jobcore/texinfo/PKGBUILD

55 lines
1.7 KiB
Bash

#!/usr/bin/bash
# JOBoRun : Jwm OpenBox Obarun RUNit
# Maintainer : Joe Bo Run <joborun@disroot.org>
# PkgSource : url="https://gittea.disroot.org/joborun-pkg/jobcore/$pkgname"
# Website : https://pozol.eu
#-----------------------------------------| DESCRIPTION |---------------------------------------
pkgname=texinfo
pkgver=7.1
pkgrel=02
pkgdesc='GNU documentation system for on-line information and printed output'
url='https://www.gnu.org/software/texinfo/'
groups=( jobbot )
depends=(ncurses gzip perl sh)
optdepends=('perl-archive-zip: EPUB file output via texi2any')
source=(https://ftp.gnu.org/pub/gnu/$pkgname/$pkgname-$pkgver.tar.xz{,.sig}
texinfo-install.hook
texinfo-remove.hook)
#prepare() {
# patch -d $pkgname-$pkgver -p1 < texinfo-pt-br-crash.patch # Avoid info crash for Brazillian Portuguese
#}
build() {
cd $pkgname-$pkgver
./configure --prefix=/usr
make
}
check() {
make -C $pkgname-$pkgver check
}
package() {
make -C $pkgname-$pkgver DESTDIR="$pkgdir" install
install -dm755 "$pkgdir"/usr/share/libalpm/hooks/
install -m644 texinfo-{install,remove}.hook "$pkgdir"/usr/share/libalpm/hooks/
}
#---- arch license gpg-key & sha256sums ----
arch=(x86_64)
license=(GPL3)
validpgpkeys=('EAF669B31E31E1DECBD11513DDBC579DAB37FBA9') # Gavin Smith
sha256sums=(deeec9f19f159e046fdf8ad22231981806dac332cc372f1c763504ad82b30953 # texinfo-7.1.tar.xz
61f3eb6f70eac86087965f7a8f20d379119f909b6d9013896938770545f5ad3b # texinfo-7.1.tar.xz.sig
beb0ff50bd8e8ca1d6e1c01e6a50352f9d25937c62822cf767a7b3d8f7374a9d # texinfo-install.hook
913ca8aac84386399b0a83ed0f6b04b5e6322da62f5c1d7ed31e1050ed37c1a9) # texinfo-remove.hook
## 3ac768e0e7887741be9b259a4c09ee26801ba9812855c7d76d2ff1df66bfcff0 texinfo-7.1-02-x86_64.pkg.tar.lz