jobcore/unixodbc/PKGBUILD

44 lines
1.3 KiB
Bash

#!/usr/bin/bash
# JOBoRun : Jwm OpenBox Obarun RUNit
# Maintainer : Joe Bo Run <joborun@disroot.org>
# PkgSource : url="https://gittea.disroot.org/joborun-pkg/jobcore/$pkgname"
# Website : https://pozol.eu
#-----------------------------------------| DESCRIPTION |---------------------------------------
pkgname=unixodbc
pkgver=2.3.12
pkgrel=01
pkgdesc="ODBC is an open specification for providing application developers with a predictable API with which to access Data Sources"
url="http://www.unixodbc.org/"
backup=('etc/odbc.ini' 'etc/odbcinst.ini')
depends=('readline' 'libltdl' 'glibc')
source=(ftp://ftp.unixodbc.org/pub/unixODBC/unixODBC-$pkgver.tar.gz)
build() {
cd unixODBC-${pkgver}
./configure --prefix=/usr --sysconfdir=/etc
sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
make
}
check() {
cd unixODBC-${pkgver}
make -k check
}
package() {
cd unixODBC-${pkgver}
make DESTDIR="${pkgdir}" install
touch "$pkgdir"/etc/{odbc,odbcinst}.ini
}
#---- arch license gpg-key & sha256sums ----
arch=(x86_64)
license=('GPL2' 'LGPL2.1')
sha256sums=(f210501445ce21bf607ba51ef8c125e10e22dffdffec377646462df5f01915ec) # unixODBC-2.3.12.tar.gz
## 989d92eaf5c17c6d1a05a4e465f688a992f5a8dcb736cec5976315f5e0dd3da9 unixodbc-2.3.12-01-x86_64.pkg.tar.lz