jobextra/cmake/PKGBUILD

77 lines
3.1 KiB
Bash

#!/usr/bin/bash
# JOBoRun : Jwm OpenBox Obarun RUNit
# Maintainer : Joe Bo Run <joborun@disroot.org>
# PkgSource : url="https://gittea.disroot.org/joborun-pkg/jobextra/$pkgname"
# Website : https://pozol.eu
#-----------------------------------------| DESCRIPTION |---------------------------------------
pkgname=cmake
pkgver=3.29.2
pkgrel=01
pkgdesc='A cross-platform open-source make system w/o zstd or qt-gui '
url="https://www.cmake.org/"
depends=('curl' 'libarchive' 'hicolor-icon-theme' 'jsoncpp' 'libuv' 'rhash' 'cppdap')
## makedepends=('python-sphinx' 'emacs-git' 'python-sphinx-autoapi' 'nlohmann-json') # without autoapi build fails at sphinx html documents
makedepends=('emacs-git' 'nlohmann-json') # without autoapi build fails at sphinx html documents
optdepends=('make: for unix Makefile generator'
'ninja: for ninja generator')
source=("https://www.cmake.org/files/v${pkgver%.*}/${pkgname}-${pkgver}.tar.gz"
"https://www.cmake.org/files/v${pkgver%.*}/${pkgname}-${pkgver}-SHA-256.txt"{,.asc})
prepare() {
# upstream does not provide signed tarballs, only signed checksums
sha256sum -c --ignore-missing "${pkgname}-${pkgver}-SHA-256.txt"
}
build() {
cd ${pkgname}-${pkgver}
./bootstrap --prefix=/usr \
--mandir=/share/man \
--docdir=/share/doc/cmake \
--datadir=/share/cmake \
--no-system-zstd \
--no-qt-gui \
--system-libs \
--parallel=$(/usr/bin/getconf _NPROCESSORS_ONLN)
make
## --no-system-liblzma \
## used temporarily while xz/lzma situation was unclear on 3.29.0-02
}
# --sphinx-man \ I removed this to avoid error at sphinx html docs
# export CXXFLAGS+=" ${CPPFLAGS}" # used in the past
# --qt-gui \ # qt6-base dependency is needed for the gui
# --sphinx-html \ Build stops unable to find sphinx module to build html docs
# it still fails and there are no valid options for --no-sphinx-html ..
package() {
cd ${pkgname}-${pkgver}
make DESTDIR="${pkgdir}" install
# rm -r "$pkgdir"/usr/share/doc/cmake/html/_sources
emacs -batch -f batch-byte-compile "${pkgdir}"/usr/share/emacs/site-lisp/cmake-mode.el
install -Dm644 Copyright.txt "${pkgdir}"/usr/share/licenses/${pkgname}/LICENSE
}
#---- arch license gpg-key & sha256sums ----
arch=(x86_64)
license=('custom')
validpgpkeys=(CBA23971357C2E6590D9EFD3EC8FEF3A7BFB4EDA) # Brad King <brad.king@kitware.com>
sha512sums=('0dad9e0e3ad9c1178d337cd3a14e9ce145e011175e9d9fce4961d12b8fe37091f9fdf05f4303cdd846408955b11bac3cfe5064f852833b99e31f5a7b82a9d1eb'
'e6483779cb5f6966bbfa36bc483a78ea89a0a149d6bbf1987b5ba25e4f745b1dea17fde7217ce03636a525888283eb35b6f211a1c6f74512ee096599e7180051'
'SKIP')
sha256sums=(36db4b6926aab741ba6e4b2ea2d99c9193222132308b4dc824d4123cb730352e # cmake-3.29.2.tar.gz
a7a73522a47455dd6066b6c393216facfe06d49b34bb8dae1195c74c47f79ee5 # cmake-3.29.2-SHA-256.txt
1f12488ef66df344efb42dd97bb160cb64cd94bd2f341f3bf2eb2adc684a4b04) # cmake-3.29.2-SHA-256.txt.asc
## grep cmake-3.29.2.tar.gz cmake*txt
## 36db4b6926aab741ba6e4b2ea2d99c9193222132308b4dc824d4123cb730352e cmake-3.29.2.tar.gz
## 283dac259c274961b337dc5ec58bc8dfc4213037cbbae187f82846cdbb91b00b cmake-3.29.2-01-x86_64.pkg.tar.lz