jobextra/enchant/PKGBUILD

58 lines
1.7 KiB
Bash

#!/usr/bin/bash
# JOBoRun : Jwm OpenBox Obarun RUNit
# Maintainer : Joe Bo Run <joborun@disroot.org>
# PkgSource : url="https://gittea.disroot.org/joborun-pkg/jobextra/$pkgname"
# Website : https://pozol.eu
#-----------------------------------------| DESCRIPTION |---------------------------------------
pkgname=enchant
pkgver=2.6.5
pkgrel=01
pkgdesc="A wrapper library for generic spell checking"
url="https://abiword.github.io/enchant/"
depends=('glib2')
makedepends=('aspell' 'hunspell' 'hspell' 'nuspell' 'libvoikko')
checkdepends=('unittestpp')
optdepends=('aspell: for aspell based spell checking support'
'hunspell: for hunspell based spell checking support'
'libvoikko: for libvoikko based spell checking support'
'hspell: for hspell based spell checking support'
'nuspell: for nuspell based spell checking support')
provides=('libenchant-2.so') # enchant_voikko.so enchant_nuspell.so enchant_hunspell.so enchant_hspell.so enchant_aspell.so)
source=("https://github.com/AbiWord/enchant/releases/download/v$pkgver/enchant-$pkgver.tar.gz")
prepare() {
cd $pkgname-$pkgver
autoreconf -vfi
}
build() {
cd $pkgname-$pkgver
./configure --prefix=/usr \
--disable-static \
--enable-relocatable
sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
make
}
check() {
cd $pkgname-$pkgver
make check
}
package() {
cd $pkgname-$pkgver
make DESTDIR="$pkgdir" install
}
#---- arch license gpg-key & sha256sums ----
arch=(x86_64)
license=(LGPL)
sha256sums=(9e8fd28cb65a7b6da3545878a5c2f52a15f03c04933a5ff48db89fe86845728e) # enchant-2.6.5.tar.gz
## 466dd245c58a6bd22e20d32c8bfdf1769edbb1b8ac25d52e3c0958afd60b56af enchant-2.6.5-01-x86_64.pkg.tar.lz