jobextra/fluidsynth/PKGBUILD

69 lines
2.5 KiB
Bash

#!/usr/bin/bash
# JOBoRun : Jwm OpenBox Obarun RUNit
# Maintainer : Joe Bo Run <joborun@disroot.org>
# PkgSource : url="https://gittea.disroot.org/joborun-pkg/jobextra/$pkgname"
# Website : https://pozol.eu
#-----------------------------------------| DESCRIPTION |---------------------------------------
pkgname=fluidsynth
pkgver=2.3.5
pkgrel=01
pkgdesc="A real-time software synthesizer based on the SoundFont 2 specifications w/o systemd"
url="https://www.fluidsynth.org/"
groups=(pro-audio)
depends=(glibc sdl2 gcc-libs)
makedepends=(alsa-lib cmake dbus doxygen glib2 jack ladspa libinstpatch
libpulse libpipewire libsndfile portaudio readline )
provides=(libfluidsynth.so soundfont-synthesizer)
backup=(etc/conf.d/$pkgname)
# options=(debug) ## uncomment this to produce the debug package for fluidsynth
source=($pkgname-$pkgver.tar.gz::https://github.com/$pkgname/$pkgname/archive/v$pkgver.tar.gz)
install="$pkgname.install"
#prepare() {
# # remove sandboxing options only available to systemd system services: https://github.com/FluidSynth/fluidsynth/issues/1147
# patch -Np1 -d $pkgname-$pkgver -i ../$pkgname-2.2.9-user_service_hardening.patch
#}
build() {
cmake -DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_BUILD_TYPE=None \
-DFLUID_DAEMON_ENV_FILE=/etc/conf.d/fluidsynth \
-Denable-ladspa=ON \
-Denable-portaudio=ON \
-DLIB_SUFFIX="" \
-Wno-dev \
-B build \
-S $pkgname-$pkgver
make -C build VERBOSE=1
}
check() {
make check -k -C build
}
package() {
depends+=(alsa-lib libasound.so dbus libdbus-1.so glib2 libglib-2.0.so libgmodule-2.0.so libgobject-2.0.so
jack libjack.so libinstpatch libinstpatch-1.0.so libpipewire libpipewire-0.3.so libpulse libpulse-simple.so
libsndfile libsndfile.so portaudio libportaudio.so readline libreadline.so)
make -C build DESTDIR="$pkgdir" install
# systemd user unit
# install -vDm 644 build/$pkgname.service -t "$pkgdir/usr/lib/systemd/user/"
# system-wide configuration file
install -vDm 644 build/$pkgname.conf "$pkgdir/etc/conf.d/$pkgname"
# docs
install -vDm 644 $pkgname-$pkgver/{AUTHORS,ChangeLog,{CONTRIBUTING,README}.md,THANKS,TODO} -t "$pkgdir/usr/share/doc/$pkgname/"
}
#---- arch license gpg-key & sha256sums ----
arch=(x86_64)
license=(LGPL-2.1-or-later)
sha256sums=(f89e8e983ecfb4a5b4f5d8c2b9157ed18d15ed2e36246fa782f18abaea550e0d) # fluidsynth-2.3.5.tar.gz
## dcea65968a38f96f93e7bc359120dfa308fee45ac4452d3c952fd2052508d709 fluidsynth-2.3.5-01-x86_64.pkg.tar.lz