jobextra/goffice/PKGBUILD

54 lines
1.5 KiB
Bash

#!/usr/bin/bash
# JOBoRun : Jwm OpenBox Obarun RUNit
# Maintainer : Joe Bo Run <joborun@disroot.org>
# PkgSource : url="https://gittea.disroot.org/joborun-pkg/jobextra/$pkgname"
# Website : https://pozol.eu
#-----------------------------------------| DESCRIPTION |---------------------------------------
pkgname=goffice
pkgver=0.10.57
pkgrel=01
pkgdesc="A GLib/GTK+ set of document-centric objects and charting library"
url="https://git.gnome.org/browse/goffice"
depends=(librsvg gtk3 libgsf libspectre libxslt lasem)
makedepends=(intltool gtk-doc gobject-introspection autoconf-archive git)
_commit=b00e60ef42100764e4fbf329cd36194389ed8dbb # tags/GOFFICE_0_10_57
source=("git+https://gitlab.gnome.org/GNOME/goffice.git#commit=$_commit")
#source=(https://download.gnome.org/sources/goffice/0.10/goffice-$pkgver.tar.xz)
#pkgver() {
# cd $pkgname
# git describe --tags | sed 's/^GOFFICE_//;s/_/./g;s/-/+/g'
#}
prepare() {
cd $pkgname
NOCONFIGURE=1 ./autogen.sh
}
build() {
cd $pkgname
./configure --prefix=/usr --sysconfdir=/etc \
--localstatedir=/var --disable-static --enable-introspection --enable-gtk-doc
sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
make
}
package() {
cd $pkgname
make DESTDIR="${pkgdir}" install
}
#---- arch license gpg-key & sha256sums ----
arch=(x86_64)
license=(GPL)
#sha256sums=(66bfd7e31d2f6756d5a62c3670383cbba02b3cb4c1042950192a801b72a3c9ab) # goffice-0.10.57.tar.xz
sha256sums=(SKIP)
## 666c39a9c00f7c8ab40dd7ef64388bee99a9e33f6c302d6d35d3431a66009b0b goffice-0.10.57-01-x86_64.pkg.tar.lz