jobextra/help2man/PKGBUILD

43 lines
1.1 KiB
Bash

#!/usr/bin/bash
# JOBoRun : Jwm OpenBox Obarun RUNit
# Maintainer : Joe Bo Run <joborun@disroot.org>
# PkgSource : url="https://gittea.disroot.org/joborun-pkg/jobextra/$pkgname"
# Website : https://pozol.eu
#-----------------------------------------| DESCRIPTION |---------------------------------------
pkgname=help2man
pkgver=1.49.3
pkgrel=01
pkgdesc="Conversion tool to create man files"
arch=('x86_64')
url="https://www.gnu.org/software/help2man/"
depends=('perl-locale-gettext')
source=("https://ftp.gnu.org/gnu/${pkgname}/${pkgname}-${pkgver}.tar.xz"{,.sig})
build() {
cd ${pkgname}-${pkgver}
./configure --prefix=/usr \
--mandir=/usr/share/man \
--infodir=/usr/share/info \
--libdir=/usr/lib
make
}
package() {
cd ${pkgname}-${pkgver}
make DESTDIR="${pkgdir}" install
}
#---- license gpg-key sha256sums ----
license=('GPL')
validpgpkeys=('87EA44D150D89615E39A3FEEF0DC8E00B28C5995') # Brendan O'Dea <bod@debian.org>
sha256sums=(4d7e4fdef2eca6afe07a2682151cea78781e0a4e8f9622142d9f70c083a2fd4f # help2man-1.49.3.tar.xz
d0ba9b2c9ccd73e476f7d949bd1e60e74e7a9e3fc8bece95b40b499f5e38b2b5) # help2man-1.49.3.tar.xz.sig