jobextra/hidapi/PKGBUILD

39 lines
1.3 KiB
Bash

#!/usr/bin/bash
# JOBoRun : Jwm OpenBox Obarun RUNit
# Maintainer : Joe Bo Run <joborun@disroot.org>
# PkgSource : url="https://gittea.disroot.org/joborun-pkg/jobextra/$pkgname"
# Website : https://pozol.eu
#-----------------------------------------| DESCRIPTION |---------------------------------------
pkgname=hidapi
pkgver=0.14.0
pkgrel=02
pkgdesc='Simple library for communicating with USB and Bluetooth HID devices w/o systemd'
url='https://github.com/libusb/hidapi'
depends=('libusb')
optdepends=('libusb: for hidapi-libusb')
makedepends=('cmake' 'libusb')
provides=('libhidapi-hidraw.so' 'libhidapi-libusb.so')
source=("https://github.com/libusb/${pkgname}/archive/${pkgname}-${pkgver}.tar.gz")
build() {
cmake -B build -S ${pkgname}-${pkgname}-${pkgver} -DCMAKE_INSTALL_PREFIX=/usr
cmake --build build
}
package() {
DESTDIR="${pkgdir}" cmake --install build
install -Dm0644 ${pkgname}-${pkgname}-${pkgver}/LICENSE*.txt -t "${pkgdir}/usr/share/licenses/${pkgname}/"
}
#---- arch license gpg-key & sha256sums ----
arch=(x86_64)
license=('GPL3' 'BSD' 'custom')
sha256sums=(a5714234abe6e1f53647dd8cba7d69f65f71c558b7896ed218864ffcf405bcbd) # hidapi-0.14.0.tar.gz
## 77cfcf8401eab3c83debb7a27b4a8cac0063e177a9921ce67b915ba6063cd0e1 hidapi-0.14.0-02-x86_64.pkg.tar.lz