jobextra/hwloc/PKGBUILD

50 lines
1.3 KiB
Bash

#!/usr/bin/bash
# JOBoRun : Jwm OpenBox Obarun RUNit
# Maintainer : Joe Bo Run <joborun@disroot.org>
# PkgSource : url="https://gittea.disroot.org/joborun-pkg/jobextra/$pkgname"
# Website : https://pozol.eu
#-----------------------------------------| DESCRIPTION |---------------------------------------
pkgname=hwloc
pkgver=2.10.0
pkgrel=01
pkgdesc='Portable Hardware Locality is a portable abstraction of hierarchical architectures'
url='https://www.open-mpi.org/projects/hwloc/'
depends=('glibc' 'libtool' 'libpciaccess')
makedepends=('cairo' 'libxml2' 'pciutils' 'libx11')
optdepends=('cairo' 'libxml2' 'pciutils' 'libx11')
#options=('!docs')
source=(https://www.open-mpi.org/software/hwloc/v${pkgver%.*}/downloads/${pkgname}-${pkgver}.tar.bz2)
build() {
cd hwloc-${pkgver}
./configure \
--prefix=/usr \
--sbindir=/usr/bin \
--enable-plugins \
--sysconfdir=/etc
make
}
check() {
cd hwloc-${pkgver}
make check
}
package() {
cd hwloc-${pkgver}
make DESTDIR="${pkgdir}" install
install -Dm 644 COPYING -t "${pkgdir}/usr/share/licenses/${pkgname}"
}
#---- arch license gpg-key & sha256sums ----
arch=(x86_64)
license=('BSD')
sha256sums=(0305dd60c9de2fbe6519fe2a4e8fdc6d3db8de574a0ca7812b92e80c05ae1392) # hwloc-2.10.0.tar.bz2
## 751f5942d492a274761510c5036fce188e2b7caa982eb2fef7edb7bbfe5f3348 hwloc-2.10.0-01-x86_64.pkg.tar.lz