jobextra/itstool/PKGBUILD

80 lines
2.5 KiB
Bash

#!/usr/bin/bash
# JOBoRun : Jwm OpenBox Obarun RUNit
# Maintainer : Joe Bo Run <joborun@disroot.org>
# PkgSource : url="https://gittea.disroot.org/joborun-pkg/jobextra/$pkgname"
# Website : https://pozol.eu
#-----------------------------------------| DESCRIPTION |---------------------------------------
pkgname=itstool
pkgver=2.0.7
pkgrel=02
epoch=1
pkgdesc="XML to PO and back again"
url="http://itstool.org/"
depends=(python libxml2 docbook-xml)
makedepends=(git)
#_commit=f1c6544dcd83a73a5ccea9e0c48cf9a47e006190 # tags/2.0.7^0
#source=("git+https://github.com/itstool/itstool#commit=$_commit"
source=("git+https://github.com/itstool/itstool?signed#tag=$pkgver"
0001-Fix-the-crash-from-912099.patch
0002-Fix-insufficiently-quoted-regular-expressions.patch)
#pkgver() {
# cd $pkgname
# git describe --tags | sed 's/-/+/g'
#}
prepare() {
cd $pkgname
# https://src.fedoraproject.org/rpms/itstool/blob/rawhide/f/itstool-2.0.5-fix-crash-wrong-encoding.patch
git apply -3 ../0001-Fix-the-crash-from-912099.patch
# Fix insufficiently quoted regular expressions / Python 3.12
## https://github.com/itstool/itstool/pull/51
git apply -3 ../0002-Fix-insufficiently-quoted-regular-expressions.patch
autoreconf -fvi
}
build() {
cd $pkgname
./configure --prefix=/usr
make
}
check() {
cd $pkgname
make check
}
package() {
cd $pkgname
make DESTDIR="$pkgdir" install
}
#---- arch license gpg-key & sha256sums ----
arch=(x86_64)
license=(GPL-3.0-only)
validpgpkeys=(4E03CB89E1C8ED8E049367ABE5D9AD24CC3ADF80) # Shaun McCance <shaunm@redhat.com>
b2sums=('316a27ad8c76d789e773298a656d9d2516277f65be968e583e953c886f94d0e2a2af49fedc79c0652571affac7851e5dd1b671dfb92b0db3537b9495c1a95616'
'42e496c4d0aa3c5561d259c970cb9f43835e50c94b273bc01b4e388d1d6d16f05dc00cfded631cd8fdf2c1bf28f6ec64c1e626b5bdc50c15abfa7020d398673a'
'da79a18dee20e10c9b9e49824a09a00cab4b22abab83f3cb00d0d899216d0cf8b9d56b79f46714360312e87ec04501f6fedb3e2b8e2dcabca18c8777361f6490')
sha256sums=(SKIP
b43cea38118aaefa6724136d142dcc7099cd6de04cf2e226f53d4310dfe207cc # 0001-Fix-the-crash-from-912099.patch
4e64a2e884f9d4cbc493732fcbde9f1d5bed534f9a66330bbcc1cbeb54808c1e) # 0002-Fix-insufficiently-quoted-regular-expressions.patch
# Note to packager:
#ls -l *pkg.tar.lz
#echo "you must rename this package to meet SF naming before you move to the repo"
#mv $(ls -l $pkgname*pkg.tar.lz) $pkgname-$epoch_$pkgver-$pkgrel-$arch.pkg.tar.lz >pkg-mv.log
##
##
## 19f86e404570823331e47431cc4785c42fea4ef2dc2ad90f44772e97a035c439 itstool-1_2.0.7-02-x86_64.pkg.tar.lz