jobextra/kismet/PKGBUILD-arch

74 lines
2.7 KiB
Plaintext

# Maintainer: Levente Polyak <anthraxx[at]archlinux[dot]org>
# Maintainer: Juergen Hoetzel <juergen@archlinux.org>
# Contributor: Angel Velasquez <angvp@archlinux.org>
# Contributor: Jason Chu <jason@archlinux.org>
pkgname=kismet
pkgver=2023_07_R1
_realver="${pkgver//_/-}"
pkgrel=8
pkgdesc="802.11 layer2 wireless network detector, sniffer, and intrusion detection system"
url="https://www.kismetwireless.net/"
arch=('x86_64')
license=('GPL')
depends=('libpcap' 'pcre2' 'bluez-libs' 'libcap' 'protobuf-c' 'libprotobuf-c.so'
'sqlite' 'libnm' 'gcc-libs' 'libusb' 'libusb-1.0.so' 'libnl' 'glibc' 'zlib' 'libelf'
'lm_sensors' 'systemd' 'python' 'python-setuptools' 'python-protobuf' 'python-pyserial'
'python-numpy' 'python-websockets' 'libwebsockets' 'libcap-ng'
libpcap.so libprotobuf.so libnm.so libwebsockets.so libsensors.so)
makedepends=('python-setuptools')
optdepends=(
'gpsd: log coordinates of detected networks'
'wireshark-cli: provide OUI files used to determine device manufacturer'
'wireshark-cli: mergecap, to merge multiple capture files'
'sox: provide the default kismet sound playback binary'
'festival: text-to-speech support'
'flite: alternative/lightweight text-to-speech support')
backup=(
etc/kismet/kismet.conf
etc/kismet/kismet_80211.conf
etc/kismet/kismet_alerts.conf
etc/kismet/kismet_filter.conf
etc/kismet/kismet_httpd.conf
etc/kismet/kismet_logging.conf
etc/kismet/kismet_memory.conf
etc/kismet/kismet_uav.conf)
install=kismet.install
source=(https://www.kismetwireless.net/code/${pkgname}-${_realver}.tar.xz
kismet.sysusers
python-install-flags.patch)
sha512sums=('b8b320b8e09be5be582848ce8a1a66f71a96eccc3c78f52d3f1f18122abbe614ff3b5a55b5fcedf3e6a1fc959a72838adc0d7278ffd6c25a1c179a1caf5584ce'
'452b728c30c9932bdb91741af425267da87a66962ea9b736751948881f5477dee0bff8e2eeca2befdea2920da6d7d9e198bde69cef8c48bb49a0093a7f0ef897'
'fbf487148e50b6e3ec60fd0490ccfef1249fdb6b974d6fa25ae1e04101cd62f3c2737d81554b8f1229cd89b177f46f0ea2e853d066fe434a1bd988407809b067')
validpgpkeys=('354689DF3C9DED803381A661D7B28822738BBDB1') # Michael Kershaw
prepare() {
cd ${pkgname}-${_realver}
patch -Np0 < ../python-install-flags.patch
autoreconf -fiv
}
build() {
cd ${pkgname}-${_realver}
./configure \
--prefix=/usr \
--localstatedir=/var \
--sysconfdir=/etc/kismet \
--with-suidgroup=315
make all plugins
}
package() {
cd ${pkgname}-${_realver}
make DESTDIR="${pkgdir}" install
# Makepkg strip bug #43600
chmod u+w "${pkgdir}"/usr/bin/kismet*
chmod o-x "${pkgdir}"/usr/bin/kismet_cap*
chown 0:315 "${pkgdir}"/usr/bin/kismet_cap*
install -Dm 644 ../kismet.sysusers "${pkgdir}/usr/lib/sysusers.d/kismet.conf"
}
# vim: ts=2 sw=2 et: