jobextra/libgit2/PKGBUILD-arch

82 lines
2.3 KiB
Plaintext

# Maintainer: David Runge <dvzrv@archlinux.org>
# Maintainer: Lukas Fleischer <lfleischer@archlinux.org>
# Contributor: Hilton Medeiros <medeiros.hilton@gmail.com>
# Contributor: Dave Reisner <d@falconindy.com>
pkgname=libgit2
# NOTE: add the following packages to rebuild TODOs on soname change (although they do not link against libgit2.so):
# julia
pkgver=1.7.2
pkgrel=1
epoch=1
pkgdesc="A linkable library for Git"
arch=(x86_64)
url="https://github.com/libgit2/libgit2"
license=(LicenseRef-GPL-2.0-only-with-linking-exception)
depends=(
gcc-libs
glibc
http-parser
zlib
)
makedepends=(
cmake
libssh2
openssl
pcre2
python
)
provides=(libgit2.so)
source=($url/archive/v$pkgver/$pkgname-v$pkgver.tar.gz)
sha512sums=('825737e4a1991fba50ea535f15b0e560ebe76ead752e04aeba36925b944d0da77fe9826a70980a1aa3d0bf9afbedfab79dd92e799c9252931384c89ebec9b012')
b2sums=('c27870124c7e63a37794014a802a6fce46c577313f3b6081580f920fa842a65305b5bc56aa6ab02cf87c533d6052afdc37317f96aa1fd67387b07f52415ccbe3')
build() {
local cmake_options=(
-B build
-DCMAKE_BUILD_TYPE=None
-DCMAKE_INSTALL_PREFIX=/usr
-DREGEX_BACKEND=pcre2
-DUSE_HTTP_PARSER=system
-DUSE_SSH=ON
-S $pkgname-$pkgver
-Wno-dev
)
cmake "${cmake_options[@]}"
cmake --build build --verbose
}
check() {
local ignored_tests=(
'invasive|'
'online|'
'ssh|'
'network_url_parse__hostname_implied_root_empty_port|'
'network_url_parse__hostname_empty_port|'
'network_url_parse__ipv4_implied_root_empty_port|'
'network_url_parse__ipv4_empty_port|'
'network_url_parse__ipv6_implied_root_empty_port|'
'network_url_parse__ipv6_empty_port'
)
local ifs="$IFS"
IFS=
# NOTE: disable tests requiring the internet, relying on non-existent
# resources, or those that are only compatible with the (modified) vendored
# version of http-parser, but not with upstream http-parser
ctest --test-dir build --output-on-failure -E "${ignored_tests[*]}"
IFS="$ifs"
}
package() {
depends+=(
libssh2 libssh2.so
openssl libcrypto.so libssl.so
pcre2 libpcre2-8.so
)
DESTDIR="$pkgdir" cmake --install build
install -vDm 644 $pkgname-$pkgver/{AUTHORS,README.md} -t "$pkgdir/usr/share/doc/$pkgname/"
install -vDm 644 $pkgname-$pkgver/COPYING -t "$pkgdir/usr/share/licenses/$pkgname/"
}