jobextra/libpciaccess/PKGBUILD

53 lines
1.7 KiB
Bash

#!/usr/bin/bash
# JOBoRun : Jwm OpenBox Obarun RUNit
# Maintainer : Joe Bo Run <joborun@disroot.org>
# PkgSource : url="https://gittea.disroot.org/joborun-pkg/jobextra/$pkgname"
# Website : https://pozol.eu
#-----------------------------------------| DESCRIPTION |---------------------------------------
pkgname=libpciaccess
pkgver=0.18.1
pkgrel=02
pkgdesc="X11 PCI access library"
#url="https://xorg.freedesktop.org/"
url="https://gitlab.freedesktop.org/xorg/lib/libpciaccess"
depends=('glibc' 'zlib')
makedepends=('xorg-util-macros')
#options=('debug') ### uncomment this to have the debug pkg produced
#source=(${url}/releases/individual/lib/${pkgname}-${pkgver}.tar.xz{,.sig})
source=(https://xorg.freedesktop.org/releases/individual/lib/${pkgname}-${pkgver}.tar.xz{,.sig})
prepare() {
mkdir build
}
check() {
meson test -C build
}
build() {
arch-meson "$pkgname"-$pkgver build
ninja -C build
}
package() {
DESTDIR="$pkgdir" ninja -C build install
install -Dm644 "$pkgname"-$pkgver/COPYING -t "${pkgdir}/usr/share/licenses/${pkgname}/"
}
#---- arch license gpg-key & sha256sums ----
arch=(x86_64)
license=('LicenseRef-libpciaccess')
validpgpkeys=(4A193C06D35E7C670FA4EF0BA2FB9E081F2D130E) # Alan Coopersmith <alan.coopersmith@oracle.com>
# 8703B6700E7EE06D7A39B8D6EDAE37B02CEB490D # "Emil Velikov <emil.l.velikov@gmail.com>"
# 995ED5C8A6138EB0961F18474C09DD83CAAA50B2) # "Adam Jackson <ajax@nwnk.net>"
sha256sums=(4af43444b38adb5545d0ed1c2ce46d9608cc47b31c2387fc5181656765a6fa76 # libpciaccess-0.18.1.tar.xz
80460d40f59fea5a3177eaf139c503a3724b9ba0d01ca124d4f54f97001c89b2) # libpciaccess-0.18.1.tar.xz.sig
## dce5000f740918c40d58d2440f6d09a49fde7ed45b0d0ad30f6032fd427634b4 libpciaccess-0.18.1-02-x86_64.pkg.tar.lz