37 lines
1.2 KiB
Text
37 lines
1.2 KiB
Text
# Maintainer: Andreas Radke <andyrtr@archlinux.org>
|
|
# Contributor: Jan de Groot <jgc@archlinux.org>
|
|
# Contributor: Alexander Baldeck <alexander@archlinux.org>
|
|
|
|
pkgname=libpciaccess
|
|
pkgver=0.18.1
|
|
pkgrel=2
|
|
pkgdesc="X11 PCI access library"
|
|
arch=(x86_64)
|
|
license=('LicenseRef-libpciaccess')
|
|
url="https://gitlab.freedesktop.org/xorg/lib/libpciaccess"
|
|
depends=('glibc' 'zlib')
|
|
makedepends=('xorg-util-macros' 'meson')
|
|
source=(https://xorg.freedesktop.org/releases/individual/lib/${pkgname}-${pkgver}.tar.xz{,.sig})
|
|
sha512sums=('ef27999446e735df2331e94219ee3dafe9198a2472bb452f63ef9c9c446d5431f9e231e224cfabdeba1402974a5a0064546f9abced4d1770f994f5fc0c2b3310'
|
|
'SKIP')
|
|
validpgpkeys=('4A193C06D35E7C670FA4EF0BA2FB9E081F2D130E') # Alan Coopersmith <alan.coopersmith@oracle.com>
|
|
#validpgpkeys+=('8703B6700E7EE06D7A39B8D6EDAE37B02CEB490D') # "Emil Velikov <emil.l.velikov@gmail.com>"
|
|
#validpgpkeys+=('995ED5C8A6138EB0961F18474C09DD83CAAA50B2') # "Adam Jackson <ajax@nwnk.net>"
|
|
|
|
prepare() {
|
|
mkdir build
|
|
}
|
|
|
|
build() {
|
|
arch-meson "$pkgname"-$pkgver build
|
|
ninja -C build
|
|
}
|
|
|
|
check() {
|
|
meson test -C build
|
|
}
|
|
|
|
package() {
|
|
DESTDIR="$pkgdir" ninja -C build install
|
|
install -Dm644 "$pkgname"-$pkgver/COPYING -t "${pkgdir}/usr/share/licenses/${pkgname}/"
|
|
}
|