jobextra/libunwind/PKGBUILD

63 lines
2.0 KiB
Bash

#!/usr/bin/bash
# JOBoRun : Jwm OpenBox Obarun RUNit
# Maintainer : Joe Bo Run <joborun@disroot.org>
# PkgSource : url="https://gittea.disroot.org/joborun-pkg/jobextra/$pkgname"
# Website : https://pozol.eu
#-----------------------------------------| DESCRIPTION |---------------------------------------
pkgname=libunwind
pkgver=1.8.1
pkgrel=02
pkgdesc="Determine and manipulate the call-chain of a program"
#pkgdesc='Portable and efficient C programming interface (API) to determine the call-chain of a program'
url="https://www.nongnu.org/libunwind/"
depends=('xz' 'zlib')
#makedepends=('texlive-core')
makedepends=(texlive-binextra)
provides=(libunwind-{coredump,ptrace,setjmp,x86_64}.so libunwind.so)
source=(https://github.com/libunwind/libunwind/releases/download/v$pkgver/libunwind-$pkgver.tar.gz{,.asc})
#source=("https://download.savannah.gnu.org/releases/$pkgname/$pkgname-$pkgver.tar.gz"{,.sig})
build() {
local configure_options=(
--prefix=/usr
--sysconfdir=/etc
--localstatedir=/var
)
cd libunwind-$pkgver
./configure "${configure_options[@]}"
sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
make
}
# 2 tests fail on 1.7.2 & 1.8.1 run makepkg --nocheck (after the xz fiasco I don't know whether -e is a good option or not)
#
check() {
cd $pkgname-$pkgver
make check
}
##
package() {
cd $pkgname-$pkgver
make DESTDIR="$pkgdir" install
rm -r "$pkgdir"/usr/libexec
}
#---- arch license gpg-key & sha256sums ----
arch=(x86_64)
license=('GPL')
#validpgpkeys=('5C96BDEAF5F47FB02BD4F6B965D98560914F3F48' # Arun Sharma
# '1675C8DA2EF907FB116EB709EC52B396E6874AF2' # Dave Watson
# '75D2CFC56CC2E935A4143297015A268A17D55FA4') # Dave Watson
validpgpkeys=(F86EB09F72717426F20D36470A0FF845B7DB3427) # Stephen M. Webb <stephen.webb@bregmasoft.ca>
sha256sums=(ddf0e32dd5fafe5283198d37e4bf9decf7ba1770b6e7e006c33e6df79e6a6157 # libunwind-1.8.1.tar.gz
880fdf506d8982aa2d6d96c56fa1fb46be8897a3951005126a800d1d2da497b8) # libunwind-1.8.1.tar.gz.asc