jobextra/limine/PKGBUILD

72 lines
2.6 KiB
Bash

#!/usr/bin/bash
# JOBoRun : Jwm OpenBox Obarun RUNit
# Maintainer : Joe Bo Run <joborun@disroot.org>
# PkgSource : url="https://gittea.disroot.org/joborun-pkg/jobextra/$pkgname"
# Website : https://pozol.eu
#-----------------------------------------| DESCRIPTION |---------------------------------------
# reference to the implementation done by mobinmob in abyss
# https://github.com/mobinmob/void-mklive/tree/abyss
# https://github.com/void-linux/void-mklive/issues/313
# After joborun, eventually this made it to AUR, then extra for Arch
# End of support for this piece of garbage software!!
pkgname=limine
pkgver=5.20231006.0
pkgrel=09999
pkgdesc="An advanced, portable, multiprotocol bootloader - no longer boots from ext4 it expects FAT boot partition - GO TO MS-win11 to play"
url="https://limine-bootloader.org/"
depends=('glibc')
makedepends=('nasm' 'mtools' 'llvm' 'lld' 'clang')
source=("https://github.com/limine-bootloader/limine/releases/download/v${pkgver}/$pkgname-${pkgver}.tar.xz"
limine.cfg::https://github.com/limine-bootloader/limine/raw/trunk/test/limine.cfg
bg.jpg::https://raw.githubusercontent.com/limine-bootloader/limine/trunk/test/bg.jpg
CONFIG.md::https://github.com/limine-bootloader/limine/raw/trunk/CONFIG.md)
install=limine.install
build() {
cd "$pkgname-$pkgver"
./configure \
--prefix=/usr \
--bindir=/usr/bin \
--sbindir=/usr/bin \
--libdir=/usr/lib \
--mandir=/usr/share/man \
--docdir=/usr/share/doc \
--enable-bios-cd \
--enable-bios-pxe \
--enable-bios \
--disable-uefi-ia32 \
--enable-uefi-x86-64 \
--disable-uefi-aarch64 \
--enable-uefi-cd \
TOOLCHAIN_FOR_TARGET=llvm
make
}
package() {
cd "$pkgname-$pkgver"
make DESTDIR="$pkgdir" install
install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
mkdir -p -m755 "$pkgdir/boot/limine"
install -Dm644 $srcdir/$pkgname-$pkgver/bin/limine-bios.sys "$pkgdir/boot/limine/"
install -Dm644 $srcdir/bg.jpg "$pkgdir/boot/limine/"
install -Dm644 $srcdir/limine.cfg "$pkgdir/boot/limine/"
install -Dm644 $srcdir/CONFIG.md "$pkgdir/boot/limine/"
}
#---- arch license gpg-key & sha256sums ----
arch=(x86_64)
license=('BSD')
sha256sums=(e759bc39a59d07260d5def19bff5cd6e3f6147708e691383af7b09c33d00e347 # limine-5.20231006.0.tar.xz
a70b1fd5981d8d7d024992a521fd78481a0a69f8311a768679fc732f5c03488a # limine.cfg
15df8e06872a6cb89dfad3f99ad2b255dd1a54576e4343c954975e2ea48f28ab # bg.jpg
c2897b54e8a54d81a61f929280f98b54786a506e5269fe474ebfac4c57c57a9f) # CONFIG.md
###END OF LIMINE FOR Joborun!!!!!
## 0f40efbc37c1a764be8e22c2477eab5c2696995da89b2208831530322071297f limine-5.20231006.0-09999-x86_64.pkg.tar.lz