jobextra/ndctl/PKGBUILD

48 lines
1.5 KiB
Bash

#!/usr/bin/bash
# JOBoRun : Jwm OpenBox Obarun RUNit
# Maintainer : Joe Bo Run <joborun@disroot.org>
# PkgSource : url="https://gittea.disroot.org/joborun-pkg/jobextra/$pkgname"
# Website : https://pozol.eu
#-----------------------------------------| DESCRIPTION |---------------------------------------
pkgname=ndctl
pkgver=78
pkgrel=01 ## eudev rebuild
pkgdesc='Utility library for managing the libnvdimm (non-volatile memory device) sub-system in the Linux kernel w/o systemd'
url="https://github.com/pmem/ndctl"
depends=('iniparser' 'json-c' 'keyutils' 'kmod' 'util-linux-libs' 'eudev' 'libtraceevent' 'libtracefs' )
makedepends=('asciidoctor' 'bash-completion' 'cmake' 'meson' 'xmlto')
source=("https://github.com/pmem/ndctl/archive/v$pkgver/$pkgname-$pkgver.tar.gz")
prepare() {
# fix location of modprobe.d conf
sed -i "s|^modprobedatadir =.*|modprobedatadir = '/usr/lib/modprobe.d/'|" $pkgname-$pkgver/contrib/meson.build
}
build() {
arch-meson $pkgname-$pkgver build -D systemd=disabled
meson compile -C build
}
check() {
meson test -C build --print-errorlogs
}
package() {
meson install -C build --destdir "$pkgdir"
# cd $pkgname-$pkgver
# make DESTDIR="$pkgdir" install
}
#---- arch license gpg-key & sha256sums ----
arch=(x86_64)
license=('LGPL')
sha256sums=(80596932920a3eb42551fc0d978f22bfa6a620f57af60c898dc0d0e303c086a5) # ndctl-78.tar.gz
## 24b5b2fcf207229f05f2a896e50c508e79214b234bf350b5264e47850ea3aa0a ndctl-78-01-x86_64.pkg.tar.lz