jobextra/neon/PKGBUILD

53 lines
1.4 KiB
Bash

#!/usr/bin/bash
# JOBoRun : Jwm OpenBox Obarun RUNit
# Maintainer : Joe Bo Run <joborun@disroot.org>
# PkgSource : url="https://gittea.disroot.org/joborun-pkg/jobextra/$pkgname"
# Website : https://pozol.eu
#-----------------------------------------| DESCRIPTION |---------------------------------------
pkgname=neon
pkgver=0.33.0
pkgrel=01
pkgdesc='HTTP/1.1 and WebDAV client library with a C interface'
url="https://notroj.github.io/neon/"
depends=('krb5' 'expat' 'ca-certificates' 'zlib' 'openssl')
makedepends=('xmlto' 'docbook-xsl')
options=('libtool') # FS#16067
source=(https://notroj.github.io/neon/$pkgname-$pkgver.tar.gz)
build() {
cd ${pkgname}-${pkgver}
./configure --prefix=/usr \
--with-expat \
--enable-shared \
--disable-static \
--with-ssl=openssl \
--with-ca-bundle=/etc/ssl/certs/ca-certificates.crt
# sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
make
}
check() {
cd $pkgname-$pkgver
make check
}
package() {
cd ${pkgname}-${pkgver}
make DESTDIR="${pkgdir}" install
}
#---- arch license gpg-key & sha256sums ----
arch=('x86_64')
license=('LGPL-2.0-or-later')
validpgpkeys=('190555472DCC589BEF01609C608A86DF9833CC49') # Joe Orton
sha256sums=(659a5cc9cea05e6e7864094f1e13a77abbbdbab452f04d751a8c16a9447cf4b8) # neon-0.33.0.tar.gz
## 426ab081cf7cc3c312b98a44e926f877f86ff630e02180ae9833bc573ff8d0e9 neon-0.33.0-01-x86_64.pkg.tar.lz