jobextra/onetbb/PKGBUILD

72 lines
2.1 KiB
Bash

#!/usr/bin/bash
# JOBoRun : Jwm OpenBox Obarun RUNit
# Maintainer : Joe Bo Run <joborun@disroot.org>
# PkgSource : url="https://gittea.disroot.org/joborun-pkg/jobextra/$pkgname"
# Website : https://pozol.eu
#-----------------------------------------| DESCRIPTION |---------------------------------------
pkgname=onetbb
pkgver=2021.12.0
pkgrel=02
pkgdesc='High level abstract threading library (oneAPI Threading Building Blocks)'
url='https://oneapi-src.github.io/oneTBB/'
depends=('gcc-libs' 'hwloc')
makedepends=('cmake' 'inetutils' 'ninja' 'python' 'swig' 'python-setuptools')
conflicts=('intel-tbb' 'tbb')
provides=("intel-tbb=$pkgver" "tbb=$pkgver")
replaces=('intel-tbb' 'tbb')
source=(https://github.com/oneapi-src/oneTBB/archive/v$pkgver/$pkgname-$pkgver.tar.gz)
# $pkgname-gcc13.patch::https://github.com/oneapi-src/oneTBB/commit/154cc73ca4d359621202399cc0c3c91058e56e79.patch)
#prepare() {
# cd oneTBB-$pkgver
# # FS#77894
# patch -Np1 -i ../$pkgname-gcc13.patch
#}
build() {
cmake -B build -S oneTBB-$pkgver -GNinja \
-DCMAKE_INSTALL_PREFIX=/usr \
-DTBB_STRICT=OFF \
-DTBB4PY_BUILD=ON \
-DCMAKE_BUILD_TYPE=None
cmake --build build
}
# 2021.10 comment check section out and rerun without the -f option
#99% tests passed, 2 tests failed out of 138
#
#Total Test time (real) = 99.06 sec
#
#The following tests FAILED:
# 69 - test_arena_constraints (Subprocess aborted)
# 123 - conformance_arena_constraints (Failed)
#Errors while running CTest
#
check() {
cd build
ninja test
}
package() {
DESTDIR="$pkgdir" cmake --install build
rm -r "$pkgdir"/usr/lib/python*
cd oneTBB-$pkgver/python
TBBROOT="$pkgdir"/usr python setup.py install --root="$pkgdir"
}
#---- arch license gpg-key & sha256sums ----
arch=(x86_64)
license=('Apache')
sha512sums=('64022bcb61cf7b2030a1bcc11168445ef9f0d69b70290233a7febb71cc7a12cc2282dddc045f84e30893efe276342f02fd78d176706268eeaefe9aac7446d4e9')
sha256sums=(c7bb7aa69c254d91b8f0041a71c5bcc3936acb64408a1719aec0b2b7639dd84f) # onetbb-2021.12.0.tar.gz
## cd19d50955258a73ea6a5ab8c4b35fccfa1b345a1a0ad03f74de80e3b523ec7a onetbb-2021.12.0-02-x86_64.pkg.tar.lz