jobextra/openbox-patched/PKGBUILD

138 lines
5.6 KiB
Bash

#!/usr/bin/bash
# JOBoRun : Jwm OpenBox Obarun RUNit
# Maintainer : Joe Bo Run <joborun@disroot.org>
# PkgSource : url="https://gittea.disroot.org/joborun-pkg/jobextra/$pkgname"
# Website : https://pozol.eu
#-----------------------------------------| DESCRIPTION |---------------------------------------
# Contributor : Dylan Araps <dylan.araps@gmail.com>
pkgname=openbox-patched
_pkgname=openbox
pkgver=3.6.1
pkgrel=011
pkgdesc='Openbox with Rounded Corners patch and debian patches'
url='http://openbox.org'
makedepends=('automake' 'docbook2x' 'python-pyxdg' 'autoconf' 'gettext')
optdepends=('python-pyxdg: for the openbox-xdg-autostart script')
backup=('etc/xdg/openbox/menu.xml'
'etc/xdg/openbox/rc.xml'
'etc/xdg/openbox/autostart'
'etc/xdg/openbox/environment')
depends=('libxml2' 'libxinerama' 'libxrandr'
'libxcursor' 'pango' 'imlib2' 'librsvg' 'libsm' 'python-pyxdg'
'libxi' 'startup-notification')
provides=('libobrender.so' $_pkgname)
conflicts=($_pkgname $_pkgname-debian)
replaces=($_pkgname)
source=("http://openbox.org/dist/openbox/${_pkgname}-${pkgver}.tar.gz"
"http://openbox.org/dist/openbox/openbox-3.5.0-title-matching.patch"
"http://openbox.org/dist/openbox/openbox-3.5.0-which-2.20.patch"
"http://openbox.org/dist/openbox/openbox-3.6.2-rounded-corners.patch"
"http://openbox.org/dist/openbox/openbox-3.6.2-fix-out-of-bounds.patch"
# "https://github.com/archlinux/svntogit-community/blob/packages/openbox/trunk/py3.patch"
"http://http.debian.net/debian/pool/main/o/openbox/openbox_3.6.1-10.debian.tar.xz"
"https://github.com/Mikachu/openbox/commit/9ed6fdd71890c5cc43747f105382d5677e5d37e7.patch")
install="${pkgname}.install"
prepare() {
cd "${_pkgname}-${pkgver}"
local patches=(
01_rc.xml.patch
02_fix_freedesktop_compliance.patch
04_fix_xml_load_file.patch
# 05_openbox-3.5.0-title-matching.patch
# 06_openbox-3.5.0-which-2.20.patch
07_update_desktop.patch
08_autostart-fix.patch
704724_fix_refers-to-autostart.sh.patch
719620_fix_show_startup_notification.patch
754207_use-scrot.patch
808138_Replace-getgrent-with-getgroups.patch
d9a405e9.patch
fix-spelling-error-in-binary.patch
adapt-to-gsd-324.patch
843231.patch
09-disable-check-gnome-version.patch
887908.patch
917204_undecorated_maximized_no_border.patch
# python3.patch
Allow-256x256-window-icon-size-for-HiDPI-displays.patch
Add-class-hint-to-focus-cycle-popup.patch
Fix-collision-between-iterator-and-throw-away-argume.patch
# 974180.patch
)
for i in "${patches[@]}"; do
msg "Applying ${i} ..."
patch -p1 -i "../debian/patches/${i}"
done
patch -Np1 -i "${srcdir}/openbox-3.5.0-title-matching.patch" # OB#5277
patch -Np1 -i "${srcdir}/openbox-3.5.0-which-2.20.patch" # FS#11455
# https://forums.bunsenlabs.org/viewtopic.php?pid=46711#p46711
patch -Np1 -i "${srcdir}/openbox-3.6.2-rounded-corners.patch"
# https://github.com/danakj/openbox/pull/26
patch -Np1 -i "${srcdir}/openbox-3.6.2-fix-out-of-bounds.patch"
# # py3.patch modifies configure.ac
# patch -Np1 -i "${srcdir}/py3.patch"
# https://bugs.archlinux.org/task/77853
# The patch is proposed on https://bugzilla.icculus.org/show_bug.cgi?id=6669
# and commited to a work branch in the upstream repo
patch -Np1 -i "$srcdir"/9ed6fdd71890c5cc43747f105382d5677e5d37e7.patch
autoreconf -ifv
}
build() {
cd "${_pkgname}-${pkgver}"
./configure \
--prefix=/usr \
--with-x \
--enable-startup-notification \
--sysconfdir=/etc \
--libexecdir=/usr/lib/openbox
make
}
package() {
cd "${_pkgname}-${pkgver}"
make DESTDIR="$pkgdir" install
# GNOME Panel is no longer available in the arch repositories
rm -r "${pkgdir}/usr/bin/"{gdm-control,gnome-panel-control,openbox-gnome-session} \
"${pkgdir}/usr/share/gnome"{,-session} \
"${pkgdir}/usr/share/man/man1/openbox-gnome-session.1" \
"${pkgdir}/usr/share/xsessions/openbox-gnome.desktop"
# sed -i 's:startkde:/usr/bin/\0:' \
# "${pkgdir}/usr/share/xsessions/openbox-kde.desktop"
#
}
#---- arch license gpg-key & sha256sums ----
arch=(x86_64)
license=('GPL')
sha256sums=(8b4ac0760018c77c0044fab06a4f0c510ba87eae934d9983b10878483bde7ef7 # openbox-3.6.1.tar.gz
adc0820671e6ec42ff1bb4cbb04c65e19cdf74c62bcef3a3b727adb208eb82c7 # openbox-3.5.0-title-matching.patch
ce33bb6c3d543da091db2037e1f3084e5a0e752c9479584256d2f000f0da920d # openbox-3.5.0-which-2.20.patch
ac5617253dfc39e2fc204830ca19aa3fa48a0e00e46dd90a0057a2f1dd77cfbb # openbox-3.6.2-rounded-corners.patch
ec1f99bd7149e888c96b719b4192c413464815848bb05cfa8e88c7cb4214b9ac # openbox-3.6.2-fix-out-of-bounds.patch
# 4cd2708320ab3cdf4868bd66f20481dbad504d0e9aa43f13bca5c149b94a49cf # py3.patch
897cd12faf2c5a0c3b9b0db675b04bc1de084ca189b7797afac9ed50998c7ce4 # openbox_3.6.1-10.debian.tar.xz
a371d116483f37cd888bdeb1a5a1b594ddc9bf92c9c91478a1d5bff48a24b537) # 9ed6fdd71890c5cc43747f105382d5677e5d37e7.patch
## 7276120922e47283ee3c0b7cdd51ea343ee027781d662161da159f68b0a093df openbox-patched-3.6.1-08-x86_64.pkg.tar.lz
## 0c5b28e361dbc06ce83c62fb0c6a5164cd464d89d88bda471137f2e35f1f0bcb openbox-patched-3.6.1-09-x86_64.pkg.tar.lz
## 58fb7f7ca994b91a1c762a85b7f3ad7b95a99a44fb370dcc9287c94a356fe61e openbox-patched-3.6.1-010-x86_64.pkg.tar.lz
## 25c6b510785b2dd632dc2cca22b27add3bd1f06dc7dc77310928cf2e160b48ee openbox-patched-3.6.1-011-x86_64.pkg.tar.lz