jobextra/pam_rundir/PKGBUILD

39 lines
1016 B
Bash

#!/usr/bin/bash
# JOBoRun : Jwm OpenBox Obarun RUNit
# Maintainer : Joe Bo Run <joborun@disroot.org>
# PkgSource : url="https://gittea.disroot.org/joborun-pkg/jobextra/$pkgname"
# Website : https://pozol.eu
#-----------------------------------------| DESCRIPTION |---------------------------------------
pkgname=pam_rundir
pkgver=1.2.0
pkgrel=01
pkgdesc='PAM module to provide $XDG_RUNTIME_DIR'
arch=('x86_64')
url="https://gitea.artixlinux.org/artix/pam_rundir"
depends=('pam')
makedepends=('git')
_commit=5338dec85e201b7e5fb4aeb0d548448d140ac41e # tags/1.2.0^0
source=("git+https://gitea.artixlinux.org/artix/pam_rundir.git#commit=$_commit")
build() {
cd $pkgname
./configure --prefix=/usr
make
}
package() {
cd $pkgname
DESTDIR="$pkgdir" make install
install -Dm644 COPYING "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
# empty directory for tmpfiles-setup
install -d $pkgdir/usr/share/factory/etc/pam.d
}
#---- license gpg-key sha256sums ----
license=('GPL2+')
sha256sums=('SKIP')