jobextra/python-setuptools/PKGBUILD

118 lines
4.2 KiB
Bash

#!/usr/bin/bash
# JOBoRun : Jwm OpenBox Obarun RUNit
# Maintainer : Joe Bo Run <joborun@disroot.org>
# PkgSource : url="https://gittea.disroot.org/joborun-pkg/jobextra/$pkgname"
# Website : https://pozol.eu
#-----------------------------------------| DESCRIPTION |---------------------------------------
pkgname=python-setuptools
pkgver=69.0.3
_commit=b07d2f58233f9a99a820901924e263645c57a7c6
pkgrel=05
epoch=1
pkgdesc="Easily download, build, install, upgrade, and uninstall Python packages"
groups=(python-build-backend)
url="https://pypi.org/project/setuptools/"
depends=('python-jaraco.text' 'python-more-itertools' 'python-ordered-set' 'python-packaging'
'python-platformdirs' 'python-tomli' 'python-validate-pyproject')
makedepends=('git' 'python-setuptools')
checkdepends=('python-jaraco.envs' 'python-jaraco.path' 'python-pip'
'python-wheel' 'python-pytest-enabler' 'python-pytest-mypy'
'python-pytest-timeout' 'python-sphinx' 'python-build'
'python-ini2toml' 'python-tomli-w')
provides=('python-distribute')
replaces=('python-distribute')
#source=("$pkgname-$pkgver.tar.gz::https://github.com/pypa/setuptools/archive/v$pkgver.tar.gz"
source=("git+https://github.com/pypa/setuptools.git#commit=$_commit"
system-validate-pyproject.patch
add-dependency.patch
build-no-isolation.patch)
export SETUPTOOLS_INSTALL_WINDOWS_SPECIFIC_FILES=0
prepare() {
# cd setuptools-$pkgver
cd setuptools
patch -p1 -i ../system-validate-pyproject.patch
rm -r {pkg_resources,setuptools}/{extern,_vendor} setuptools/config/_validate_pyproject
# Upstream devendoring logic is badly broken, see:
# https://bugs.archlinux.org/task/58670
# https://github.com/pypa/pip/issues/5429
# https://github.com/pypa/setuptools/issues/1383
# The simplest fix is to simply rewrite import paths to use the canonical
# location in the first place
for _module in setuptools pkg_resources '' ; do
find . -name \*.py -exec sed -i \
-e 's/from '$_module.extern' import/import/' \
-e 's/from '$_module.extern'\./from /' \
-e 's/import '$_module.extern'\./import /' \
-e "s/__import__('$_module.extern./__import__('/" \
-e 's/from \.\.extern\./from /' \
{} +
done
# Add the devendored dependencies into metadata of setuptools
patch -p1 -i ../add-dependency.patch
# Fix tests invoking python-build
patch -p1 -i ../build-no-isolation.patch
# Remove post-release tag since we are using stable tags
sed -e '/tag_build = .post/d' \
-e '/tag_date = 1/d' \
-i setup.cfg
}
build() {
cd setuptools
python setup.py build
}
check() { (
# Workaround UTF-8 tests by setting LC_CTYPE
export LC_CTYPE=en_US.UTF-8
# https://github.com/pypa/setuptools/pull/810
export PYTHONDONTWRITEBYTECODE=1
cd setuptools
# 1,4: subtle difference introduced by devendoring
# 2: pip failures related to devendoring,
# 3,5: TODO
# 6: jaraco.develop is not packaged
PYTHONPATH="$PWD"/build/lib python -m pytest \
--deselect setuptools/tests/config/test_apply_pyprojecttoml.py::test_apply_pyproject_equivalent_to_setupcfg \
--deselect setuptools/tests/test_virtualenv.py \
--deselect setuptools/tests/test_editable_install.py::test_editable_with_prefix \
--deselect setuptools/_normalization.py::setuptools._normalization.safe_version \
--deselect setuptools/tests/test_easy_install.py::TestSetupRequires::test_setup_requires_honors_fetch_params \
--ignore tools/finalize.py
)}
package() {
cd setuptools
python setup.py install --prefix=/usr --root="$pkgdir" --optimize=1 --skip-build
}
#---- arch license gpg-key & sha256sums ----
arch=(x86_64)
license=('PSF')
sha256sums=(SKIP
06e2f68aebedbaeb0b0fe923eae686568910cc3355b33bf619db9266eef83efb # system-validate-pyproject.patch
a2bc8b9d470c13b4cb682ab3943e80ab2841aae98f7c3d9ba1f089408f96aa91 # add-dependency.patch
583ddbc8b636d47c57706a82317ae9956207db9418a1498324b43733a1732860) # build-no-isolation.patch
# Note to packager:
#ls -l *pkg.tar.lz
#echo "you must rename this package to meet SF naming before you move to the repo"
#echo "mv $(ls -l $pkgname*pkg.tar.lz) $pkgname-$epoch_$pkgver-$pkgrel-$arch.pkg.tar.lz >pkg-mv.log"
## 6d33e2649f742c5bff62960a6af8da0438fcecee2e1ff9cd96d8d0d716531f45 python-setuptools-1_69.0.3-05-x86_64.pkg.tar.lz