jobextra/python-six/PKGBUILD

40 lines
1.1 KiB
Bash

#!/usr/bin/bash
# JOBoRun : Jwm OpenBox Obarun RUNit
# Maintainer : Joe Bo Run <joborun@disroot.org>
# PkgSource : url="https://gittea.disroot.org/joborun-pkg/jobextra/$pkgname"
# Website : https://pozol.eu
#-----------------------------------------| DESCRIPTION |---------------------------------------
#pkgbase=python-six
pkgname=python-six
pkgver=1.16.0
pkgrel=09
pkgdesc="Python 2 and 3 compatibility utilities"
url="https://pypi.python.org/pypi/six/"
depends=('python')
makedepends=('python-setuptools')
checkdepends=('python-pytest' 'tk')
source=("https://pypi.io/packages/source/s/six/six-$pkgver.tar.gz")
check() {
cd six-$pkgver
python -m pytest
}
package() {
cd six-$pkgver
python setup.py install --root "$pkgdir" --optimize=1
install -Dm644 LICENSE -t "$pkgdir"/usr/share/licenses/$pkgname/
}
#---- arch license gpg-key & sha256sums ----
arch=(x86_64)
license=('MIT')
sha256sums=(1e61c37477a1626458e36f7b1d82aa5c9b094fa4802892072e49de9c60c4c926) # six-1.16.0.tar.gz
## 149572ede57583635ef340b5501f145ff2639a35b22ad75dca47c8f34d04c311 python-six-1.16.0-09-x86_64.pkg.tar.lz