jobextra/unrar/PKGBUILD

56 lines
1.6 KiB
Bash

#!/usr/bin/bash
# JOBoRun : Jwm OpenBox Obarun RUNit
# Maintainer : Joe Bo Run <joborun@disroot.org>
# PkgSource : url="https://gittea.disroot.org/joborun-pkg/jobextra/$pkgname"
# Website : https://pozol.eu
#-----------------------------------------| DESCRIPTION |---------------------------------------
pkgbase=unrar
pkgname=(unrar libunrar)
pkgver=7.0.8
pkgrel=01
epoch=1
depends=(gcc-libs glibc)
url='https://www.rarlab.com/rar_add.htm'
source=(https://www.rarlab.com/rar/unrarsrc-$pkgver.tar.gz)
#prepare() {
# sed -e '/CXXFLAGS=/d' -e '/LDFLAGS=/d' -i unrar/makefile # Use system build flags
#}
build() {
cp -a unrar libunrar
export LDFLAGS+=' -pthread'
make -C libunrar lib
make -C unrar -j1
}
package_unrar() {
pkgdesc='The RAR un/compression program'
cd unrar
install -Dm755 unrar -t "$pkgdir"/usr/bin/
# install license
install -Dm644 license.txt "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
}
package_libunrar() {
pkgdesc='Library and header file for applications that use libunrar'
cd libunrar
install -Dm755 libunrar.so -t "$pkgdir"/usr/lib/
install -Dm644 dll.hpp -t "$pkgdir"/usr/include/unrar/
# install license
install -Dm644 license.txt "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
}
#---- arch license gpg-key & sha256sums ----
arch=(x86_64)
license=(LicenseRef-UnRAR)
sha256sums=(f68b6a0bb16cbc7e157652542966ee64ca66ae3958273a64128484c51f1b768d) # unrarsrc-7.0.8.tar.gz
## cd6cd85f0dc2a320223ddf7bd1325c038fe2558c9722175941703957766ea828 libunrar-1_7.0.8-01-x86_64.pkg.tar.lz
## e06315e9befec22347a94ae13b93c1717b8276fbe94ad9a14bb5ee5d87fc0bf8 unrar-1_7.0.8-01-x86_64.pkg.tar.lz