jobextra/upower/PKGBUILD

64 lines
1.7 KiB
Bash

#!/usr/bin/bash
# JOBoRun : Jwm OpenBox Obarun RUNit
# Maintainer : Joe Bo Run <joborun@disroot.org>
# PkgSource : url="https://gittea.disroot.org/joborun-pkg/jobextra/$pkgname"
# Website : https://pozol.eu
#-----------------------------------------| DESCRIPTION |---------------------------------------
pkgname=upower
pkgver=1.90.2
pkgrel=01
pkgdesc="Abstraction for enumerating power devices, listening to device events and querying history and statistics w/o systemd"
url="https://upower.freedesktop.org"
depends=(libimobiledevice libgudev usbmuxd)
makedepends=(docbook-xsl gobject-introspection python git gtk-doc meson)
checkdepends=(python-{dbus,dbusmock,gobject} umockdev)
backup=(etc/UPower/UPower.conf)
# options=(debug) ## uncomment this to have the debug pkg produced
_commit=8dcf54440d7eb58b75d7982bc1c29ee35dccf0c2 # tags/v1.90.2^0
source=("git+https://gitlab.freedesktop.org/upower/upower.git#commit=$_commit")
pkgver() {
cd upower
git describe --tags | sed -e 's/^v\|^UPOWER_//;s/_/\./g;s/[^-]*-g/r&/;s/-/+/g'
}
prepare() {
cd upower
# # Fix use of libimobiledevice
# git cherry-pick -n 81a89385a45d3de1028bcd86b3688fb465b4035c
}
build() {
arch-meson upower build \
-D systemdsystemunitdir=no
meson compile -C build
}
#check() {
# meson test -C build --print-errorlogs
#}
package() {
depends+=(libg{lib,object,io}-2.0.so)
provides+=(libupower-glib.so)
meson install -C build --destdir "$pkgdir"
# Remove installed-tests
rm -rv "$pkgdir"/usr/{lib/upower,share/installed-tests}
}
#---- arch license gpg-key && sha256sums ----
arch=(x86_64)
license=(GPL)
sha256sums=(SKIP)
## f9ce530ba65dfbe6c8df7fc00636a1b0e7783c1f51dd6487e6c4882f896f178f upower-1.90.2-01-x86_64.pkg.tar.lz