jobextra/wget/PKGBUILD

68 lines
1.9 KiB
Bash

#!/usr/bin/bash
# JOBoRun : Jwm OpenBox Obarun RUNit
# Maintainer : Joe Bo Run <joborun@disroot.org>
# PkgSource : url="https://gittea.disroot.org/joborun-pkg/jobextra/$pkgname"
# Website : https://pozol.eu
#-----------------------------------------| DESCRIPTION |---------------------------------------
pkgname=wget
pkgver=1.24.5
pkgrel=01
pkgdesc='Network utility to retrieve files from the Web'
url='https://www.gnu.org/software/wget/wget.html'
groups=( jobbot )
depends=('glibc' 'zlib' 'gnutls' 'libidn2' 'libidn2.so' 'util-linux-libs' 'libuuid.so'
'libpsl' 'libpsl.so' 'pcre2' 'nettle' 'libnettle.so')
checkdepends=('perl-http-daemon' 'perl-io-socket-ssl' 'python')
optdepends=('ca-certificates: HTTPS downloads')
makedepends=('perl-http-daemon' 'perl-io-socket-ssl' 'python')
backup=('etc/wgetrc')
source=(https://ftp.gnu.org/gnu/${pkgname}/${pkgname}-${pkgver}.tar.lz{,.sig})
prepare() {
cd ${pkgname}-${pkgver}
cat >> doc/sample.wgetrc <<EOF
# default root certs location
ca_certificate=/etc/ssl/certs/ca-certificates.crt
EOF
}
build() {
cd ${pkgname}-${pkgver}
./configure \
--prefix=/usr \
--sysconfdir=/etc \
--disable-rpath \
--enable-nls \
--with-ssl=gnutls
make
}
check() {
cd ${pkgname}-${pkgver}
make check < /dev/null
}
package() {
cd ${pkgname}-${pkgver}
make DESTDIR="${pkgdir}" install
}
#---- arch license gpg-key & sha256sums ----
arch=(x86_64)
license=('GPL3')
validpgpkeys=(AC404C1C0BF735C63FF4D562263D6DF2E163E1EA # Giuseppe Scrivano <gscrivano@gnu.org>
7845120B07CBD8D6ECE5FF2B2A1743EDA91A35B6 # Darshit Shah <darnir@gnu.org>
1CB27DBC98614B2D5841646D08302DB6A2670428) # Tim Rühsen <tim.ruehsen@gmx.de>
sha256sums=(57a107151e4ef94fdf94affecfac598963f372f13293ed9c74032105390b36ee # wget-1.24.5.tar.lz
4792f4995cd06a6d3dd1243fcded80d21c62f5f3e559ba1fbafe48b947fb52f1) # wget-1.24.5.tar.lz.sig
## 281abfccf3fb437d8e50cba314368d2463ae87c1b3a90c4a9fa561c8af608862 wget-1.24.5-01-x86_64.pkg.tar.lz