50 lines
1.3 KiB
Bash
50 lines
1.3 KiB
Bash
#!/usr/bin/bash
|
|
# JOBoRun : Jwm OpenBox Obarun RUNit
|
|
# Maintainer : Joe Bo Run <joborun@disroot.org>
|
|
# PkgSource : url="https://git.disroot.org/joborun-pkg/jobextra/src/branch/main/$pkgname"
|
|
# Website : https://pozol.eu
|
|
#-----------------------------------------| DESCRIPTION |---------------------------------------
|
|
|
|
pkgname=wlsunset
|
|
pkgver=0.4.1.pr
|
|
_pkgver=0.4.0.r0.634c8eb
|
|
pkgrel=03
|
|
pkgdesc='Day/night gamma adjustments for Wayland compositors'
|
|
url="https://git.sr.ht/~kennylevinsen/wlsunset"
|
|
makedepends=('git' 'meson' 'ninja' 'scdoc' 'wayland' 'wayland-protocols')
|
|
provides=('wlsunset')
|
|
conflicts=('wlsunset-git')
|
|
source=("$pkgname::git+$url")
|
|
|
|
_pkgver() {
|
|
cd "$pkgname"
|
|
|
|
# Git, tags available
|
|
printf "%s" "$(git describe --long | sed 's/\([^-]*-\)g/r\1/;s/-/./g')"
|
|
|
|
# Git, no tags available
|
|
# printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
|
|
}
|
|
|
|
build() {
|
|
cd "$pkgname"
|
|
arch-meson build
|
|
ninja -C build
|
|
}
|
|
|
|
package() {
|
|
cd "$pkgname"
|
|
depends=('wayland' 'wayland-protocols')
|
|
DESTDIR="$pkgdir" ninja -C build install
|
|
install -Dm644 LICENSE -t "$pkgdir/usr/share/licenses/$pkgname/"
|
|
}
|
|
|
|
#---- arch license gpg-key & sha256sums ----
|
|
|
|
arch=(x86_64)
|
|
|
|
license=('MIT')
|
|
|
|
sha256sums=('SKIP')
|
|
|
|
## b8cb3554c232eb275630765d3384880c755ea24bae2cf3dbd1a10d6939912925 wlsunset-0.4.1.pr-03-x86_64.pkg.tar.lz
|