49 lines
1.7 KiB
Text
49 lines
1.7 KiB
Text
# Maintainer: Laurent Carlier <lordheavym@gmail.com>
|
|
|
|
pkgname=xf86-video-amdgpu
|
|
pkgver=23.0.0
|
|
pkgrel=2
|
|
pkgdesc="X.org amdgpu video driver"
|
|
arch=('x86_64')
|
|
url="https://xorg.freedesktop.org/"
|
|
license=('MIT')
|
|
depends=('systemd-libs' 'mesa' 'libdrm' 'glibc')
|
|
makedepends=('xorg-server-devel' 'systemd' 'X-ABI-VIDEODRV_VERSION=25.2')
|
|
conflicts=('xorg-server<1.20.0' 'X-ABI-VIDEODRV_VERSION<25' 'X-ABI-VIDEODRV_VERSION>=26')
|
|
groups=('xorg-drivers')
|
|
source=(${url}/releases/individual/driver/${pkgname}-${pkgver}.tar.xz{,.sig})
|
|
sha512sums=('bf26f147629a34e84a0ae8435119e170b9c95edafcab1995b63bb8f55abef32f2efbf4536eb070e64b2ae1460424b1b27a4206cb9836d33ddc6dfbee404f718b'
|
|
'SKIP')
|
|
#validpgpkeys=('B09FAF35BE914521980951145A81AF8E6ADBB200') # Michel Daenzer <michel@daenzer.net>
|
|
#validpgpkeys=('017E91A875CBA321258380F19B4EE4F98474DE40') # "Alex Deucher <alexdeucher@gmail.com>"
|
|
validpgpkeys=('F1111E4AAF984C9763795FFE4B25B5180522B8D9') # Shashank Sharma <contactshashanksharma@gmail.com>
|
|
|
|
build() {
|
|
cd ${pkgname}-${pkgver}
|
|
|
|
# Since pacman 5.0.2-2, hardened flags are now enabled in makepkg.conf
|
|
# With them, module fail to load with undefined symbol.
|
|
# See https://bugs.archlinux.org/task/55102 / https://bugs.archlinux.org/task/54845
|
|
export CFLAGS=${CFLAGS/-fno-plt}
|
|
export CXXFLAGS=${CXXFLAGS/-fno-plt}
|
|
export LDFLAGS=${LDFLAGS/-Wl,-z,now}
|
|
|
|
#CFLAGS+=' -fcommon' # https://wiki.gentoo.org/wiki/Gcc_10_porting_notes/fno_common
|
|
|
|
./configure --prefix=/usr \
|
|
--enable-glamor
|
|
make
|
|
}
|
|
|
|
check() {
|
|
cd ${pkgname}-${pkgver}
|
|
make check
|
|
}
|
|
|
|
package() {
|
|
cd ${pkgname}-${pkgver}
|
|
|
|
make "DESTDIR=${pkgdir}" install
|
|
install -m755 -d "${pkgdir}/usr/share/licenses/${pkgname}"
|
|
install -m644 COPYING "${pkgdir}/usr/share/licenses/${pkgname}/"
|
|
}
|