jobextra/xf86-video-ati/PKGBUILD

94 lines
3.1 KiB
Bash

#!/usr/bin/bash
# JOBoRun : Jwm OpenBox Obarun RUNit
# Maintainer : Joe Bo Run <joborun@disroot.org>
# PkgSource : url="https://gittea.disroot.org/joborun-pkg/jobextra/$pkgname"
# Website : https://pozol.eu
#-----------------------------------------| DESCRIPTION |---------------------------------------
pkgname=xf86-video-ati
pkgver=22.0.0
pkgrel=02
epoch=1
pkgdesc="X.org ati video driver"
url="https://xorg.freedesktop.org/"
depends=('mesa' 'libpciaccess' 'libdrm' 'glibc')
makedepends=('xorg-server-devel' 'X-ABI-VIDEODRV_VERSION=25.2') # 'git')
conflicts=('xorg-server<21.1.1' 'X-ABI-VIDEODRV_VERSION<25' 'X-ABI-VIDEODRV_VERSION>=26')
groups=('xorg-drivers')
#source=("${pkgname}-${pkgver}::git+https://gitlab.freedesktop.org/xorg/driver/xf86-video-ati#commit=${_commit}")
source=(${url}/releases/individual/driver/${pkgname}-${pkgver}.tar.xz{,.sig})
#pkgver() {
# cd ${pkgname}*
# # from ati-git AUR pkg
# git describe --long | sed 's/^xf86-video-ati-//;s/\([^-]*-g\)/r\1/;s/-/./g'
#}
#
#
#prepare() {
# cd ${pkgname}*
#
## # fix a crash under Xorg-server 21.1.1
## # https://bugs.archlinux.org/task/72759
## # https://gitlab.freedesktop.org/xorg/driver/xf86-video-ati/-/merge_requests/9
## patch -Np1 -i ../0001_dont_set_sourcevalidate_pointer_to_null.diff
#
# NOCONFIGURE=1 ./autogen.sh
#}
build() {
# cd ${pkgname}* #-${pkgver}
cd ${pkgname}-${pkgver}
# CFLAGS+=' -fcommon' # https://wiki.gentoo.org/wiki/Gcc_10_porting_notes/fno_common
# Since pacman 5.0.2-2, hardened flags are now enabled in makepkg.conf
# With them, module fail to load with undefined symbol.
# See https://bugs.archlinux.org/task/55102 / https://bugs.archlinux.org/task/54845
export CFLAGS=${CFLAGS/-fno-plt}
export CXXFLAGS=${CXXFLAGS/-fno-plt}
export LDFLAGS=${LDFLAGS/-Wl,-z,now}
./configure --prefix=/usr
make
}
check() {
# cd ${pkgname}* #-${pkgver}
cd ${pkgname}-${pkgver}
make check
}
package() {
# cd ${pkgname}* #-${pkgver}
cd ${pkgname}-${pkgver}
make "DESTDIR=${pkgdir}" install
install -m755 -d "${pkgdir}/usr/share/licenses/${pkgname}"
install -m644 COPYING "${pkgdir}/usr/share/licenses/${pkgname}/"
}
#---- arch license gpg-key & sha256sums ----
arch=(x86_64)
license=('MIT')
#validpgpkeys=('B09FAF35BE914521980951145A81AF8E6ADBB200') # Michel Daenzer <michel@daenzer.net>
validpgpkeys=('3BB639E56F861FA2E86505690FDD682D974CA72A') # Matt Turner <mattst88@gmail.com>
sha512sums=('fba9ffc7b0eeb0c369eb1a6f8ef0bb3061cfeca26bc269baf6e3d16dcd943fbf4092f1e37adfb1bc71051cee0b7a0e6fb253f0b8bcd210732ccaf99e8f2356fe'
'SKIP')
sha256sums=(c8c8bb56d3f6227c97e59c3a3c85a25133584ceb82ab5bc05a902a743ab7bf6d # xf86-video-ati-22.0.0.tar.xz
4002f7e9f5431fa860efb06e39727536307886e34080e1a2be057161d672dc93) # xf86-video-ati-22.0.0.tar.xz.sig
## ee6650dcdd05c9ba80f998d66c5bdbcf63c752ce4fb861de064b773406bc1296 xf86-video-ati-1_22.0.0-02-x86_64.pkg.tar.lz
# Note to packager:
#ls -l *pkg.tar.lz
#echo "you must rename this package to meet SF naming before you move to the repo"
#mv $(ls -l $pkgname*pkg.tar.lz) $pkgname-$epoch_$pkgver-$pkgrel-$arch.pkg.tar.lz >pkg-mv.log