jobextra/xfce4-terminal/PKGBUILD

56 lines
1.5 KiB
Bash

#!/usr/bin/bash
# JOBoRun : Jwm OpenBox Obarun RUNit
# Maintainer : Joe Bo Run <joborun@disroot.org>
# PkgSource : url="https://gittea.disroot.org/joborun-pkg/jobextra/$pkgname"
# Website : https://pozol.eu
#-----------------------------------------| DESCRIPTION |---------------------------------------
## Last time building this flea dog and anythin xfce
## Unless all layers of logind and dbus are present this is the only vte terminal
## that fails to alter configuration due to dbus errors. Even if you edit the .conf file manually
pkgname=xfce4-terminal
pkgver=1.1.3
pkgrel=01
pkgdesc="An xfce4 modern terminal emulator no html docs"
url="https://docs.xfce.org/apps/terminal/start"
groups=('xfce4')
depends=('libxfce4ui' 'vte3' 'gtk-layer-shell' 'hicolor-icon-theme')
makedepends=('intltool')
source=(https://archive.xfce.org/src/apps/$pkgname/${pkgver%.*}/$pkgname-$pkgver.tar.bz2)
prepare() {
cd "$pkgname-$pkgver"
}
build() {
cd "$pkgname-$pkgver"
./configure \
--prefix=/usr \
--sysconfdir=/etc \
--enable-gtk-doc-html=no \
--enable-wayland \
--disable-systemd \
--disable-dbus \
--disable-debug
make
}
package() {
cd "$pkgname-$pkgver"
make DESTDIR="$pkgdir" install
}
#---- arch license gpg-key & sha256sums ----
arch=(x86_64)
license=('GPL2')
sha256sums=(214dd588d441b69f816009682a3bb4652cc19bed7ea64b612a12f097417b3d45) # xfce4-terminal-1.1.3.tar.bz2
## 10bc6aedc7808de8da8db9979849f682a94acffe1dc8c93437b39c138b15e6d9 xfce4-terminal-1.1.3-01-x86_64.pkg.tar.lz