jobextra/xorg-xwayland/PKGBUILD

75 lines
2.8 KiB
Bash

#!/usr/bin/bash
# JOBoRun : Jwm OpenBox Obarun RUNit
# Maintainer : Joe Bo Run <joborun@disroot.org>
# PkgSource : url="https://gittea.disroot.org/joborun-pkg/jobextra/$pkgname"
# Website : https://pozol.eu
#-----------------------------------------| DESCRIPTION |---------------------------------------
pkgname=xorg-xwayland
pkgver=23.2.6
pkgrel=02
groups=('xorg')
url="https://xorg.freedesktop.org"
pkgdesc="run X clients under wayland w/o ipv6 just like xorg-server"
provides=('xorg-server-xwayland')
depends=('nettle' 'libepoxy' 'libxfont2' 'libei'
'pixman' 'xorg-server-common' 'libxcvt' 'mesa'
'libglvnd' 'libxau' 'wayland' 'libdrm' 'libtirpc'
'libxshmfence' 'glibc')
makedepends=('meson' 'xorgproto' 'xtrans' 'libxkbfile' # 'dbus'
'xorg-font-util' 'wayland-protocols' 'mesa-libgl'
'egl-wayland')
source=(https://xorg.freedesktop.org/archive/individual/xserver/xwayland-$pkgver.tar.xz{,.sig})
provides=('xorg-server-xwayland')
conflicts=('xorg-server-xwayland')
replaces=('xorg-server-xwayland')
build() {
arch-meson xwayland-$pkgver build \
-D ipv6=false \
-D xvfb=false \
-D xdmcp=false \
-D xcsecurity=true \
-D dri3=true \
-D xwayland_eglstream=true \
-D glamor=true \
-D xkb_dir=/usr/share/X11/xkb \
-D xkb_output_dir=/var/lib/xkb
# Print config
meson configure build
ninja -C build
}
package() {
DESTDIR="${pkgdir}" ninja -C build install
# xorg-server-common file /usr/lib/xorg/protocol.txt
rm "${pkgdir}"/usr/lib/xorg/protocol.txt
rmdir "${pkgdir}"/usr/lib/xorg
rm "${pkgdir}"/usr/share/man/man1/Xserver.1
# license
install -m644 -Dt "${pkgdir}/usr/share/licenses/${pkgname}" xwayland-$pkgver/COPYING
}
#---- arch license gpg-key & sha256sums ----
arch=(x86_64)
license=(LicenseRef-Adobe-Display-PostScript BSD-3-Clause LicenseRef-DEC-3-Clause HPND LicenseRef-HPND-sell-MIT-disclaimer-xserver HPND-sell-variant ICU ISC MIT MIT-open-group NTP SGI-B-2.0 SMLNJ X11 X11-distribute-modifications-variant)
#validpgpkeys=('B09FAF35BE914521980951145A81AF8E6ADBB200') # "Michel Daenzer <michel@daenzer.net>"
#validpgpkeys=('3C2C43D9447D5938EF4551EBE23B7E70B467F0BF') # Peter Hutterer (Who-T) <office@who-t.net>
validpgpkeys=('67DC86F2623FC5FD4BB5225D14706DBE1E4B4540') # "Olivier Fourdan <fourdan@xfce.org>"
sha512sums=('9e3c2253af335a559d0f890fa8f9bc381beca6531e0842d739ac15cbca008b3d07c0eefafd03611b04917c626861a7871a83657afa2a298994f4b162f714fc49'
'SKIP')
sha256sums=(1c9a366b4e7ccadba0f9bd313c59eae12d23bd72543b22a26eaf8b20835cfc6d # xwayland-23.2.6.tar.xz
5c2b30ba2bd562d73f9dbf996eacd6586a1c07ee78813b54ab3b09eb92d95fa1) # xwayland-23.2.6.tar.xz.sig
## b76a92d1337475ee83ce267d33eeed80d16ac97527458700d2411f65e29d92ea xorg-xwayland-23.2.6-02-x86_64.pkg.tar.lz