jobextra/libinput/PKGBUILD.0

103 lines
3.8 KiB
Bash

#!/usr/bin/bash
# JOBoRun : Jwm OpenBox Obarun RUNit
# Maintainer : Joe Bo Run <joborun@disroot.org>
# PkgSource : url="https://gittea.disroot.org/joborun-pkg/jobcextra/$pkgname"
#-----------------------------------------| DESCRIPTION |---------------------------------------
pkgname=libinput
pkgver=1.19.3
pkgrel=02
pkgdesc="Input device management and event handling library"
url="https://www.freedesktop.org/wiki/Software/libinput/"
arch=(x86_64)
depends=('mtdev' 'libevdev' 'libwacom')
# upstream doesn't recommend building docs
makedepends=('gtk3' 'meson' 'wayland-protocols' 'cmake' 'gtk4') # 'doxygen' 'graphviz' 'python-sphinx' 'python-recommonmark'
optdepends=('gtk3: libinput debug-gui'
'python-pyudev: libinput measure'
'python-libevdev: libinput measure')
source=(https://freedesktop.org/software/$pkgname/$pkgname-$pkgver.tar.xz{,.sig})
build() {
arch-meson $pkgname-$pkgver build \
-D b_lto=false \
-D udev-dir=/usr/lib/udev \
-D tests=false \
-D documentation=false
meson compile -C build
}
package() {
DESTDIR="$pkgdir" meson install -C build
install -Dvm644 $pkgname-$pkgver/COPYING \
"$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}
#---- license gpg-key sha256sums ----
license=(custom:X11)
validpgpkeys=('3C2C43D9447D5938EF4551EBE23B7E70B467F0BF') # Peter Hutterer (Who-T) <office@who-t.net>
sha256sums=(3cae78ccde19d7d0f387e58bc734d4d17ab5f6426f54a9e8b728c90b17baa068 # libinput-1.19.3.tar.xz
db134d7f37e85160373f7377bacd6bd33ffe6a25b756d927ef63e9809b7107fd) # libinput-1.19.3.tar.xz.sig
####### diffs between old and new Arch PKGBUILD
--- PKGBUILD-arch 2022-01-25 16:08:27.211291154 +0000
+++ PKGBUILD-arch.new 2022-02-20 07:21:57.296817153 +0000
@@ -1,30 +1,34 @@
# Maintainer: Andreas Radke <andyrtr@archlinux.org>
-# Maintainer: Jan de Groot
pkgname=libinput
-pkgver=1.19.3
-pkgrel=2
+pkgver=1.20.0
+pkgrel=1
pkgdesc="Input device management and event handling library"
-url="https://www.freedesktop.org/wiki/Software/libinput/"
+url="https://gitlab.freedesktop.org/libinput"
arch=(x86_64)
license=(custom:X11)
depends=('mtdev' 'systemd' 'libevdev' 'libwacom')
# upstream doesn't recommend building docs
-makedepends=('gtk3' 'meson' 'wayland-protocols') # 'doxygen' 'graphviz' 'python-sphinx' 'python-recommonmark'
-optdepends=('gtk3: libinput debug-gui'
+makedepends=('gtk4' 'meson' 'wayland-protocols') # 'doxygen' 'graphviz' 'python-sphinx' 'python-recommonmark'
+optdepends=('gtk4: libinput debug-gui'
'python-pyudev: libinput measure'
'python-libevdev: libinput measure')
-source=(https://freedesktop.org/software/$pkgname/$pkgname-$pkgver.tar.xz{,.sig})
-sha512sums=('f4b776d0da78c687ba21b430a04941ac6b43f68970c82ec9f7360358fdea5ed6a873948ce66a25bcdd64d4b95fa4bf705cc24dbc25c7c0f5fd2d0efbd763f298'
- 'SKIP')
-validpgpkeys=('3C2C43D9447D5938EF4551EBE23B7E70B467F0BF') # Peter Hutterer (Who-T) <office@who-t.net>
+source=(#https://freedesktop.org/software/$pkgname/$pkgname-$pkgver.tar.xz{,.sig}
+ https://gitlab.freedesktop.org/libinput/libinput/-/archive/$pkgver/$pkgname-$pkgver.tar.bz2 #{,.sig}.tar.bz2
+)
+#sha512sums=('f4b776d0da78c687ba21b430a04941ac6b43f68970c82ec9f7360358fdea5ed6a873948ce66a25bcdd64d4b95fa4bf705cc24dbc25c7c0f5fd2d0efbd763f298'
+# 'SKIP')
+sha512sums=('145b0e0760929137ab442b2030b4b42f6df54a3ae61c47c929e1a74857a170f0f2a56bb7522b7d1d9c0943028ac54c7728cf8d66a0c384f6118f31d6625ab44c')
+#validpgpkeys=('3C2C43D9447D5938EF4551EBE23B7E70B467F0BF') # Peter Hutterer (Who-T) <office@who-t.net>
build() {
arch-meson $pkgname-$pkgver build \
- -D b_lto=false \
-D udev-dir=/usr/lib/udev \
-D tests=false \
-D documentation=false
+
+ # Print config
+ meson configure build
meson compile -C build
}
#### systemd crap in new PKGBUILD
scan for systemd ipv6 service & socket
depends=('mtdev' 'systemd' 'libevdev' 'libwacom')