add ports

This commit is contained in:
Javier 2024-03-12 21:07:50 -05:00
commit c3675671af
17 changed files with 350 additions and 0 deletions

2
mpd/.checksums Normal file
View File

@ -0,0 +1,2 @@
4d97b22c37ca8c0939830cd6497023d868005a123f866db594716027c590e2d1dffb65bbd3af41404dcc7c0249466192e457ae1ba80f1f95ff044516be4c99ae mpd-0.23.14.tar.xz
84845c4ce6a24cde50196c36fef61fea50f34750d13fd158ac4ed8b5469ca2c2adc93e987ef61c67af35e3f1cf12674fd340c21bf3f7d0706da6b0af652d6b39 rc.mpd

15
mpd/.pkgfiles Normal file
View File

@ -0,0 +1,15 @@
mpd-0.23.14-1
drwxr-xr-x root/root etc/
drwxr-xr-x root/root etc/mpd/
-rw-r--r-- root/root etc/mpd/mpd.conf
drwxr-xr-x root/root etc/rc.d/
-rwxr-xr-x root/root etc/rc.d/mpd
drwxr-xr-x root/root usr/
drwxr-xr-x root/root usr/bin/
-rwxr-xr-x root/root usr/bin/mpd
drwxr-xr-x root/root usr/share/
drwxr-xr-x root/root usr/share/icons/
drwxr-xr-x root/root usr/share/icons/hicolor/
drwxr-xr-x root/root usr/share/icons/hicolor/scalable/
drwxr-xr-x root/root usr/share/icons/hicolor/scalable/apps/
-rw-r--r-- root/root usr/share/icons/hicolor/scalable/apps/mpd.svg

6
mpd/pre.install.sh Normal file
View File

@ -0,0 +1,6 @@
#!/bin/sh
useradd -c "mpd music daemon" -d /var/lib/mpd -s /bin/false -g audio -g mpd mpd 2>/dev/null
exit 0

32
mpd/rc.mpd Normal file
View File

@ -0,0 +1,32 @@
#!/bin/sh
#
# /etc/rc.d/mpd: start/stop mpd daemon
#
. /etc/rc.subr
NAME="Mpv daemon"
PROG=/usr/bin/mpd
OPTS=""
case $1 in
start)
start_daemon $PROG $OPTS
;;
stop)
stop_daemon $PROG
;;
restart)
$0 stop
sleep 1
$0 start
;;
status)
status_daemon $PROG
;;
*)
echo "usage: $0 [start|stop|restart|status]"
;;
esac
# End of file

58
mpd/spkgbuild Normal file
View File

@ -0,0 +1,58 @@
# description : Music playback daemon
# homepage : https://www.musicpd.org/
# depends : boost fmt libpcre2 meson ninja alsa-lib libsndfile ffmpeg
# optional : audiofile avahi dbus faad2 flac fluidsynth icu jack lame libcdio-paranoia
# optional : libid3tag libisofs libmad libmpcdec libsamplerate mpg123
# optional : pipewire pulseaudio python3-sphinx samba twolame yajl
# optional : libsoxr wavpack
name=mpd
version=0.23.14
release=1
source="https://www.musicpd.org/download/$name/0.23/$name-$version.tar.xz
rc.mpd"
build() {
venom-meson $name-$version build \
--auto-features disabled \
-D curl=enabled \
-D bzip2=enabled \
-D iconv=enabled \
-D ipv6=enabled \
-D pcre=enabled \
-D sqlite=enabled \
-D alsa=enabled \
-D sndfile=enabled \
-D audiofile=$(scratch isinstalled audiofile && echo enabled || echo disabled) \
-D dbus=$(scratch isinstalled dbus && echo enabled || echo disabled) \
-D faad=$(scratch isinstalled faad2 && echo enabled || echo disabled) \
-D flac=$(scratch isinstalled flac && echo enabled || echo disabled) \
-D fluidsynth=$(scratch isinstalled fluidsynth && echo enabled || echo disabled) \
-D icu=$(scratch isinstalled icu && echo enabled || echo disabled) \
-D jack=$(scratch isinstalled jack && echo enabled || echo disabled) \
-D lame=$(scratch isinstalled lame && echo enabled || echo disabled) \
-D cdio_paranoia=$(scratch isinstalled libcdio-paranoia && echo enabled || echo disabled) \
-D id3tag=$(scratch isinstalled libid3tag && echo enabled || echo disabled) \
-D iso9660=$(scratch isinstalled libisofs && echo enabled || echo disabled) \
-D mad=$(scratch isinstalled libmad && echo enabled || echo disabled) \
-D libsamplerate=$(scratch isinstalled libsamplerate && echo enabled || echo disabled) \
-D soxr=$(scratch isinstalled libsoxr && echo enabled || echo disabled) \
-D mpcdec=$(scratch isinstalled libmpcdec && echo enabled || echo disabled) \
-D mpg123=$(scratch isinstalled mpg123 && echo enabled || echo disabled) \
-D pulse=$(scratch isinstalled pulseaudio && echo enabled || echo disabled) \
-D pipewire=$(scratch isinstalled pipewire && echo enabled || echo disabled) \
-D smbclient=$(scratch isinstalled samba && echo enabled || echo disabled) \
-D twolame=$(scratch isinstalled twolame && echo enabled || echo disabled) \
-D wavpack=$(scratch isinstalled wavpack && echo enabled || echo disabled) \
-D yajl=$(scratch isinstalled yajl && echo enabled || echo disabled) \
-D html_manual=false
meson compile -C build
DESTDIR=$PKG meson install --no-rebuild -C build
install -Dm 0644 $SRC/$name-$version/doc/mpdconf.example $PKG/etc/mpd/mpd.conf
install -D $SRC/rc.mpd $PKG/etc/rc.d/mpd
rm -r $PKG/usr/share/doc
}

2
ncmpcpp/.checksums Normal file
View File

@ -0,0 +1,2 @@
bbcb3b50233e363412af3c1cf1c0118122733dc376759cd35dee79950f42e098a0402ff670684df91847b990b26022630c9a71192e462bd46e70628e31489742 ncmpcpp-0.9.2.tar.bz2
f8693b615a414ddd2a6a0817c68af0485755556f9e20d08df6d7e05ede74c881480ef3139e0499bc1c645541b19de57958456e5dc079712882636bfd95ae2bc4 taglib2.patch

11
ncmpcpp/.pkgfiles Normal file
View File

@ -0,0 +1,11 @@
ncmpcpp-0.9.2-3
drwxr-xr-x root/root usr/
drwxr-xr-x root/root usr/bin/
-rwxr-xr-x root/root usr/bin/ncmpcpp
drwxr-xr-x root/root usr/share/
drwxr-xr-x root/root usr/share/man/
drwxr-xr-x root/root usr/share/man/man1/
-rw-r--r-- root/root usr/share/man/man1/ncmpcpp.1.gz
drwxr-xr-x root/root usr/share/ncmpcpp/
-rw-r--r-- root/root usr/share/ncmpcpp/bindings
-rw-r--r-- root/root usr/share/ncmpcpp/config

30
ncmpcpp/spkgbuild Normal file
View File

@ -0,0 +1,30 @@
# description : Almost exact clone of ncmpc with some new features
# depends : boost libmpdclient icu ncurses readline taglib curl
name=ncmpcpp
version=0.9.2
release=3
source="https://rybczak.net/ncmpcpp/stable/$name-$version.tar.bz2
taglib2.patch"
build() {
cd $name-$version
echo "ncmpcpp javier version"
patch -Np1 -i $SRC/taglib2.patch
./configure --prefix=/usr \
--enable-clock \
--enable-outputs \
--enable-visualizer \
--with-taglib
make
make DESTDIR=$PKG install
mkdir -p $PKG/usr/share/$name
mv $PKG/usr/share/doc/$name/config \
$PKG/usr/share/doc/$name/bindings \
$PKG/usr/share/$name
sed -i 's,/usr/share/doc/,/usr/share/,g' \
$PKG/usr/share/man/man1/ncmpcpp.1
}

43
ncmpcpp/taglib2.patch Normal file
View File

@ -0,0 +1,43 @@
diff --git a/extras/artist_to_albumartist.cpp b/extras/artist_to_albumartist.cpp
index c3ddfee3..bf5aac29 100644
--- a/extras/artist_to_albumartist.cpp
+++ b/extras/artist_to_albumartist.cpp
@@ -34,7 +34,7 @@ enum class CopyResult { Success, NoArtist, AlbumArtistAlreadyInPlace };
bool is_framelist_empty(const TagLib::ID3v2::FrameList &list)
{
for (auto it = list.begin(); it != list.end(); ++it)
- if ((*it)->toString() != TagLib::String::null)
+ if ((*it)->toString() != TagLib::String())
return false;
return true;
}
diff --git a/src/tags.cpp b/src/tags.cpp
index 6cd6a8c2..09731801 100644
--- a/src/tags.cpp
+++ b/src/tags.cpp
@@ -123,12 +123,12 @@ void writeCommonTags(const MPD::MutableSong &s, TagLib::Tag *tag)
tag->setArtist(ToWString(s.getArtist()));
tag->setAlbum(ToWString(s.getAlbum()));
try {
- tag->setYear(boost::lexical_cast<TagLib::uint>(s.getDate()));
+ tag->setYear(boost::lexical_cast<uint>(s.getDate()));
} catch (boost::bad_lexical_cast &) {
std::cerr << "writeCommonTags: couldn't write 'year' tag to '" << s.getURI() << "' as it's not a positive integer\n";
}
try {
- tag->setTrack(boost::lexical_cast<TagLib::uint>(s.getTrack()));
+ tag->setTrack(boost::lexical_cast<uint>(s.getTrack()));
} catch (boost::bad_lexical_cast &) {
std::cerr << "writeCommonTags: couldn't write 'track' tag to '" << s.getURI() << "' as it's not a positive integer\n";
}
@@ -306,7 +306,7 @@ bool write(MPD::MutableSong &s)
{
writeID3v2Tags(s, mpeg_file->ID3v2Tag(true));
// write id3v2.4 tags only
- if (!mpeg_file->save(TagLib::MPEG::File::ID3v2, true, 4, false))
+ if (!mpeg_file->save(TagLib::MPEG::File::ID3v2, TagLib::File::StripTags::StripNone, TagLib::ID3v2::Version::v4, TagLib::File::DuplicateTags::DoNotDuplicate))
return false;
// do not call generic save() as it will duplicate tags
saved = true;

1
zzzfm-bin/.checksum Normal file
View File

@ -0,0 +1 @@
21de0bee0aaaf6da10d5adbb564b13e6e30bfaafbde692c5edb0f7508bf81c221b4bdf0fa22be61a0319925207484581fee7a0699dfa87e02daf47f5d9e3bbf7 zzzfm-common_1.0.7-6~contribs2_all.deb

2
zzzfm-bin/.checksums Normal file
View File

@ -0,0 +1,2 @@
21de0bee0aaaf6da10d5adbb564b13e6e30bfaafbde692c5edb0f7508bf81c221b4bdf0fa22be61a0319925207484581fee7a0699dfa87e02daf47f5d9e3bbf7 zzzfm-common_1.0.7-6~contribs2_all.deb
b147db6ddab1c3ffd91f6d374e16007d525e5eb2541536d99dafa071164cc4a8aa54dd855a62ed97dd972d3bcf931f5663276f42a0e109752354785cefeac68a zzzfm_1.0.7-6~contribs2_amd64.deb

24
zzzfm-bin/.pkgfiles Normal file
View File

@ -0,0 +1,24 @@
zzzfm-bin-1.0.7-1
drwxr-xr-x root/root etc/
drwxr-xr-x root/root etc/xdg/
drwxr-xr-x root/root etc/xdg/zzzfm/
-rw-r--r-- root/root etc/xdg/zzzfm/README_setup.txt
-rw-r--r-- root/root etc/xdg/zzzfm/session
drwxr-xr-x root/root etc/zzzfm/
-rw-r--r-- root/root etc/zzzfm/zzzfm.conf
drwxr-xr-x root/root usr/
drwxr-xr-x root/root usr/bin/
-rwxr-xr-x root/root usr/bin/zzzfm
-rwxr-xr-x root/root usr/bin/zzzfm-auth
drwxr-xr-x root/root usr/share/
drwxr-xr-x root/root usr/share/applications/
-rw-r--r-- root/root usr/share/applications/zzzfm-find.desktop
-rw-r--r-- root/root usr/share/applications/zzzfm-folder-handler.desktop
-rw-r--r-- root/root usr/share/applications/zzzfm.desktop
drwxr-xr-x root/root usr/share/man/
drwxr-xr-x root/root usr/share/man/man1/
-rw-r--r-- root/root usr/share/man/man1/zzzfm-auth.1.gz
-rw-r--r-- root/root usr/share/man/man1/zzzfm.1.gz
drwxr-xr-x root/root usr/share/zzzfm/
-rw-r--r-- root/root usr/share/zzzfm/COPYING
-rw-r--r-- root/root usr/share/zzzfm/COPYING-LGPL

21
zzzfm-bin/spkgbuild Normal file
View File

@ -0,0 +1,21 @@
# description : ZzzFM is a multi-panel tabbed file and desktop manager for Linux. This package contains files used by both the GTK+2 (zzzfm) and GTK+3 (zzzfm-gtk3) versions.
# homepage : https://gitlab.com/skidoo/zzzfm
# depends : cairo desktop-file-utils e2fsprogs gdk-pixbuf glibc gtk2 hicolor-icon-theme udev libx11 pango shared-mime-info
name=zzzfm-bin
version=1.0.7
release=1
noextract=""
backup=""
source="https://gitlab.com/antix-contribs/zzzfm/-/raw/contribs/deb-packages/zzzfm_1.0.7-6~contribs2_amd64.deb
https://gitlab.com/antix-contribs/zzzfm/-/raw/contribs/deb-packages/zzzfm-common_1.0.7-6~contribs2_all.deb"
noextract="zzzfm-common_1.0.7-6~contribs2_all.deb zzzfm_1.0.7-6~contribs2_amd64.deb"
sources="zzzfm-common_1.0.7-6~contribs2_all.deb zzzfm_1.0.7-6~contribs2_amd64.deb"
build() {
mkdir common bin
bsdtar -xf zzzfm-common_1.0.7-6~contribs2_all.deb -C common
bsdtar -xf zzzfm_1.0.7-6~contribs2_amd64.deb -C bin
bsdtar -xf bin/data.tar.xz -C $PKG
bsdtar -xf common/data.tar.xz -C $PKG
}

2
zzzfm/.checksums Normal file
View File

@ -0,0 +1,2 @@
92ca67d5cd4e4f238dd1b379a7966e1f9cf3e6924fe7a2bfa0fa537c02ed7843a8fcff61ef735b40c5d313e43a59253a1c0de1421c6e38e9becb23f009fabebd gtk3.patch
c2d09a1b8f32b703e844ef2c99d0efb13a96e93e95e773ec42a9f7323fbe01c75edff36d889930e173a63ae0c7e852ecf396023806c83472915b7dd9910f0384 zzzfm-1.0.7-5.tar.gz

37
zzzfm/.pkgfiles Normal file
View File

@ -0,0 +1,37 @@
zzzfm-1.0.7-1
drwxr-xr-x root/root etc/
drwxr-xr-x root/root etc/zzzfm/
-rw-r--r-- root/root etc/zzzfm/zzzfm.conf
drwxr-xr-x root/root usr/
drwxr-xr-x root/root usr/bin/
-rwxr-xr-x root/root usr/bin/zzzfm
-rwxr-xr-x root/root usr/bin/zzzfm-auth
drwxr-xr-x root/root usr/share/
drwxr-xr-x root/root usr/share/applications/
-rw-r--r-- root/root usr/share/applications/zzzfm-find.desktop
-rw-r--r-- root/root usr/share/applications/zzzfm-folder-handler.desktop
-rw-r--r-- root/root usr/share/applications/zzzfm.desktop
drwxr-xr-x root/root usr/share/mime/
drwxr-xr-x root/root usr/share/mime/packages/
-rw-r--r-- root/root usr/share/mime/packages/zzzfm-mime.xml
drwxr-xr-x root/root usr/share/pixmaps/
-rw-r--r-- root/root usr/share/pixmaps/zzzfm-128-cube-blue.png
-rw-r--r-- root/root usr/share/pixmaps/zzzfm-128-cube-red.png
-rw-r--r-- root/root usr/share/pixmaps/zzzfm-48-cube-blue.png
-rw-r--r-- root/root usr/share/pixmaps/zzzfm-48-cube-red.png
-rw-r--r-- root/root usr/share/pixmaps/zzzfm-48-folder-blue.png
-rw-r--r-- root/root usr/share/pixmaps/zzzfm-48-folder-red.png
-rw-r--r-- root/root usr/share/pixmaps/zzzfm-find.png
-rw-r--r-- root/root usr/share/pixmaps/zzzfm-root.png
-rw-r--r-- root/root usr/share/pixmaps/zzzfm-root24.png
-rw-r--r-- root/root usr/share/pixmaps/zzzfm.png
-rw-r--r-- root/root usr/share/pixmaps/zzzfm24.png
drwxr-xr-x root/root usr/share/zzzfm/
drwxr-xr-x root/root usr/share/zzzfm/ui/
-rw-r--r-- root/root usr/share/zzzfm/ui/appchooserdlg.ui
-rw-r--r-- root/root usr/share/zzzfm/ui/file_properties.ui
-rw-r--r-- root/root usr/share/zzzfm/ui/find-files.ui
-rw-r--r-- root/root usr/share/zzzfm/ui/find-files2.ui
-rw-r--r-- root/root usr/share/zzzfm/ui/godlg.ui
-rw-r--r-- root/root usr/share/zzzfm/ui/prefdlg.ui
-rw-r--r-- root/root usr/share/zzzfm/ui/prefdlg2.ui

44
zzzfm/gtk3.patch Normal file
View File

@ -0,0 +1,44 @@
--- a/configure-ori.ac 2024-03-10 20:31:36.618202374 +0100
+++ b/configure.ac 2024-03-10 20:33:51.714209343 +0100
@@ -63,26 +63,11 @@
AC_ARG_WITH([gtk3], AS_HELP_STRING([--with-gtk3], [Build with GTK3 interface instead of GTK2 (default: with GTK2 unless GTK2 not installed)]), with_gtk3=$withval, with_gtk3="no")
-AC_ARG_WITH([gtk2], AS_HELP_STRING([--with-gtk2], [Build with GTK2 interface only (default: with GTK2 unless GTK2 not installed)]), with_gtk2=$withval, with_gtk2="no")
-if test x"$with_gtk3" = x"yes"; then
# user enabled - gtk3 required
- PKG_CHECK_MODULES(GTK, [$gtk3_modules])
- AC_DEFINE([HAVE_GTK3], [1], [Use GTK3])
-elif test x"$with_gtk2" = x"yes"; then
- # user enabled - gtk2 required
- PKG_CHECK_MODULES(GTK, [$gtk2_modules])
-else
- # disabled - use gtk3 only if gtk2 not installed
- PKG_CHECK_MODULES(GTK, [$gtk2_modules], with_gtk3="no", [
- PKG_CHECK_MODULES(GTK, [$gtk3_modules], with_gtk3="yes", with_gtk3="no")
- ])
- if test x"$with_gtk3" = x"yes"; then
- AC_DEFINE([HAVE_GTK3], [1], [Use GTK3])
- else
- PKG_CHECK_MODULES(GTK, [$gtk2_modules])
- fi
-fi
+PKG_CHECK_MODULES(GTK, [$gtk3_modules])
+AC_DEFINE([HAVE_GTK3], [1], [Use GTK3])
+AC_DEFINE([HAVE_GTK3], [1], [Use GTK3])
AC_SUBST([GTK_CFLAGS])
AC_SUBST([GTK_LIBS])
@@ -296,11 +281,7 @@
fi
echo 64-bit Large file support.................... : $largefile
-if test x"$with_gtk3" = x"yes"; then
echo 'GTK+ Version................................. : GTK 3'
-else
-echo 'GTK+ Version................................. : GTK 2'
-fi
echo Desktop manager integration.................. : $desktop_integration
echo Video thumbnail support...................... : $video_thumbnails
echo

20
zzzfm/spkgbuild Normal file
View File

@ -0,0 +1,20 @@
# description : Multi-panel tabbed file manager - gtk2 version
# homepage : https://gitlab.com/skidoo/zzzfm
# depends : gtk3 e2fsprogs ffmpegthumbnailer gdk-pixbuf2 initltool
# depends : hicolor-icon-theme util-linux lsof wget udevil
name=zzzfm
version=1.0.7
build=5
release=1
source="https://gitlab.com/skidoo/$name/-/archive/$version-$build/$name-$version-$build.tar.gz
gtk3.patch"
build() {
cd $name-$version-$build
patch -Np1 -i $SRC/gtk3.patch
CONFIG_SHELL=/bin/bash ./autogen.sh --with-gkt3 --prefix=/usr
make
make DESTDIR=$PKG install
}