- Update to 7.300.1

- Re-add the config.hpp patch

PR:		211559
Submitted by:	pi
This commit is contained in:
Danilo Egea Gondolfo 2016-08-03 19:37:59 +00:00
parent 118c457e89
commit 001b628a5e
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=419544
5 changed files with 40 additions and 6 deletions

View file

@ -1,7 +1,7 @@
# $FreeBSD$
PORTNAME= armadillo
PORTVERSION= 7.100.3
PORTVERSION= 7.300.1
CATEGORIES= math
MASTER_SITES= SF/arma
@ -11,6 +11,7 @@ COMMENT= C++ linear algebra library
LICENSE= MPL
LIB_DEPENDS= libboost_date_time.so:devel/boost-libs \
libopenblasp.so:math/openblas \
libarpack.so:math/arpack \
libhdf5.so:science/hdf5 \
libsuperlu.so:math/superlu

View file

@ -1,3 +1,3 @@
TIMESTAMP = 1465123703
SHA256 (armadillo-7.100.3.tar.xz) = 3fa4a2f84b54d48260efd587d7e6290618bc909d191bec0a3084a890af699d1e
SIZE (armadillo-7.100.3.tar.xz) = 3715272
TIMESTAMP = 1470241704
SHA256 (armadillo-7.300.1.tar.xz) = 5404744e89294ad9d47d651f2f95325840ba268b7fe374e2e40ef217d2f44bce
SIZE (armadillo-7.300.1.tar.xz) = 3994936

View file

@ -1,4 +1,4 @@
--- CMakeLists.txt.orig 2016-05-25 08:46:44 UTC
--- CMakeLists.txt.orig 2016-06-16 16:16:01 UTC
+++ CMakeLists.txt
@@ -368,12 +368,12 @@ if(NOT INSTALL_LIB_DIR)
message(STATUS "*** Detected 64 bit system")

View file

@ -0,0 +1,27 @@
--- include/armadillo_bits/config.hpp.orig 2016-08-03 19:20:44 UTC
+++ include/armadillo_bits/config.hpp
@@ -32,13 +32,13 @@
#endif
#if !defined(ARMA_USE_ARPACK)
-// #define ARMA_USE_ARPACK
+#define ARMA_USE_ARPACK
//// Uncomment the above line if you have ARPACK or a high-speed replacement for ARPACK.
//// ARPACK is required for eigen decompositions of complex sparse matrices
#endif
#if !defined(ARMA_USE_SUPERLU)
-// #define ARMA_USE_SUPERLU
+#define ARMA_USE_SUPERLU
//// Uncomment the above line if you have SuperLU.
//// SuperLU is used for solving sparse linear systems via spsolve()
//// Caveat: only SuperLU version 5.2 can be used!
@@ -76,7 +76,7 @@
//// Uncomment the above line if you want to use Intel MKL mkl_malloc() and mkl_free() instead of standard malloc() and free()
// #define ARMA_USE_ATLAS
-// #define ARMA_ATLAS_INCLUDE_DIR /usr/include/
+#define ARMA_ATLAS_INCLUDE_DIR /usr/local/include/
//// If you're using ATLAS and the compiler can't find cblas.h and/or clapack.h
//// uncomment the above define and specify the appropriate include directory.
//// Make sure the directory has a trailing /

View file

@ -137,6 +137,8 @@ include/armadillo_bits/fn_find_unique.hpp
include/armadillo_bits/fn_flip.hpp
include/armadillo_bits/fn_hist.hpp
include/armadillo_bits/fn_histc.hpp
include/armadillo_bits/fn_index_max.hpp
include/armadillo_bits/fn_index_min.hpp
include/armadillo_bits/fn_inplace_strans.hpp
include/armadillo_bits/fn_inplace_trans.hpp
include/armadillo_bits/fn_interp1.hpp
@ -323,6 +325,10 @@ include/armadillo_bits/op_hist_bones.hpp
include/armadillo_bits/op_hist_meat.hpp
include/armadillo_bits/op_htrans_bones.hpp
include/armadillo_bits/op_htrans_meat.hpp
include/armadillo_bits/op_index_max_bones.hpp
include/armadillo_bits/op_index_max_meat.hpp
include/armadillo_bits/op_index_min_bones.hpp
include/armadillo_bits/op_index_min_meat.hpp
include/armadillo_bits/op_inv_bones.hpp
include/armadillo_bits/op_inv_meat.hpp
include/armadillo_bits/op_logmat_bones.hpp
@ -474,7 +480,7 @@ include/armadillo_bits/xvec_htrans_bones.hpp
include/armadillo_bits/xvec_htrans_meat.hpp
lib/libarmadillo.so
lib/libarmadillo.so.7
lib/libarmadillo.so.7.100.3
lib/libarmadillo.so.7.300.0
share/Armadillo/CMake/ArmadilloConfig.cmake
share/Armadillo/CMake/ArmadilloConfigVersion.cmake
share/Armadillo/CMake/ArmadilloLibraryDepends-release.cmake