databases/mydumper: Update to 0.16.1-2

Changes:	https://github.com/mydumper/mydumper/releases
This commit is contained in:
Po-Chuan Hsieh 2024-03-23 22:18:08 +08:00
parent 9915c8755e
commit 00493afae3
No known key found for this signature in database
GPG Key ID: 9A4BD10F002DD04B
4 changed files with 9 additions and 20 deletions

View File

@ -1,6 +1,6 @@
PORTNAME= mydumper
DISTVERSIONPREFIX= v
DISTVERSION= 0.15.1-3
DISTVERSION= 0.16.1-2
CATEGORIES= databases
MAINTAINER= sunpoet@FreeBSD.org
@ -17,7 +17,7 @@ USE_GNOME= glib20
CMAKE_ARGS= ${CMAKE_ARGS_${CHOSEN_COMPILER_TYPE}}
CMAKE_ARGS_gcc= -DMYSQL_LIBRARIES_atomic:FILEPATH=${LOCALBASE}/lib/gcc${GCC_DEFAULT}/libatomic.so
CMAKE_OFF= BUILD_DOCS WITH_BINLOG
CMAKE_ON= WITH_GLIB_uuid_string_random
CMAKE_ON= WITH_GLIB_uuid_string_random WITH_SSL
PLIST_FILES= sbin/mydumper sbin/myloader

View File

@ -1,3 +1,3 @@
TIMESTAMP = 1692211635
SHA256 (mydumper-mydumper-v0.15.1-3_GH0.tar.gz) = a25bcb283b2eab192640da2e55ab7798d92293693bb717fb1490d59bc35887ee
SIZE (mydumper-mydumper-v0.15.1-3_GH0.tar.gz) = 165488
TIMESTAMP = 1710712310
SHA256 (mydumper-mydumper-v0.16.1-2_GH0.tar.gz) = 4a347fbfa84efa2d20427ee36883bf6f288fe59c552c95468e7a320e72814774
SIZE (mydumper-mydumper-v0.16.1-2_GH0.tar.gz) = 187141

View File

@ -1,11 +1,11 @@
--- CMakeLists.txt.orig 2023-08-02 14:40:15 UTC
--- CMakeLists.txt.orig 2024-03-06 21:10:19 UTC
+++ CMakeLists.txt
@@ -30,7 +30,7 @@ if (MARIADB_FOUND AND NOT MARIADB_SSL AND WITH_SSL)
@@ -44,7 +44,7 @@ endif()
set(WITH_SSL OFF)
endif()
-set(CMAKE_C_FLAGS "-Wall -Wno-deprecated-declarations -Wunused -Wwrite-strings -Wno-strict-aliasing -Wextra -Wshadow -g -Werror ${MYSQL_CFLAGS}")
+set(CMAKE_C_FLAGS "-Wall -Wno-deprecated-declarations -Wunused -Wwrite-strings -Wno-strict-aliasing -Wextra -Wshadow -g ${MYSQL_CFLAGS}")
-set(CMAKE_C_FLAGS "-std=gnu99 -Wall -Wno-deprecated-declarations -Wunused -Wwrite-strings -Wno-strict-aliasing -Wextra -Wshadow -g -Werror ${MYSQL_CFLAGS}")
+set(CMAKE_C_FLAGS "-std=gnu99 -Wall -Wno-deprecated-declarations -Wunused -Wwrite-strings -Wno-strict-aliasing -Wextra -Wshadow -g ${MYSQL_CFLAGS}")
include_directories(${MYDUMPER_SOURCE_DIR} ${MYSQL_INCLUDE_DIR} ${GLIB2_INCLUDE_DIR} ${PCRE_INCLUDE_DIR} ${ZLIB_INCLUDE_DIRS} )
OPTION(WITH_ASAN "Build with ASAN" OFF)

View File

@ -1,11 +0,0 @@
--- src/mydumper_common.c.orig 2023-08-02 14:40:15 UTC
+++ src/mydumper_common.c
@@ -123,7 +123,7 @@ int m_close_pipe(guint thread_id, void *file, gchar *f
g_mutex_lock(fifo_table_mutex);
struct fifo *f=g_hash_table_lookup(fifo_hash,file);
g_mutex_unlock(fifo_table_mutex);
- int r=close(fileno(file));
+ int r=close(fileno((FILE *) file));
if (f != NULL){
int status=0;
waitpid(f->pid, &status, 0);