Biniax-2 is original and entertaining game. Takes a minute to learn
and gives you hours and hours of gameplay. Discover the different Biniax-2 faces - for action heroes or careful strategists. Biniax-2 has three game modes (two singleplayer and one multiplayer), hall of fame, dynamic music and nice cartoon look. WWW: http://biniax.com/index2.html PR: ports/122895 Submitted by: Dmitry Marakasov <amdmi3 at amdmi3.ru>
This commit is contained in:
parent
129c27a433
commit
0059c76a1c
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=212150
6 changed files with 110 additions and 0 deletions
|
@ -75,6 +75,7 @@
|
|||
SUBDIR += belooted
|
||||
SUBDIR += bfm
|
||||
SUBDIR += biloba
|
||||
SUBDIR += biniax2
|
||||
SUBDIR += biorythm
|
||||
SUBDIR += bitefusion
|
||||
SUBDIR += blackjack
|
||||
|
|
38
games/biniax2/Makefile
Normal file
38
games/biniax2/Makefile
Normal file
|
@ -0,0 +1,38 @@
|
|||
# New ports collection makefile for: biniax2
|
||||
# Date created: 16 Apr 2008
|
||||
# Whom: Dmitry Marakasov <amdmi3@amdmi3.ru>
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= biniax2
|
||||
PORTVERSION= 1.0
|
||||
CATEGORIES= games
|
||||
MASTER_SITES= http://mordred.dir.bg/biniax/ \
|
||||
http://www.amdmi3.ru/distfiles/
|
||||
DISTNAME= ${PORTNAME}-fullsrc
|
||||
|
||||
MAINTAINER= amdmi3@amdmi3.ru
|
||||
COMMENT= Original logic game with arcade and tactics modes
|
||||
|
||||
USE_SDL= sdl mixer image
|
||||
|
||||
WRKSRC= ${WRKDIR}
|
||||
|
||||
post-patch:
|
||||
@${RM} -f ${WRKSRC}/data/Thumbs.db
|
||||
@${REINPLACE_CMD} -e 's|data/|${DATADIR}/|g' \
|
||||
${WRKSRC}/desktop/gfx.c ${WRKSRC}/desktop/snd.c
|
||||
|
||||
do-build:
|
||||
cd ${WRKSRC} && ${CC} ${CFLAGS} biniax.c hof.c desktop/cfg.c \
|
||||
desktop/gfx.c desktop/snd.c desktop/inp.c desktop/sys.c \
|
||||
-I. -Idesktop `${SDL_CONFIG} --cflags --libs` \
|
||||
-lSDL_image -lSDL_mixer -o ${PORTNAME}
|
||||
|
||||
do-install:
|
||||
${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
|
||||
${MKDIR} ${DATADIR}
|
||||
cd ${WRKSRC}/data && ${COPYTREE_SHARE} . ${DATADIR}
|
||||
|
||||
.include <bsd.port.mk>
|
3
games/biniax2/distinfo
Normal file
3
games/biniax2/distinfo
Normal file
|
@ -0,0 +1,3 @@
|
|||
MD5 (biniax2-fullsrc.tar.gz) = 2bd3a46f5caea361ed8a7ec60a16f110
|
||||
SHA256 (biniax2-fullsrc.tar.gz) = 50db7c7a6bd7377aa1b4de617ad4d3abebc81212b8d72f384d59cf937f758508
|
||||
SIZE (biniax2-fullsrc.tar.gz) = 2972058
|
18
games/biniax2/files/patch-biniax.c
Normal file
18
games/biniax2/files/patch-biniax.c
Normal file
|
@ -0,0 +1,18 @@
|
|||
--- biniax.c.orig 2008-04-08 09:25:14.000000000 +0400
|
||||
+++ biniax.c 2008-04-16 22:33:02.000000000 +0400
|
||||
@@ -89,6 +89,15 @@
|
||||
|
||||
int main( int argc, char *argv[] )
|
||||
{
|
||||
+ if (chdir(getenv("HOME")) != 0)
|
||||
+ err(1, "cannot chdir to $HOME");
|
||||
+
|
||||
+ if (mkdir(".biniax2", 0755) != 0 && errno != EEXIST)
|
||||
+ err(1, "cannot mkdir $HOME/.biniax2");
|
||||
+
|
||||
+ if (chdir(".biniax2") != 0)
|
||||
+ err(1, "cannot chdir to $HOME/.biniax2");
|
||||
+
|
||||
BNX_BOOL bquit = BNX_FALSE;
|
||||
BNX_INT16 enterState = cStateMainMenu;
|
||||
BNX_INT16 nmenu = 0;
|
7
games/biniax2/pkg-descr
Normal file
7
games/biniax2/pkg-descr
Normal file
|
@ -0,0 +1,7 @@
|
|||
Biniax-2 is original and entertaining game. Takes a minute to learn
|
||||
and gives you hours and hours of gameplay. Discover the different
|
||||
Biniax-2 faces - for action heroes or careful strategists. Biniax-2
|
||||
has three game modes (two singleplayer and one multiplayer), hall
|
||||
of fame, dynamic music and nice cartoon look.
|
||||
|
||||
WWW: http://biniax.com/index2.html
|
43
games/biniax2/pkg-plist
Normal file
43
games/biniax2/pkg-plist
Normal file
|
@ -0,0 +1,43 @@
|
|||
bin/biniax2
|
||||
%%DATADIR%%/graphics/background0.png
|
||||
%%DATADIR%%/graphics/background1.png
|
||||
%%DATADIR%%/graphics/background2.png
|
||||
%%DATADIR%%/graphics/cursor0.png
|
||||
%%DATADIR%%/graphics/cursor1.png
|
||||
%%DATADIR%%/graphics/element0.png
|
||||
%%DATADIR%%/graphics/element1.png
|
||||
%%DATADIR%%/graphics/element2.png
|
||||
%%DATADIR%%/graphics/element3.png
|
||||
%%DATADIR%%/graphics/elementB.png
|
||||
%%DATADIR%%/graphics/font.png
|
||||
%%DATADIR%%/graphics/help.png
|
||||
%%DATADIR%%/graphics/logo.png
|
||||
%%DATADIR%%/graphics/marker0.png
|
||||
%%DATADIR%%/graphics/marker1.png
|
||||
%%DATADIR%%/graphics/movecount.png
|
||||
%%DATADIR%%/graphics/particle0.png
|
||||
%%DATADIR%%/graphics/particle1.png
|
||||
%%DATADIR%%/graphics/particle2.png
|
||||
%%DATADIR%%/graphics/roadmap.png
|
||||
%%DATADIR%%/graphics/splash.png
|
||||
%%DATADIR%%/graphics/sweep.png
|
||||
%%DATADIR%%/graphics/window.png
|
||||
%%DATADIR%%/music/biniax_common00.it
|
||||
%%DATADIR%%/music/biniax_common01.it
|
||||
%%DATADIR%%/music/biniax_common02.it
|
||||
%%DATADIR%%/music/biniax_common03.it
|
||||
%%DATADIR%%/music/biniax_common04.it
|
||||
%%DATADIR%%/music/biniax_common05.it
|
||||
%%DATADIR%%/music/biniax_common06.it
|
||||
%%DATADIR%%/music/biniax_common07.it
|
||||
%%DATADIR%%/sound/sfx1.wav
|
||||
%%DATADIR%%/sound/sfx2.wav
|
||||
%%DATADIR%%/sound/sfx3.wav
|
||||
%%DATADIR%%/sound/sfx4.wav
|
||||
%%DATADIR%%/sound/sfx5.wav
|
||||
%%DATADIR%%/text/help.txt
|
||||
@dirrm %%DATADIR%%/text
|
||||
@dirrm %%DATADIR%%/sound
|
||||
@dirrm %%DATADIR%%/music
|
||||
@dirrm %%DATADIR%%/graphics
|
||||
@dirrm %%DATADIR%%
|
Loading…
Reference in a new issue