Library for handling binary OpenStreetMap data

WWW: https://github.com/scrosby/OSM-binary
This commit is contained in:
Dmitry Marakasov 2013-05-24 15:43:16 +00:00
parent 4e2bdb8426
commit 00c0c987f6
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=318981
6 changed files with 79 additions and 0 deletions

View file

@ -37,6 +37,7 @@
SUBDIR += libgal
SUBDIR += libkgeomap
SUBDIR += libnova
SUBDIR += libosmpbf
SUBDIR += libroadnav
SUBDIR += luna
SUBDIR += marble

38
astro/libosmpbf/Makefile Normal file
View file

@ -0,0 +1,38 @@
# Created by: Dmitry Marakasov <amdmi3@FreeBSD.org>
# $FreeBSD$
PORTNAME= libosmpbf
PORTVERSION= 1.3.0
CATEGORIES= astro devel
MAINTAINER= amdmi3@FreeBSD.org
COMMENT= Library for handling binary OpenStreetMap data
LICENSE= GPLv3
LIB_DEPENDS= protobuf:${PORTSDIR}/devel/protobuf
USE_GITHUB= yes
GH_ACCOUNT= scrosby
GH_PROJECT= OSM-binary
GH_TAGNAME= v${PORTVERSION}
GH_COMMIT= d9be2d1
USE_GMAKE= yes
MAKE_JOBS_SAFE= yes
BUILD_WRKSRC= ${WRKSRC}/src
INSTALL_WRKSRC= ${WRKSRC}/src
CXXFLAGS+= -I${LOCALBASE}/include
PORTDOCS= *
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MDOCS}
post-install:
${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}/
.endif
.include <bsd.port.mk>

2
astro/libosmpbf/distinfo Normal file
View file

@ -0,0 +1,2 @@
SHA256 (libosmpbf-1.3.0.tar.gz) = 25226cba789292fe2c78c29321afd81d1d083b6f990f6bc4d02b41ff8b1e638f
SIZE (libosmpbf-1.3.0.tar.gz) = 23774

View file

@ -0,0 +1,30 @@
--- src/Makefile.orig 2012-12-05 08:14:05.000000000 +0400
+++ src/Makefile 2013-05-23 03:08:09.903921308 +0400
@@ -1,6 +1,6 @@
-CXX = g++
-CXXFLAGS = -O3
+CXX ?= g++
+CXXFLAGS ?= -O3
AR = ar
all: libosmpbf.a ../include/osmpbf/fileformat.pb.h ../include/osmpbf/osmformat.pb.h
@@ -16,12 +16,12 @@
cp *.pb.h ../include/osmpbf/
install:
- install -m 755 -g root -o root -d $(DESTDIR)/usr/lib
- install -m 644 -g root -o root libosmpbf.a $(DESTDIR)/usr/lib
- install -m 755 -g root -o root -d $(DESTDIR)/usr/include/osmpbf
- install -m 644 -g root -o root ../include/osmpbf/osmpbf.h $(DESTDIR)/usr/include/osmpbf
- install -m 644 -g root -o root ../include/osmpbf/fileformat.pb.h $(DESTDIR)/usr/include/osmpbf
- install -m 644 -g root -o root ../include/osmpbf/osmformat.pb.h $(DESTDIR)/usr/include/osmpbf
+ install -m 755 -d $(PREFIX)/lib
+ install -m 644 libosmpbf.a $(PREFIX)/lib
+ install -m 755 -d $(PREFIX)/include/osmpbf
+ install -m 644 ../include/osmpbf/osmpbf.h $(PREFIX)/include/osmpbf
+ install -m 644 ../include/osmpbf/fileformat.pb.h $(PREFIX)/include/osmpbf
+ install -m 644 ../include/osmpbf/osmformat.pb.h $(PREFIX)/include/osmpbf
clean:
rm -f *.pb.h *.pb.cc *.pb.o libosmpbf.a

View file

@ -0,0 +1,3 @@
Library for handling binary OpenStreetMap data
WWW: https://github.com/scrosby/OSM-binary

View file

@ -0,0 +1,5 @@
include/osmpbf/fileformat.pb.h
include/osmpbf/osmformat.pb.h
include/osmpbf/osmpbf.h
lib/libosmpbf.a
@dirrm include/osmpbf