Update to 0.5.2 .
This commit is contained in:
parent
301598e7bd
commit
00c4181b3e
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=296854
3 changed files with 9 additions and 9 deletions
|
@ -6,23 +6,23 @@
|
|||
#
|
||||
|
||||
PORTNAME= vdr-plugin-streamdev
|
||||
PORTVERSION= 0.5.1p20120311
|
||||
PORTVERSION= 0.5.2
|
||||
CATEGORIES= multimedia
|
||||
MASTER_SITES= http://projects.vdr-developer.org/attachments/download/497/:release \
|
||||
MASTER_SITES= http://projects.vdr-developer.org/attachments/download/953/:release \
|
||||
LOCAL:snapshot
|
||||
MASTER_SITE_SUBDIR= nox/:snapshot
|
||||
DISTFILES= ${DISTNAME}${EXTRACT_SUFX}:snapshot
|
||||
DISTFILES= ${DISTNAME:S/plugin-//}${EXTRACT_SUFX}:release
|
||||
EXTRACT_SUFX= .tgz
|
||||
|
||||
MAINTAINER= nox@FreeBSD.org
|
||||
COMMENT= Video Disk Recorder - stream device plugin
|
||||
|
||||
RUN_DEPENDS+= bash:${PORTSDIR}/shells/bash
|
||||
|
||||
USE_BZIP2= yes
|
||||
PORTDOCS= COPYING README
|
||||
HAVE_CONFIGURE= yes
|
||||
MAKE_JOBS_UNSAFE= yes
|
||||
WRKSRC= ${WRKDIR}/${PORTNAME}
|
||||
WRKSRC= ${WRKDIR}/${PLUGIN}-${PORTVERSION}
|
||||
VDR_PLUGIN_MAKEFILES= ${WRKSRC}/client/Makefile \
|
||||
${WRKSRC}/server/Makefile
|
||||
|
||||
|
|
|
@ -1,2 +1,2 @@
|
|||
SHA256 (vdr/vdr-plugin-streamdev-0.5.1p20120311.tar.bz2) = 519bc2295b7e17504c25beadc4715853bdc095d1e112b0416e74bd083d895122
|
||||
SIZE (vdr/vdr-plugin-streamdev-0.5.1p20120311.tar.bz2) = 148996
|
||||
SHA256 (vdr/vdr-streamdev-0.5.2.tgz) = 554d71f251a1f0be94c6883a5df52340eaa728758271a0f0a486fee90620f2dd
|
||||
SIZE (vdr/vdr-streamdev-0.5.2.tgz) = 182629
|
||||
|
|
|
@ -1,12 +1,12 @@
|
|||
--- server/recplayer.c.orig
|
||||
+++ server/recplayer.c
|
||||
@@ -196,8 +196,10 @@ unsigned long RecPlayer::getBlock(unsign
|
||||
@@ -199,8 +199,10 @@ unsigned long RecPlayer::getBlock(unsign
|
||||
fseek(file, filePosition, SEEK_SET);
|
||||
if (fread(&buffer[got], getFromThisSegment, 1, file) != 1) return 0; // umm, big problem.
|
||||
|
||||
+#ifdef __linux__
|
||||
// Tell linux not to bother keeping the data in the FS cache
|
||||
posix_fadvise(file->_fileno, filePosition, getFromThisSegment, POSIX_FADV_DONTNEED);
|
||||
posix_fadvise(fileno(file), filePosition, getFromThisSegment, POSIX_FADV_DONTNEED);
|
||||
+#endif
|
||||
|
||||
got += getFromThisSegment;
|
||||
|
|
Loading…
Reference in a new issue