- Remove always false OSVERSION condition

- Switch to options helpers
- Cosmetic fixes
This commit is contained in:
Dmitry Marakasov 2017-01-09 09:48:54 +00:00
parent d24f07b566
commit 00c7c1124f
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=430929
2 changed files with 3 additions and 45 deletions

View file

@ -25,21 +25,14 @@ DOCSDIR= ${PREFIX}/share/doc/pcre-ocaml
OPTIONS_DEFINE= DOCS EXAMPLES
.include <bsd.port.options.mk>
.if ${OPSYS} == FreeBSD && ${OSVERSION} < 1000000
# unknown warning flag for old gcc
EXTRA_PATCHES+= ${FILESDIR}/extra-patch--Wno-keyword-macro
.endif
post-patch:
@${REINPLACE_CMD} -e 's|$$prefix"/"share|${STAGEDIR}${PREFIX}/share|' \
-e '/datarootdir/s|$$pkg_name|&-ocaml|' \
${WRKSRC}/setup.ml
@${REINPLACE_CMD} -e 's| safe_string,||' ${WRKSRC}/_tags
post-install:
post-install-EXAMPLES-on:
@${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
@cd ${WRKSRC}/examples && ${COPYTREE_SHARE} \* ${STAGEDIR}${EXAMPLESDIR}
@cd ${WRKSRC}/examples && ${COPYTREE_SHARE} . ${STAGEDIR}${EXAMPLESDIR}
.include <bsd.port.mk>

View file

@ -1,35 +0,0 @@
--- _oasis.orig 2016-02-25 15:20:15 UTC
+++ _oasis
@@ -32,7 +32,7 @@ Library pcre
BuildDepends: bytes
CCOpt: -g -O2 -fPIC -DPIC
if flag(strict) && ccomp_type(cc)
- CCOpt+: -Wall -pedantic -Wextra -Wunused -Wno-long-long -Wno-keyword-macro
+ CCOpt+: -Wall -pedantic -Wextra -Wunused -Wno-long-long
# Examples
--- myocamlbuild.ml.orig 2016-02-25 15:20:15 UTC
+++ myocamlbuild.ml
@@ -648,8 +648,6 @@ let package_default =
A "-Wunused";
A "-ccopt";
- A "-Wno-long-long";
- A "-ccopt";
- A "-Wno-keyword-macro"
+ A "-Wno-long-long"
])
])
];
--- setup.ml.orig 2016-02-25 15:20:15 UTC
+++ setup.ml
@@ -6785,8 +6785,7 @@ let setup_t =
"-pedantic";
"-Wextra";
"-Wunused";
- "-Wno-long-long";
- "-Wno-keyword-macro"
+ "-Wno-long-long"
])
];
bs_cclib = [(OASISExpr.EBool true, [])];