Snap is a simple and fast web development framework and server written in
Haskell. WWW: http://snapframework.com/ Obtained from: FreeBSD Haskell
This commit is contained in:
parent
edc96cba7c
commit
00d415717d
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=279644
6 changed files with 44 additions and 0 deletions
|
@ -148,6 +148,7 @@ sendfile_port= net/hs-sendfile
|
|||
SHA_port= security/hs-SHA
|
||||
show_port= devel/hs-show
|
||||
smallcheck_port= devel/hs-smallcheck
|
||||
snap-core_port= www/hs-snap-core
|
||||
soegtk_port= graphics/hs-soegtk
|
||||
split_port= devel/hs-split
|
||||
StateVar_port= devel/hs-StateVar
|
||||
|
|
|
@ -317,6 +317,7 @@
|
|||
SUBDIR += hs-http-types
|
||||
SUBDIR += hs-oeis
|
||||
SUBDIR += hs-scgi
|
||||
SUBDIR += hs-snap-core
|
||||
SUBDIR += hs-url
|
||||
SUBDIR += hs-wai
|
||||
SUBDIR += hs-warp
|
||||
|
|
25
www/hs-snap-core/Makefile
Normal file
25
www/hs-snap-core/Makefile
Normal file
|
@ -0,0 +1,25 @@
|
|||
# New ports collection makefile for: hs-snap-core
|
||||
# Date created: September 19, 2010
|
||||
# Whom: haskell@FreeBSD.org
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= snap-core
|
||||
PORTVERSION= 0.5.2
|
||||
CATEGORIES= www haskell
|
||||
|
||||
MAINTAINER= haskell@FreeBSD.org
|
||||
COMMENT= Snap: A Haskell Web Framework (Core)
|
||||
|
||||
LICENSE= BSD
|
||||
|
||||
CABAL_SETUP= Setup.hs
|
||||
USE_CABAL= attoparsec>=0.8.0.2 attoparsec-enumerator>=0.2.0.3 \
|
||||
blaze-builder>=0.2.1.4 bytestring-nums case-insensitive \
|
||||
deepseq>=1.1 dlist>=0.5 enumerator>=0.4.13.1 \
|
||||
MonadCatchIO-transformers>=0.2.1 mtl>=2 text>=0.11 \
|
||||
transformers>=0.2 unix-compat>=0.2 vector>=0.6 zlib
|
||||
|
||||
.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
|
||||
.include <bsd.port.mk>
|
2
www/hs-snap-core/distinfo
Normal file
2
www/hs-snap-core/distinfo
Normal file
|
@ -0,0 +1,2 @@
|
|||
SHA256 (cabal/snap-core-0.5.2.tar.gz) = 14d234b4706e5e993e1e5c4178ede3e8ccafa070daf96eb826bc0681e17b52f2
|
||||
SIZE (cabal/snap-core-0.5.2.tar.gz) = 74409
|
11
www/hs-snap-core/files/patch-snap-core.cabal
Normal file
11
www/hs-snap-core/files/patch-snap-core.cabal
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- ./snap-core.cabal.orig 2011-06-23 17:08:48.000000000 +0200
|
||||
+++ ./snap-core.cabal 2011-07-18 15:34:06.000000000 +0200
|
||||
@@ -133,7 +133,7 @@
|
||||
blaze-builder >= 0.2.1.4 && <0.4,
|
||||
bytestring,
|
||||
bytestring-nums,
|
||||
- case-insensitive >= 0.2 && < 0.3,
|
||||
+ case-insensitive >= 0.2,
|
||||
containers,
|
||||
deepseq >= 1.1 && <1.2,
|
||||
directory,
|
4
www/hs-snap-core/pkg-descr
Normal file
4
www/hs-snap-core/pkg-descr
Normal file
|
@ -0,0 +1,4 @@
|
|||
Snap is a simple and fast web development framework and server written in
|
||||
Haskell.
|
||||
|
||||
WWW: http://snapframework.com/
|
Loading…
Reference in a new issue