lang/emilua: Update to 0.5.1

Does not build in FreeBSD releases < 14

ChangeLog: https://docs.emilua.org/api/0.5/changelog.html#0-5

PR:		275643
Reported by:	manipuladordedados@gmail.com (maintainer)
This commit is contained in:
Valter Nazianzeno 2023-12-10 17:48:52 +01:00 committed by Fernando Apesteguía
parent 5c3bc831b2
commit 00ddef6817
5 changed files with 149 additions and 166 deletions

View file

@ -1,27 +1,29 @@
PORTNAME= emilua
DISTVERSIONPREFIX= v
DISTVERSION= 0.4.3
DISTVERSION= 0.5.1
CATEGORIES= lang devel
MAINTAINER= manipuladordedados@gmail.com
COMMENT= Lua execution engine
WWW= https://emilua.org
WWW= https://emilua.org/
LICENSE= BSL
LICENSE_FILE= ${WRKSRC}/LICENSE_1_0.txt
ONLY_FOR_ARCHS= aarch64 amd64
ONLY_FOR_ARCHS_REASON= the software structures have not yet been ported
IGNORE_FreeBSD_12= not supported by Emilua ('memfd_create' was not declared in this scope)
IGNORE_FreeBSD_13= not supported by Emilua ('clearenv' was not declared in this scope)
BUILD_DEPENDS= asciidoctor:textproc/rubygem-asciidoctor \
boost-libs>0:devel/boost-libs \
cereal>0:devel/cereal \
cmake:devel/cmake-core \
gawk:lang/gawk \
gperf:devel/gperf \
re2c:devel/re2c \
xxd:sysutils/xxd
LIB_DEPENDS= libfmt.so:devel/libfmt \
libserd-0.so:devel/serd \
ksh93:shells/ksh \
libfmt>0:devel/libfmt \
re2c:devel/re2c
LIB_DEPENDS= libserd-0.so:devel/serd \
libsord-0.so:devel/sord
USES= localbase luajit:luajit-openresty meson ncurses pathfix \
@ -32,6 +34,9 @@ GH_TUPLE= BoostGSoC14:boost.http:93ae527c89ffc517862e1f5f54c8a257278f1195:emilua
breese:trial.protocol:79149f6:trial_protocol/subprojects/trial-protocol
USE_GITLAB= yes
CONFIGURE_ENV+= BOOST_INCLUDEDIR="${LOCALBASE}/include" \
BOOST_LIBRARYDIR="${LOCALBASE}/lib"
MESON_ARGS= --buildtype=plain \
--wrap-mode=nodownload \
-Db_pch=false \
@ -39,7 +44,7 @@ MESON_ARGS= --buildtype=plain \
-Denable_manpages=true \
-Denable_tests=true
LDFLAGS+= -static-libstdc++
CXXFLAGS+= "-DFMT_HEADER_ONLY"
post-extract:
${CP} ${WRKSRC}/subprojects/packagefiles/emilua-http/meson.build \
@ -47,9 +52,4 @@ post-extract:
${CP} ${WRKSRC}/subprojects/packagefiles/trial.protocol/meson.build \
${WRKSRC}/subprojects/trial-protocol/
post-install:
${MV} ${STAGEDIR}${PREFIX}/man/man3em/* \
${STAGEDIR}${PREFIX}/man/man3/
${RMDIR} ${STAGEDIR}${PREFIX}/man/man3em
.include <bsd.port.mk>

View file

@ -1,7 +1,7 @@
TIMESTAMP = 1694922832
TIMESTAMP = 1702060584
SHA256 (BoostGSoC14-boost.http-93ae527c89ffc517862e1f5f54c8a257278f1195_GH0.tar.gz) = 4e90417806c285348d968183072918e86d7fd7d7db5affb63ec03faee92ed8ed
SIZE (BoostGSoC14-boost.http-93ae527c89ffc517862e1f5f54c8a257278f1195_GH0.tar.gz) = 237404
SHA256 (breese-trial.protocol-79149f6_GH0.tar.gz) = ea82ba7736a2c6ae94e72587a454d3380517ed764df89e2297e6fac2acdeac03
SIZE (breese-trial.protocol-79149f6_GH0.tar.gz) = 255698
SHA256 (emilua-v0.4.3.tar.bz2) = 8e3ca114a3c71c985dfb8d84171a145bf245a679b5228dad27ce301ba899b15c
SIZE (emilua-v0.4.3.tar.bz2) = 313696
SHA256 (emilua-v0.5.1.tar.bz2) = 08a46894dbdb2384e4c4aa4cfb7026caa557b6c16836e47bb30aca3372bf3ccb
SIZE (emilua-v0.5.1.tar.bz2) = 328877

View file

@ -1,19 +0,0 @@
--- meson.build.orig 2023-05-01 18:05:51 UTC
+++ meson.build
@@ -31,7 +31,6 @@ luajit = dependency('luajit', version : '>=2.0.5')
boost = dependency(
'boost',
version : '>=1.80',
- modules : boost_modules,
)
fmt = dependency('fmt', version : '>=8.0')
serd = dependency('serd-0')
@@ -190,7 +189,7 @@ if get_option('enable_tests')
)
else
# GNU Coreutils binaries are not specified explicitly, but expected too
- shell = find_program('bash', 'ksh')
+ shell = find_program('bash', 'ksh', 'tcsh')
endif
endif

View file

@ -1,10 +0,0 @@
--- src/mutex.cpp.orig 2023-05-01 18:05:51 UTC
+++ src/mutex.cpp
@@ -4,6 +4,7 @@
file LICENSE_1_0.txt or copy at http://www.boost.org/LICENSE_1_0.txt) */
EMILUA_GPERF_DECLS_BEGIN(includes)
+#define FMT_HEADER_ONLY
#include <fmt/format.h>
#include <emilua/mutex.hpp>

View file

@ -11,16 +11,17 @@ include/emilua/fiber.hpp
include/emilua/file.hpp
include/emilua/file_descriptor.hpp
include/emilua/filesystem.hpp
include/emilua/future.hpp
include/emilua/generic_error.hpp
include/emilua/http.hpp
include/emilua/ip.hpp
include/emilua/json.hpp
include/emilua/linux_namespaces.hpp
include/emilua/lua_shim.hpp
include/emilua/modules.re
include/emilua/mutex.hpp
include/emilua/pipe.hpp
include/emilua/plugin.hpp
include/emilua/recursive_mutex.hpp
include/emilua/regex.hpp
include/emilua/scope_cleanup.hpp
include/emilua/serial_port.hpp
@ -33,134 +34,145 @@ include/emilua/tls.hpp
include/emilua/unix.hpp
include/emilua/websocket.hpp
include/emilua/windows.hpp
lib/libemilua.so
lib/libemilua.so.0
lib/libemilua.so.0.5.1
libdata/pkgconfig/emilua.pc
libexec/emilua/emilua_gperf.awk
man/man1/emilua.1.gz
man/man3/asio_error.3em.gz
man/man3/byte_span.3em.gz
man/man3/condition_variable.3em.gz
man/man3/file.open_flag.3em.gz
man/man3/file.random_access.3em.gz
man/man3/file.read_all_at.3em.gz
man/man3/file.read_at_least_at.3em.gz
man/man3/file.stream.3em.gz
man/man3/file.write_all_at.3em.gz
man/man3/file.write_at_least_at.3em.gz
man/man3/file_descriptor.3em.gz
man/man3/filesystem.absolute.3em.gz
man/man3/filesystem.canonical.3em.gz
man/man3/filesystem.cap_get_file.3em.gz
man/man3/filesystem.cap_set_file.3em.gz
man/man3/filesystem.chmod.3em.gz
man/man3/filesystem.clock.3em.gz
man/man3/filesystem.copy.3em.gz
man/man3/filesystem.copy_file.3em.gz
man/man3/filesystem.copy_symlink.3em.gz
man/man3/filesystem.create_directory.3em.gz
man/man3/filesystem.create_hard_link.3em.gz
man/man3/filesystem.create_symlink.3em.gz
man/man3/filesystem.current_working_directory.3em.gz
man/man3/filesystem.directory_entry.3em.gz
man/man3/filesystem.directory_iterator.3em.gz
man/man3/filesystem.equivalent.3em.gz
man/man3/filesystem.file_size.3em.gz
man/man3/filesystem.hard_link_count.3em.gz
man/man3/filesystem.is_empty.3em.gz
man/man3/filesystem.last_write_time.3em.gz
man/man3/filesystem.path.3em.gz
man/man3/filesystem.proximate.3em.gz
man/man3/filesystem.read_symlink.3em.gz
man/man3/filesystem.recursive_directory_iterator.3em.gz
man/man3/filesystem.relative.3em.gz
man/man3/filesystem.remove.3em.gz
man/man3/filesystem.rename.3em.gz
man/man3/filesystem.resize_file.3em.gz
man/man3/filesystem.space.3em.gz
man/man3/filesystem.status.3em.gz
man/man3/filesystem.temp_directory_path.3em.gz
man/man3/filesystem.umask.3em.gz
man/man3/filesystem.weakly_canonical.3em.gz
man/man3/generic_error.3em.gz
man/man3/http.headers.3em.gz
man/man3/http.request.3em.gz
man/man3/http.response.3em.gz
man/man3/http.socket.3em.gz
man/man3/ip.address.3em.gz
man/man3/ip.address_info_flag.3em.gz
man/man3/ip.connect.3em.gz
man/man3/ip.get_address_info.3em.gz
man/man3/ip.get_name_info.3em.gz
man/man3/ip.host_name.3em.gz
man/man3/ip.message_flag.3em.gz
man/man3/ip.tcp.acceptor.3em.gz
man/man3/ip.tcp.socket.3em.gz
man/man3/ip.toendpoint.3em.gz
man/man3/ip.tostring.3em.gz
man/man3/ip.udp.socket.3em.gz
man/man3/json.3em.gz
man/man3/json.writer.3em.gz
man/man3/mutex.3em.gz
man/man3/pipe.pair.3em.gz
man/man3/pipe.read_stream.3em.gz
man/man3/pipe.write_stream.3em.gz
man/man3/regex.3em.gz
man/man3/serial_port.3em.gz
man/man3/stream.read_all.3em.gz
man/man3/stream.read_at_least.3em.gz
man/man3/stream.scanner.3em.gz
man/man3/stream.write_all.3em.gz
man/man3/stream.write_at_least.3em.gz
man/man3/system.arguments.3em.gz
man/man3/system.environment.3em.gz
man/man3/system.err.3em.gz
man/man3/system.exit.3em.gz
man/man3/system.getgroups.3em.gz
man/man3/system.getpgid.3em.gz
man/man3/system.getpgrp.3em.gz
man/man3/system.getpid.3em.gz
man/man3/system.getppid.3em.gz
man/man3/system.getresgid.3em.gz
man/man3/system.getresuid.3em.gz
man/man3/system.getsid.3em.gz
man/man3/system.in_.3em.gz
man/man3/system.kill.3em.gz
man/man3/system.linux_capabilities.3em.gz
man/man3/system.out.3em.gz
man/man3/system.setgroups.3em.gz
man/man3/system.setpgid.3em.gz
man/man3/system.setresgid.3em.gz
man/man3/system.setresuid.3em.gz
man/man3/system.setsid.3em.gz
man/man3/system.signal.3em.gz
man/man3/system.signal.default.3em.gz
man/man3/system.signal.ignore.3em.gz
man/man3/system.signal.raise.3em.gz
man/man3/system.signal.set.3em.gz
man/man3/system.spawn.3em.gz
man/man3/time.high_resolution_clock.3em.gz
man/man3/time.sleep.3em.gz
man/man3/time.steady_clock.3em.gz
man/man3/time.steady_timer.3em.gz
man/man3/time.system_clock.3em.gz
man/man3/time.system_timer.3em.gz
man/man3/tls.context.3em.gz
man/man3/tls.context_flag.3em.gz
man/man3/tls.socket.3em.gz
man/man3/unix.datagram_socket.3em.gz
man/man3/unix.message_flag.3em.gz
man/man3/unix.seqpacket_acceptor.3em.gz
man/man3/unix.seqpacket_socket.3em.gz
man/man3/unix.stream_acceptor.3em.gz
man/man3/unix.stream_socket.3em.gz
man/man3/websocket.3em.gz
man/man7/emilua-actor.7.gz
man/man3em/asio_error.3em.gz
man/man3em/byte_span.3em.gz
man/man3em/condition_variable.3em.gz
man/man3em/file.open_flag.3em.gz
man/man3em/file.random_access.3em.gz
man/man3em/file.read_all_at.3em.gz
man/man3em/file.read_at_least_at.3em.gz
man/man3em/file.stream.3em.gz
man/man3em/file.write_all_at.3em.gz
man/man3em/file.write_at_least_at.3em.gz
man/man3em/file_descriptor.3em.gz
man/man3em/filesystem.absolute.3em.gz
man/man3em/filesystem.canonical.3em.gz
man/man3em/filesystem.cap_get_file.3em.gz
man/man3em/filesystem.cap_set_file.3em.gz
man/man3em/filesystem.chmod.3em.gz
man/man3em/filesystem.chown.3em.gz
man/man3em/filesystem.clock.3em.gz
man/man3em/filesystem.copy.3em.gz
man/man3em/filesystem.copy_file.3em.gz
man/man3em/filesystem.copy_symlink.3em.gz
man/man3em/filesystem.create_directory.3em.gz
man/man3em/filesystem.create_hard_link.3em.gz
man/man3em/filesystem.create_symlink.3em.gz
man/man3em/filesystem.current_working_directory.3em.gz
man/man3em/filesystem.directory_entry.3em.gz
man/man3em/filesystem.directory_iterator.3em.gz
man/man3em/filesystem.equivalent.3em.gz
man/man3em/filesystem.file_size.3em.gz
man/man3em/filesystem.hard_link_count.3em.gz
man/man3em/filesystem.is_empty.3em.gz
man/man3em/filesystem.last_write_time.3em.gz
man/man3em/filesystem.path.3em.gz
man/man3em/filesystem.proximate.3em.gz
man/man3em/filesystem.read_symlink.3em.gz
man/man3em/filesystem.recursive_directory_iterator.3em.gz
man/man3em/filesystem.relative.3em.gz
man/man3em/filesystem.remove.3em.gz
man/man3em/filesystem.rename.3em.gz
man/man3em/filesystem.resize_file.3em.gz
man/man3em/filesystem.space.3em.gz
man/man3em/filesystem.status.3em.gz
man/man3em/filesystem.temp_directory_path.3em.gz
man/man3em/filesystem.umask.3em.gz
man/man3em/filesystem.weakly_canonical.3em.gz
man/man3em/future.3em.gz
man/man3em/generic_error.3em.gz
man/man3em/http.headers.3em.gz
man/man3em/http.request.3em.gz
man/man3em/http.response.3em.gz
man/man3em/http.socket.3em.gz
man/man3em/inbox.3em.gz
man/man3em/ip.address.3em.gz
man/man3em/ip.address_info_flag.3em.gz
man/man3em/ip.connect.3em.gz
man/man3em/ip.get_address_info.3em.gz
man/man3em/ip.get_name_info.3em.gz
man/man3em/ip.host_name.3em.gz
man/man3em/ip.message_flag.3em.gz
man/man3em/ip.tcp.acceptor.3em.gz
man/man3em/ip.tcp.socket.3em.gz
man/man3em/ip.toendpoint.3em.gz
man/man3em/ip.tostring.3em.gz
man/man3em/ip.udp.socket.3em.gz
man/man3em/json.3em.gz
man/man3em/json.writer.3em.gz
man/man3em/mutex.3em.gz
man/man3em/pipe.pair.3em.gz
man/man3em/pipe.read_stream.3em.gz
man/man3em/pipe.write_stream.3em.gz
man/man3em/recursive_mutex.3em.gz
man/man3em/regex.3em.gz
man/man3em/serial_port.3em.gz
man/man3em/spawn.3em.gz
man/man3em/spawn_context_threads.3em.gz
man/man3em/spawn_vm.3em.gz
man/man3em/stream.read_all.3em.gz
man/man3em/stream.read_at_least.3em.gz
man/man3em/stream.scanner.3em.gz
man/man3em/stream.write_all.3em.gz
man/man3em/stream.write_at_least.3em.gz
man/man3em/system.arguments.3em.gz
man/man3em/system.environment.3em.gz
man/man3em/system.err.3em.gz
man/man3em/system.exit.3em.gz
man/man3em/system.getgroups.3em.gz
man/man3em/system.getpgid.3em.gz
man/man3em/system.getpgrp.3em.gz
man/man3em/system.getpid.3em.gz
man/man3em/system.getppid.3em.gz
man/man3em/system.getresgid.3em.gz
man/man3em/system.getresuid.3em.gz
man/man3em/system.getsid.3em.gz
man/man3em/system.in_.3em.gz
man/man3em/system.kill.3em.gz
man/man3em/system.linux_capabilities.3em.gz
man/man3em/system.out.3em.gz
man/man3em/system.setgroups.3em.gz
man/man3em/system.setpgid.3em.gz
man/man3em/system.setresgid.3em.gz
man/man3em/system.setresuid.3em.gz
man/man3em/system.setsid.3em.gz
man/man3em/system.signal.3em.gz
man/man3em/system.signal.default.3em.gz
man/man3em/system.signal.ignore.3em.gz
man/man3em/system.signal.raise.3em.gz
man/man3em/system.signal.set.3em.gz
man/man3em/system.spawn.3em.gz
man/man3em/this_fiber.3em.gz
man/man3em/time.high_resolution_clock.3em.gz
man/man3em/time.sleep.3em.gz
man/man3em/time.steady_clock.3em.gz
man/man3em/time.steady_timer.3em.gz
man/man3em/time.system_clock.3em.gz
man/man3em/time.system_timer.3em.gz
man/man3em/tls.context.3em.gz
man/man3em/tls.context_flag.3em.gz
man/man3em/tls.socket.3em.gz
man/man3em/unix.datagram_socket.3em.gz
man/man3em/unix.message_flag.3em.gz
man/man3em/unix.seqpacket_acceptor.3em.gz
man/man3em/unix.seqpacket_socket.3em.gz
man/man3em/unix.stream_acceptor.3em.gz
man/man3em/unix.stream_socket.3em.gz
man/man3em/websocket.3em.gz
man/man7/emilua-alternatives.7.gz
man/man7/emilua-embedding.7.gz
man/man7/emilua-errors.7.gz
man/man7/emilua-fiber.7.gz
man/man7/emilua-getting-started.7.gz
man/man7/emilua-internals.7.gz
man/man7/emilua-interruption.7.gz
man/man7/emilua-linux_namespaces.7.gz
man/man7/emilua-lua51.7.gz
man/man7/emilua-modules.7.gz
man/man7/emilua-sandboxes.7.gz
man/man7/emilua-streams.7.gz