- mark IGNORE under old perl

This commit is contained in:
Yen-Ming Lee 2006-06-20 02:26:11 +00:00
parent e85d62852a
commit 01057ccebb
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=165823
4 changed files with 9 additions and 27 deletions

View file

@ -20,4 +20,11 @@ PERL_CONFIGURE= yes
MAN3= Regexp::Bind.3
.include <bsd.port.mk>
.include <bsd.port.pre.mk>
# can't pass 'make test'
.if ${PERL_LEVEL} < 500600
IGNORE= needs perl 5.6.0 or higher, install lang/perl5 and try again
.endif
.include <bsd.port.post.mk>

View file

@ -29,9 +29,7 @@ MAN3= Image::Info.3 Image::Info::BMP.3 Image::Info::SVG.3 \
.include <bsd.port.pre.mk>
.if ${PERL_LEVEL} < 500600
EXTRA_PATCHES= ${PATCHDIR}/5.005-Info.pm.tmpl ${PATCHDIR}/5.005-lib::Image::Info::PPM.pm
post-patch:
@${RM} -f ${WRKSRC}/lib/Image/Info/PPM.pm.orig
IGNORE= needs perl 5.6.0 or higher, install lang/perl5.8 and try again
.endif
.include <bsd.port.post.mk>

View file

@ -1,11 +0,0 @@
--- dev/Info.pm.tmpl~ Wed Jan 7 13:39:11 2004
+++ dev/Info.pm.tmpl Mon Mar 22 14:33:37 2004
@@ -33,7 +33,7 @@
}
elsif (ref($source) eq "SCALAR") {
if ($] >= 5.008) {
- open(my $s, "<", $source) or return _os_err("Can't open string");
+ open(my $s, "<". $source) or return _os_err("Can't open string");
$source = $s;
}
else {

View file

@ -1,12 +0,0 @@
--- lib/Image/Info/PPM.pm~ Mon Oct 6 18:38:53 2003
+++ lib/Image/Info/PPM.pm Mon Mar 22 14:29:29 2004
@@ -39,7 +39,8 @@
$type = shift(@header);
$type =~ s/^P// || die;
$binary++ if $type > 3;
- $type = "p" . qw/p b g/[$type % 3] . "m";
+ my @typetmp = qw/p b g/;
+ $type = "p" . $typetmp[$type % 3] . "m";
$num_wanted = 2 if $type eq "pbm";
}