databases/mariadb101-server: Update to 10.1.19

- Update to 10.1.19
  - Use target-OPT-on not .if exists
  - Remove OQGraph patches now included upstream

MFH:		2016Q4
Security:	9bc14850-a070-11e6-a881-b499baebfeaf
This commit is contained in:
Bernard Spil 2016-11-12 00:11:26 +00:00
parent 048208ae79
commit 01158fba96
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=425916
4 changed files with 5 additions and 89 deletions

View file

@ -1,8 +1,7 @@
# $FreeBSD$
PORTNAME?= mariadb
PORTVERSION= 10.1.18
PORTREVISION= 1
PORTVERSION= 10.1.19
CATEGORIES= databases ipv6
MASTER_SITES= http://ftp.osuosl.org/pub/${SITESDIR}/ \
http://mirrors.supportex.net/${SITESDIR}/ \
@ -175,10 +174,8 @@ post-patch:
${WRKSRC}/cmake/os/DragonFly.cmake
.endif
.if exists(${WRKSRC}/storage/mroonga/CMakeFiles/mroonga.dir/link.txt)
post-configure:
post-configure-MROONGA-on:
@${REINPLACE_CMD} "s|/usr/bin/c++ |/usr/bin/c++ -L${LOCALBASE}/lib |" \
${WRKSRC}/storage/mroonga/CMakeFiles/mroonga.dir/link.txt
.endif
.include <bsd.port.post.mk>

View file

@ -1,3 +1,3 @@
TIMESTAMP = 1475615460
SHA256 (mariadb-10.1.18.tar.gz) = d7336907e9ff44496d6453f92526b25bd253638a64a051ca879f953499873b73
SIZE (mariadb-10.1.18.tar.gz) = 61187451
TIMESTAMP = 1478591187
SHA256 (mariadb-10.1.19.tar.gz) = 5b9373f314e2d1727422fb3795bcf50c1c59005129b35b6cadafae5663251a81
SIZE (mariadb-10.1.19.tar.gz) = 61222929

View file

@ -1,14 +0,0 @@
Patch to allow build with clang from Don Lewis
https://jira.mariadb.org/projects/MDEV/issues/MDEV-8051
--- storage/oqgraph/graphcore.cc.orig 2016-01-28 12:12:55 UTC
+++ storage/oqgraph/graphcore.cc
@@ -485,7 +485,7 @@ namespace open_query
optional<Vertex>
oqgraph_share::find_vertex(VertexID id) const
{
- return ::boost::find_vertex(id, g);
+ return oqgraph3::find_vertex(id, g);
}
#if 0

View file

@ -1,67 +0,0 @@
Patch to allow build with clang from Don Lewis
https://jira.mariadb.org/projects/MDEV/issues/MDEV-8051
--- storage/oqgraph/oqgraph_shim.h.orig 2016-01-28 12:12:55 UTC
+++ storage/oqgraph/oqgraph_shim.h
@@ -274,6 +274,33 @@ namespace boost
};
#endif
+ template<>
+ struct property_map<oqgraph3::graph, edge_weight_t>
+ {
+ typedef void type;
+ typedef oqgraph3::edge_weight_property_map const_type;
+ };
+
+ template<>
+ struct property_map<oqgraph3::graph, vertex_index_t>
+ {
+ typedef void type;
+ typedef oqgraph3::vertex_index_property_map const_type;
+ };
+
+ template<>
+ struct property_map<oqgraph3::graph, edge_index_t>
+ {
+ typedef void type;
+ typedef oqgraph3::edge_index_property_map const_type;
+ };
+
+}
+
+namespace oqgraph3
+{
+ using namespace boost;
+
inline graph_traits<oqgraph3::graph>::vertex_descriptor
source(
const graph_traits<oqgraph3::graph>::edge_descriptor& e,
@@ -401,27 +428,6 @@ namespace boost
return count;
}
- template<>
- struct property_map<oqgraph3::graph, edge_weight_t>
- {
- typedef void type;
- typedef oqgraph3::edge_weight_property_map const_type;
- };
-
- template<>
- struct property_map<oqgraph3::graph, vertex_index_t>
- {
- typedef void type;
- typedef oqgraph3::vertex_index_property_map const_type;
- };
-
- template<>
- struct property_map<oqgraph3::graph, edge_index_t>
- {
- typedef void type;
- typedef oqgraph3::edge_index_property_map const_type;
- };
-
inline property_map<
oqgraph3::graph,
edge_weight_t>::const_type::reference