Update to 0.8.2
This commit is contained in:
parent
5a4d3513a1
commit
0121d79ee0
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=52311
24 changed files with 166 additions and 210 deletions
|
@ -6,7 +6,7 @@
|
|||
#
|
||||
|
||||
PORTNAME= ogle
|
||||
PORTVERSION= 0.7.5
|
||||
PORTVERSION= 0.8.2
|
||||
CATEGORIES= graphics gnome
|
||||
MASTER_SITES= http://www.dtek.chalmers.se/groups/dvd/dist/
|
||||
PKGNAMESUFFIX= -gui
|
||||
|
@ -14,34 +14,37 @@ DISTNAME= ${PORTNAME}_gui-${PORTVERSION}
|
|||
|
||||
MAINTAINER= lioux@FreeBSD.org
|
||||
|
||||
BUILD_DEPENDS= ${LOCALBASE}/lib/ogle/libdvdcontrol.so.4:${PORTSDIR}/graphics/ogle
|
||||
BUILD_DEPENDS= ${LOCALBASE}/lib/ogle/libdvdcontrol.so.5:${PORTSDIR}/graphics/ogle
|
||||
LIB_DEPENDS= intl.1:${PORTSDIR}/devel/gettext \
|
||||
jpeg.9:${PORTSDIR}/graphics/jpeg
|
||||
giconv.2:${PORTSDIR}/converters/libiconv \
|
||||
glade.4:${PORTSDIR}/devel/libglade \
|
||||
xml2.5:${PORTSDIR}/textproc/libxml2
|
||||
RUN_DEPENDS= ogle:${PORTSDIR}/graphics/ogle
|
||||
|
||||
USE_X_PREFIX= yes
|
||||
USE_GNOMELIBS= yes
|
||||
USE_GTK= yes
|
||||
USE_XPM= yes
|
||||
GNU_CONFIGURE= yes
|
||||
USE_AUTOCONF= yes
|
||||
USE_LIBTOOL= yes
|
||||
CONFIGURE_ENV= CFLAGS="${CFLAGS} -I${LOCALBASE}/include -L${LOCALBASE}/lib"
|
||||
CONFIGURE_ARGS= --with-dvd-includes=${LOCALBASE}/include \
|
||||
--with-dvdcontrol=${LOCALBASE} \
|
||||
--without-included-gettext
|
||||
--without-included-gettext \
|
||||
--with-gtk-prefix=${X11BASE} \
|
||||
--with-libiconv-prefix=${LOCALBASE} \
|
||||
--with-libglade-config=${X11BASE}/bin/libglade-config \
|
||||
--with-xml-prefix=${LOCALBASE}
|
||||
|
||||
post-patch:
|
||||
@${LN} -sf ${LOCALBASE}/bin/libtool ${WRKSRC}
|
||||
@${PERL} -pi -e "s/aclocal/${ACLOCAL}/;s/autoconf/${AUTOCONF}/; \
|
||||
s/autoheader/${AUTOHEADER}/" \
|
||||
${CONFIGURE_WRKSRC}/aclocal.m4
|
||||
@${PERL} -pi -e "s|(libglade\.so)\.0|\1.4|; \
|
||||
s|(PACKAGE_PIXMAPS_DIR=\"$${prefix}/share/)(ogle_gui/\")|\1gnome/\2|; \
|
||||
s!(CONFIG_FILE(\s|=)\")[^/]+?/!\1${LOCALBASE}/!; \
|
||||
s|(CONFIG_FILE_DTD=\")[^/]+?/|\1${LOCALBASE}/|g; \
|
||||
s|(PACKAGE_PIXMAPS_DIR=\").+\"|\1${PREFIX}/share/gnome/ogle_gui/\"|; \
|
||||
s|%%LOCALBASE%%|${LOCALBASE}|" \
|
||||
${CONFIGURE_WRKSRC}/configure
|
||||
|
||||
pre-configure:
|
||||
@${TOUCH} `find -E ${WRKSRC} -regex ".*Makefile\.(am|in)"`
|
||||
.for file in intl/Makefile.in po/Makefile.in.in
|
||||
@${ECHO} 'all:' > ${WRKSRC}/${file}
|
||||
@${ECHO} 'install:' >> ${WRKSRC}/${file}
|
||||
.endfor
|
||||
post-configure:
|
||||
@${LN} -sf ${LOCALBASE}/bin/libtool ${WRKSRC}
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
|
|
@ -1 +1 @@
|
|||
MD5 (ogle_gui-0.7.5.tar.gz) = 1fe07e24fb43c6034f923b2d73fb2559
|
||||
MD5 (ogle_gui-0.8.2.tar.gz) = 2475844fc862d4e280a4d07e83177199
|
||||
|
|
|
@ -1,11 +0,0 @@
|
|||
--- Makefile.in.orig Wed Nov 28 03:37:29 2001
|
||||
+++ Makefile.in Wed Nov 28 03:37:59 2001
|
||||
@@ -121,7 +121,7 @@
|
||||
cxxflags_set = @cxxflags_set@
|
||||
l = @l@
|
||||
|
||||
-SUBDIRS = intl po macros src doc
|
||||
+SUBDIRS = intl po src
|
||||
ACLOCAL_M4 = $(top_srcdir)/aclocal.m4
|
||||
mkinstalldirs = $(SHELL) $(top_srcdir)/mkinstalldirs
|
||||
CONFIG_HEADER = config.h
|
11
graphics/ogle-gui/files/patch-configure
Normal file
11
graphics/ogle-gui/files/patch-configure
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- configure.orig Wed Dec 5 19:43:10 2001
|
||||
+++ configure Fri Dec 21 01:20:00 2001
|
||||
@@ -1506,6 +1506,8 @@
|
||||
ogle_pkglibdir=${exec_prefix}/lib/ogle
|
||||
fi
|
||||
|
||||
+ogle_pkglibdir=%%LOCALBASE%%/lib/ogle
|
||||
+
|
||||
echo "$as_me:1509: checking for ogle helper dir" >&5
|
||||
echo $ECHO_N "checking for ogle helper dir... $ECHO_C" >&6
|
||||
if test ! -x ${ogle_pkglibdir}/ogle_ctrl; then
|
|
@ -1,25 +0,0 @@
|
|||
--- configure.in.orig Tue Sep 18 22:31:48 2001
|
||||
+++ configure.in Thu Oct 25 14:19:39 2001
|
||||
@@ -19,6 +19,9 @@
|
||||
GNOME_COMPILE_WARNINGS
|
||||
GNOME_X_CHECKS
|
||||
|
||||
+dnl Checks for header files.
|
||||
+AC_CHECK_HEADERS(sys/param.h)
|
||||
+
|
||||
dnl Add the languages which your application supports here.
|
||||
ALL_LINGUAS=""
|
||||
AM_GNU_GETTEXT
|
||||
@@ -86,6 +89,12 @@
|
||||
;;
|
||||
linux*)
|
||||
AC_DEFINE(LINUX, 1, [This is a Linux system])
|
||||
+ ;;
|
||||
+ freebsd*)
|
||||
+ AC_DEFINE(FREEBSD, 1, [This is a FreeBSD system])
|
||||
+ ;;
|
||||
+ netbsd*|openbsd*)
|
||||
+ AC_DEFINE(BSDfamily, 1, [This is a BSD system])
|
||||
;;
|
||||
*)
|
||||
epa
|
|
@ -1,13 +0,0 @@
|
|||
--- src/callbacks.c.orig Mon Sep 17 23:20:48 2001
|
||||
+++ src/callbacks.c Mon Oct 22 15:45:26 2001
|
||||
@@ -124,6 +124,10 @@
|
||||
#else
|
||||
#ifdef SOLARIS
|
||||
char *dev="/cdrom/cdrom0";
|
||||
+#elif FREEBSD
|
||||
+ char *dev="/dev/acd0c";
|
||||
+#elif BSDfamily
|
||||
+ char *dev="/dev/racd0c";
|
||||
#else
|
||||
#error "No default path."
|
||||
#endif
|
|
@ -1,35 +1,38 @@
|
|||
--- src/xsniffer.c.orig Thu Sep 6 14:10:17 2001
|
||||
+++ src/xsniffer.c Thu Oct 25 18:22:04 2001
|
||||
@@ -16,6 +16,10 @@
|
||||
--- src/xsniffer.c.orig Sat Dec 8 14:28:37 2001
|
||||
+++ src/xsniffer.c Sat Dec 8 15:33:28 2001
|
||||
@@ -16,6 +16,11 @@
|
||||
* Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
|
||||
*/
|
||||
|
||||
+#ifdef HAVE_CONFIG_H
|
||||
+# include <config.h>
|
||||
+#endif
|
||||
+#define HAVE_SYS_PARAM_H
|
||||
+
|
||||
#include <stdio.h>
|
||||
#include <stdlib.h>
|
||||
#include <unistd.h>
|
||||
@@ -35,6 +39,9 @@
|
||||
#include "xsniffer.h"
|
||||
@@ -35,6 +40,10 @@
|
||||
#include "callbacks.h"
|
||||
#include "bindings.h"
|
||||
|
||||
+#ifdef HAVE_SYS_PARAM_H
|
||||
+#include <sys/param.h>
|
||||
+#endif
|
||||
|
||||
+
|
||||
extern int msgqid;
|
||||
|
||||
@@ -66,7 +73,12 @@
|
||||
|
||||
@@ -64,7 +73,13 @@
|
||||
init_actions(nav2);
|
||||
|
||||
fprintf(stderr, "xsniff_mouse\n");
|
||||
while(1) {
|
||||
- DVDNextEvent(nav2, &mev);
|
||||
+
|
||||
+#if (defined(BSD) && (BSD >= 199306))
|
||||
+ if (DVDNextEventNonBlocking(nav2, &mev) != DVD_E_Ok)
|
||||
+#else
|
||||
+ if (DVDNextEvent(nav2, &mev) != DVD_E_Ok)
|
||||
+ if (DVDNextEvent(nav2, &mev) != DVD_E_Ok)
|
||||
+#endif
|
||||
+ pthread_exit(NULL);
|
||||
|
||||
|
|
|
@ -1,23 +1,33 @@
|
|||
bin/ogle_gui
|
||||
share/pixmaps/ogle_gui/angle.xpm
|
||||
share/pixmaps/ogle_gui/enter.xpm
|
||||
share/pixmaps/ogle_gui/fastforward.xpm
|
||||
share/pixmaps/ogle_gui/go_up.xpm
|
||||
share/pixmaps/ogle_gui/menus.xpm
|
||||
share/pixmaps/ogle_gui/rewind.xpm
|
||||
share/pixmaps/ogle_gui/skip_backwards.xpm
|
||||
share/pixmaps/ogle_gui/skip_forwards.xpm
|
||||
share/pixmaps/ogle_gui/stock_down_arrow.xpm
|
||||
share/pixmaps/ogle_gui/stock_first.xpm
|
||||
share/pixmaps/ogle_gui/stock_last.xpm
|
||||
share/pixmaps/ogle_gui/stock_left_arrow.xpm
|
||||
share/pixmaps/ogle_gui/stock_pause.xpm
|
||||
share/pixmaps/ogle_gui/stock_right_arrow.xpm
|
||||
share/pixmaps/ogle_gui/stock_stop.xpm
|
||||
share/pixmaps/ogle_gui/stock_timer.xpm
|
||||
share/pixmaps/ogle_gui/stock_timer_stopped.xpm
|
||||
share/pixmaps/ogle_gui/stock_up_arrow.xpm
|
||||
share/pixmaps/ogle_gui/stock_volume.xpm
|
||||
share/pixmaps/ogle_gui/subpicture.xpm
|
||||
@dirrm share/pixmaps/ogle_gui
|
||||
@unexec rmdir share/pixmaps 2>/dev/null || true
|
||||
lib/ogle/ogle_gui
|
||||
share/gnome/locale/de/LC_MESSAGES/ogle_gui.mo
|
||||
share/gnome/locale/sv/LC_MESSAGES/ogle_gui.mo
|
||||
share/gnome/ogle_gui/angle.xpm
|
||||
share/gnome/ogle_gui/enter.xpm
|
||||
share/gnome/ogle_gui/fastforward.xpm
|
||||
share/gnome/ogle_gui/go_up.xpm
|
||||
share/gnome/ogle_gui/menus.xpm
|
||||
share/gnome/ogle_gui/ogle.xpm
|
||||
share/gnome/ogle_gui/ogle_gui.glade
|
||||
share/gnome/ogle_gui/rewind.xpm
|
||||
share/gnome/ogle_gui/skip_backwards.xpm
|
||||
share/gnome/ogle_gui/skip_forwards.xpm
|
||||
share/gnome/ogle_gui/stock_down_arrow.xpm
|
||||
share/gnome/ogle_gui/stock_first.xpm
|
||||
share/gnome/ogle_gui/stock_last.xpm
|
||||
share/gnome/ogle_gui/stock_left_arrow.xpm
|
||||
share/gnome/ogle_gui/stock_pause.xpm
|
||||
share/gnome/ogle_gui/stock_right_arrow.xpm
|
||||
share/gnome/ogle_gui/stock_stop.xpm
|
||||
share/gnome/ogle_gui/stock_timer.xpm
|
||||
share/gnome/ogle_gui/stock_timer_stopped.xpm
|
||||
share/gnome/ogle_gui/stock_up_arrow.xpm
|
||||
share/gnome/ogle_gui/stock_volume.xpm
|
||||
share/gnome/ogle_gui/subpicture.xpm
|
||||
@dirrm share/gnome/ogle_gui
|
||||
@unexec rmdir %D/share/gnome/locale/sv/LC_MESSAGES 2>/dev/null || true
|
||||
@unexec rmdir %D/share/gnome/locale/sv 2>/dev/null || true
|
||||
@unexec rmdir %D/share/gnome/locale/de/LC_MESSAGES 2>/dev/null || true
|
||||
@unexec rmdir %D/share/gnome/locale/de 2>/dev/null || true
|
||||
@unexec rmdir %D/share/gnome/locale 2>/dev/null || true
|
||||
@unexec rmdir %D/share/gnome 2>/dev/null || true
|
||||
@dirrm lib/ogle
|
||||
|
|
|
@ -6,7 +6,7 @@
|
|||
#
|
||||
|
||||
PORTNAME= ogle
|
||||
PORTVERSION= 0.8.1
|
||||
PORTVERSION= 0.8.2
|
||||
CATEGORIES= graphics
|
||||
MASTER_SITES= http://www.dtek.chalmers.se/groups/dvd/dist/
|
||||
|
||||
|
|
|
@ -1 +1 @@
|
|||
MD5 (ogle-0.8.1.tar.gz) = 0152baeeba763908044fc942117e5dcd
|
||||
MD5 (ogle-0.8.2.tar.gz) = 0b2c949e372b7e79f9106d99c5d2ba45
|
||||
|
|
|
@ -1,11 +1,11 @@
|
|||
--- scripts/ogle.in.orig Mon Oct 22 17:37:48 2001
|
||||
+++ scripts/ogle.in Mon Oct 22 17:39:18 2001
|
||||
--- scripts/ogle.in.orig Sat Oct 13 18:49:29 2001
|
||||
+++ scripts/ogle.in Sun Dec 23 17:59:41 2001
|
||||
@@ -27,7 +27,7 @@
|
||||
if [ -x $DVDP_ROOT/ogle_gui ]; then
|
||||
DVDP_UI=$DVDP_ROOT/ogle_gui
|
||||
else
|
||||
-DVDP_UI=$exec_prefix/bin/ogle_gui
|
||||
+DVDP_UI=%%X11BASE%%/bin/ogle_gui
|
||||
+DVDP_UI=%%X11BASE%%/lib/ogle/ogle_gui
|
||||
fi
|
||||
export DVDP_UI
|
||||
#DVDP_AC3=$DVDP_ROOT/ogle_ac3_p
|
||||
|
|
|
@ -7,11 +7,11 @@ include/ogle/msgevents.h
|
|||
lib/ogle/libdvdcontrol.a
|
||||
lib/ogle/libdvdcontrol.la
|
||||
lib/ogle/libdvdcontrol.so
|
||||
lib/ogle/libdvdcontrol.so.4
|
||||
lib/ogle/libdvdcontrol.so.5
|
||||
lib/ogle/libmsgevents.a
|
||||
lib/ogle/libmsgevents.la
|
||||
lib/ogle/libmsgevents.so
|
||||
lib/ogle/libmsgevents.so.3
|
||||
lib/ogle/libmsgevents.so.4
|
||||
lib/ogle/ogle_a52
|
||||
lib/ogle/ogle_ac3_p
|
||||
lib/ogle/ogle_cli
|
||||
|
|
|
@ -6,7 +6,7 @@
|
|||
#
|
||||
|
||||
PORTNAME= ogle
|
||||
PORTVERSION= 0.7.5
|
||||
PORTVERSION= 0.8.2
|
||||
CATEGORIES= graphics gnome
|
||||
MASTER_SITES= http://www.dtek.chalmers.se/groups/dvd/dist/
|
||||
PKGNAMESUFFIX= -gui
|
||||
|
@ -14,34 +14,37 @@ DISTNAME= ${PORTNAME}_gui-${PORTVERSION}
|
|||
|
||||
MAINTAINER= lioux@FreeBSD.org
|
||||
|
||||
BUILD_DEPENDS= ${LOCALBASE}/lib/ogle/libdvdcontrol.so.4:${PORTSDIR}/graphics/ogle
|
||||
BUILD_DEPENDS= ${LOCALBASE}/lib/ogle/libdvdcontrol.so.5:${PORTSDIR}/graphics/ogle
|
||||
LIB_DEPENDS= intl.1:${PORTSDIR}/devel/gettext \
|
||||
jpeg.9:${PORTSDIR}/graphics/jpeg
|
||||
giconv.2:${PORTSDIR}/converters/libiconv \
|
||||
glade.4:${PORTSDIR}/devel/libglade \
|
||||
xml2.5:${PORTSDIR}/textproc/libxml2
|
||||
RUN_DEPENDS= ogle:${PORTSDIR}/graphics/ogle
|
||||
|
||||
USE_X_PREFIX= yes
|
||||
USE_GNOMELIBS= yes
|
||||
USE_GTK= yes
|
||||
USE_XPM= yes
|
||||
GNU_CONFIGURE= yes
|
||||
USE_AUTOCONF= yes
|
||||
USE_LIBTOOL= yes
|
||||
CONFIGURE_ENV= CFLAGS="${CFLAGS} -I${LOCALBASE}/include -L${LOCALBASE}/lib"
|
||||
CONFIGURE_ARGS= --with-dvd-includes=${LOCALBASE}/include \
|
||||
--with-dvdcontrol=${LOCALBASE} \
|
||||
--without-included-gettext
|
||||
--without-included-gettext \
|
||||
--with-gtk-prefix=${X11BASE} \
|
||||
--with-libiconv-prefix=${LOCALBASE} \
|
||||
--with-libglade-config=${X11BASE}/bin/libglade-config \
|
||||
--with-xml-prefix=${LOCALBASE}
|
||||
|
||||
post-patch:
|
||||
@${LN} -sf ${LOCALBASE}/bin/libtool ${WRKSRC}
|
||||
@${PERL} -pi -e "s/aclocal/${ACLOCAL}/;s/autoconf/${AUTOCONF}/; \
|
||||
s/autoheader/${AUTOHEADER}/" \
|
||||
${CONFIGURE_WRKSRC}/aclocal.m4
|
||||
@${PERL} -pi -e "s|(libglade\.so)\.0|\1.4|; \
|
||||
s|(PACKAGE_PIXMAPS_DIR=\"$${prefix}/share/)(ogle_gui/\")|\1gnome/\2|; \
|
||||
s!(CONFIG_FILE(\s|=)\")[^/]+?/!\1${LOCALBASE}/!; \
|
||||
s|(CONFIG_FILE_DTD=\")[^/]+?/|\1${LOCALBASE}/|g; \
|
||||
s|(PACKAGE_PIXMAPS_DIR=\").+\"|\1${PREFIX}/share/gnome/ogle_gui/\"|; \
|
||||
s|%%LOCALBASE%%|${LOCALBASE}|" \
|
||||
${CONFIGURE_WRKSRC}/configure
|
||||
|
||||
pre-configure:
|
||||
@${TOUCH} `find -E ${WRKSRC} -regex ".*Makefile\.(am|in)"`
|
||||
.for file in intl/Makefile.in po/Makefile.in.in
|
||||
@${ECHO} 'all:' > ${WRKSRC}/${file}
|
||||
@${ECHO} 'install:' >> ${WRKSRC}/${file}
|
||||
.endfor
|
||||
post-configure:
|
||||
@${LN} -sf ${LOCALBASE}/bin/libtool ${WRKSRC}
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
|
|
@ -1 +1 @@
|
|||
MD5 (ogle_gui-0.7.5.tar.gz) = 1fe07e24fb43c6034f923b2d73fb2559
|
||||
MD5 (ogle_gui-0.8.2.tar.gz) = 2475844fc862d4e280a4d07e83177199
|
||||
|
|
|
@ -1,11 +0,0 @@
|
|||
--- Makefile.in.orig Wed Nov 28 03:37:29 2001
|
||||
+++ Makefile.in Wed Nov 28 03:37:59 2001
|
||||
@@ -121,7 +121,7 @@
|
||||
cxxflags_set = @cxxflags_set@
|
||||
l = @l@
|
||||
|
||||
-SUBDIRS = intl po macros src doc
|
||||
+SUBDIRS = intl po src
|
||||
ACLOCAL_M4 = $(top_srcdir)/aclocal.m4
|
||||
mkinstalldirs = $(SHELL) $(top_srcdir)/mkinstalldirs
|
||||
CONFIG_HEADER = config.h
|
11
multimedia/ogle-gui/files/patch-configure
Normal file
11
multimedia/ogle-gui/files/patch-configure
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- configure.orig Wed Dec 5 19:43:10 2001
|
||||
+++ configure Fri Dec 21 01:20:00 2001
|
||||
@@ -1506,6 +1506,8 @@
|
||||
ogle_pkglibdir=${exec_prefix}/lib/ogle
|
||||
fi
|
||||
|
||||
+ogle_pkglibdir=%%LOCALBASE%%/lib/ogle
|
||||
+
|
||||
echo "$as_me:1509: checking for ogle helper dir" >&5
|
||||
echo $ECHO_N "checking for ogle helper dir... $ECHO_C" >&6
|
||||
if test ! -x ${ogle_pkglibdir}/ogle_ctrl; then
|
|
@ -1,25 +0,0 @@
|
|||
--- configure.in.orig Tue Sep 18 22:31:48 2001
|
||||
+++ configure.in Thu Oct 25 14:19:39 2001
|
||||
@@ -19,6 +19,9 @@
|
||||
GNOME_COMPILE_WARNINGS
|
||||
GNOME_X_CHECKS
|
||||
|
||||
+dnl Checks for header files.
|
||||
+AC_CHECK_HEADERS(sys/param.h)
|
||||
+
|
||||
dnl Add the languages which your application supports here.
|
||||
ALL_LINGUAS=""
|
||||
AM_GNU_GETTEXT
|
||||
@@ -86,6 +89,12 @@
|
||||
;;
|
||||
linux*)
|
||||
AC_DEFINE(LINUX, 1, [This is a Linux system])
|
||||
+ ;;
|
||||
+ freebsd*)
|
||||
+ AC_DEFINE(FREEBSD, 1, [This is a FreeBSD system])
|
||||
+ ;;
|
||||
+ netbsd*|openbsd*)
|
||||
+ AC_DEFINE(BSDfamily, 1, [This is a BSD system])
|
||||
;;
|
||||
*)
|
||||
epa
|
|
@ -1,13 +0,0 @@
|
|||
--- src/callbacks.c.orig Mon Sep 17 23:20:48 2001
|
||||
+++ src/callbacks.c Mon Oct 22 15:45:26 2001
|
||||
@@ -124,6 +124,10 @@
|
||||
#else
|
||||
#ifdef SOLARIS
|
||||
char *dev="/cdrom/cdrom0";
|
||||
+#elif FREEBSD
|
||||
+ char *dev="/dev/acd0c";
|
||||
+#elif BSDfamily
|
||||
+ char *dev="/dev/racd0c";
|
||||
#else
|
||||
#error "No default path."
|
||||
#endif
|
|
@ -1,35 +1,38 @@
|
|||
--- src/xsniffer.c.orig Thu Sep 6 14:10:17 2001
|
||||
+++ src/xsniffer.c Thu Oct 25 18:22:04 2001
|
||||
@@ -16,6 +16,10 @@
|
||||
--- src/xsniffer.c.orig Sat Dec 8 14:28:37 2001
|
||||
+++ src/xsniffer.c Sat Dec 8 15:33:28 2001
|
||||
@@ -16,6 +16,11 @@
|
||||
* Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
|
||||
*/
|
||||
|
||||
+#ifdef HAVE_CONFIG_H
|
||||
+# include <config.h>
|
||||
+#endif
|
||||
+#define HAVE_SYS_PARAM_H
|
||||
+
|
||||
#include <stdio.h>
|
||||
#include <stdlib.h>
|
||||
#include <unistd.h>
|
||||
@@ -35,6 +39,9 @@
|
||||
#include "xsniffer.h"
|
||||
@@ -35,6 +40,10 @@
|
||||
#include "callbacks.h"
|
||||
#include "bindings.h"
|
||||
|
||||
+#ifdef HAVE_SYS_PARAM_H
|
||||
+#include <sys/param.h>
|
||||
+#endif
|
||||
|
||||
+
|
||||
extern int msgqid;
|
||||
|
||||
@@ -66,7 +73,12 @@
|
||||
|
||||
@@ -64,7 +73,13 @@
|
||||
init_actions(nav2);
|
||||
|
||||
fprintf(stderr, "xsniff_mouse\n");
|
||||
while(1) {
|
||||
- DVDNextEvent(nav2, &mev);
|
||||
+
|
||||
+#if (defined(BSD) && (BSD >= 199306))
|
||||
+ if (DVDNextEventNonBlocking(nav2, &mev) != DVD_E_Ok)
|
||||
+#else
|
||||
+ if (DVDNextEvent(nav2, &mev) != DVD_E_Ok)
|
||||
+ if (DVDNextEvent(nav2, &mev) != DVD_E_Ok)
|
||||
+#endif
|
||||
+ pthread_exit(NULL);
|
||||
|
||||
|
|
|
@ -1,23 +1,33 @@
|
|||
bin/ogle_gui
|
||||
share/pixmaps/ogle_gui/angle.xpm
|
||||
share/pixmaps/ogle_gui/enter.xpm
|
||||
share/pixmaps/ogle_gui/fastforward.xpm
|
||||
share/pixmaps/ogle_gui/go_up.xpm
|
||||
share/pixmaps/ogle_gui/menus.xpm
|
||||
share/pixmaps/ogle_gui/rewind.xpm
|
||||
share/pixmaps/ogle_gui/skip_backwards.xpm
|
||||
share/pixmaps/ogle_gui/skip_forwards.xpm
|
||||
share/pixmaps/ogle_gui/stock_down_arrow.xpm
|
||||
share/pixmaps/ogle_gui/stock_first.xpm
|
||||
share/pixmaps/ogle_gui/stock_last.xpm
|
||||
share/pixmaps/ogle_gui/stock_left_arrow.xpm
|
||||
share/pixmaps/ogle_gui/stock_pause.xpm
|
||||
share/pixmaps/ogle_gui/stock_right_arrow.xpm
|
||||
share/pixmaps/ogle_gui/stock_stop.xpm
|
||||
share/pixmaps/ogle_gui/stock_timer.xpm
|
||||
share/pixmaps/ogle_gui/stock_timer_stopped.xpm
|
||||
share/pixmaps/ogle_gui/stock_up_arrow.xpm
|
||||
share/pixmaps/ogle_gui/stock_volume.xpm
|
||||
share/pixmaps/ogle_gui/subpicture.xpm
|
||||
@dirrm share/pixmaps/ogle_gui
|
||||
@unexec rmdir share/pixmaps 2>/dev/null || true
|
||||
lib/ogle/ogle_gui
|
||||
share/gnome/locale/de/LC_MESSAGES/ogle_gui.mo
|
||||
share/gnome/locale/sv/LC_MESSAGES/ogle_gui.mo
|
||||
share/gnome/ogle_gui/angle.xpm
|
||||
share/gnome/ogle_gui/enter.xpm
|
||||
share/gnome/ogle_gui/fastforward.xpm
|
||||
share/gnome/ogle_gui/go_up.xpm
|
||||
share/gnome/ogle_gui/menus.xpm
|
||||
share/gnome/ogle_gui/ogle.xpm
|
||||
share/gnome/ogle_gui/ogle_gui.glade
|
||||
share/gnome/ogle_gui/rewind.xpm
|
||||
share/gnome/ogle_gui/skip_backwards.xpm
|
||||
share/gnome/ogle_gui/skip_forwards.xpm
|
||||
share/gnome/ogle_gui/stock_down_arrow.xpm
|
||||
share/gnome/ogle_gui/stock_first.xpm
|
||||
share/gnome/ogle_gui/stock_last.xpm
|
||||
share/gnome/ogle_gui/stock_left_arrow.xpm
|
||||
share/gnome/ogle_gui/stock_pause.xpm
|
||||
share/gnome/ogle_gui/stock_right_arrow.xpm
|
||||
share/gnome/ogle_gui/stock_stop.xpm
|
||||
share/gnome/ogle_gui/stock_timer.xpm
|
||||
share/gnome/ogle_gui/stock_timer_stopped.xpm
|
||||
share/gnome/ogle_gui/stock_up_arrow.xpm
|
||||
share/gnome/ogle_gui/stock_volume.xpm
|
||||
share/gnome/ogle_gui/subpicture.xpm
|
||||
@dirrm share/gnome/ogle_gui
|
||||
@unexec rmdir %D/share/gnome/locale/sv/LC_MESSAGES 2>/dev/null || true
|
||||
@unexec rmdir %D/share/gnome/locale/sv 2>/dev/null || true
|
||||
@unexec rmdir %D/share/gnome/locale/de/LC_MESSAGES 2>/dev/null || true
|
||||
@unexec rmdir %D/share/gnome/locale/de 2>/dev/null || true
|
||||
@unexec rmdir %D/share/gnome/locale 2>/dev/null || true
|
||||
@unexec rmdir %D/share/gnome 2>/dev/null || true
|
||||
@dirrm lib/ogle
|
||||
|
|
|
@ -6,7 +6,7 @@
|
|||
#
|
||||
|
||||
PORTNAME= ogle
|
||||
PORTVERSION= 0.8.1
|
||||
PORTVERSION= 0.8.2
|
||||
CATEGORIES= graphics
|
||||
MASTER_SITES= http://www.dtek.chalmers.se/groups/dvd/dist/
|
||||
|
||||
|
|
|
@ -1 +1 @@
|
|||
MD5 (ogle-0.8.1.tar.gz) = 0152baeeba763908044fc942117e5dcd
|
||||
MD5 (ogle-0.8.2.tar.gz) = 0b2c949e372b7e79f9106d99c5d2ba45
|
||||
|
|
|
@ -1,11 +1,11 @@
|
|||
--- scripts/ogle.in.orig Mon Oct 22 17:37:48 2001
|
||||
+++ scripts/ogle.in Mon Oct 22 17:39:18 2001
|
||||
--- scripts/ogle.in.orig Sat Oct 13 18:49:29 2001
|
||||
+++ scripts/ogle.in Sun Dec 23 17:59:41 2001
|
||||
@@ -27,7 +27,7 @@
|
||||
if [ -x $DVDP_ROOT/ogle_gui ]; then
|
||||
DVDP_UI=$DVDP_ROOT/ogle_gui
|
||||
else
|
||||
-DVDP_UI=$exec_prefix/bin/ogle_gui
|
||||
+DVDP_UI=%%X11BASE%%/bin/ogle_gui
|
||||
+DVDP_UI=%%X11BASE%%/lib/ogle/ogle_gui
|
||||
fi
|
||||
export DVDP_UI
|
||||
#DVDP_AC3=$DVDP_ROOT/ogle_ac3_p
|
||||
|
|
|
@ -7,11 +7,11 @@ include/ogle/msgevents.h
|
|||
lib/ogle/libdvdcontrol.a
|
||||
lib/ogle/libdvdcontrol.la
|
||||
lib/ogle/libdvdcontrol.so
|
||||
lib/ogle/libdvdcontrol.so.4
|
||||
lib/ogle/libdvdcontrol.so.5
|
||||
lib/ogle/libmsgevents.a
|
||||
lib/ogle/libmsgevents.la
|
||||
lib/ogle/libmsgevents.so
|
||||
lib/ogle/libmsgevents.so.3
|
||||
lib/ogle/libmsgevents.so.4
|
||||
lib/ogle/ogle_a52
|
||||
lib/ogle/ogle_ac3_p
|
||||
lib/ogle/ogle_cli
|
||||
|
|
Loading…
Reference in a new issue