2006-12-01 misc/instant-workstation: Incomplete pkg-plist
2006-12-01 lang/yap: Does not compile 2006-12-01 lang/tensile: "Coredump during build on FreeBSD >= 6.x"
This commit is contained in:
parent
2782bcfe89
commit
013c547f10
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=181532
17 changed files with 3 additions and 360 deletions
3
MOVED
3
MOVED
|
@ -2654,3 +2654,6 @@ print/ec-fonts-mftraced||2007-01-05|Has expired: Installs files before 'make ins
|
|||
print/yatex-xemacs-mule||2007-01-05|Has expired: hangs during build
|
||||
security/gnu-crypto||2007-01-05|Has expired: Does not compile
|
||||
www/linux-beonex||2007-01-05|Has expired: Security issues. From http://www.beonex.com/ 'The currently available Beonex Communicator 0.8 builds have several known security bugs'
|
||||
misc/instant-workstation||2007-01-05|Has expired: Incomplete pkg-plist
|
||||
lang/yap||2007-01-05|Has expired: Does not compile
|
||||
lang/tensile||2007-01-05|Has expired: "Coredump during build on FreeBSD >= 6.x"
|
||||
|
|
|
@ -318,7 +318,6 @@
|
|||
SUBDIR += tcl84-thread
|
||||
SUBDIR += tclX
|
||||
SUBDIR += tcltutor
|
||||
SUBDIR += tensile
|
||||
SUBDIR += tinycobol
|
||||
SUBDIR += tolua
|
||||
SUBDIR += tolua++
|
||||
|
@ -332,7 +331,6 @@
|
|||
SUBDIR += xotcl
|
||||
SUBDIR += xsb
|
||||
SUBDIR += yabasic
|
||||
SUBDIR += yap
|
||||
SUBDIR += yarv
|
||||
SUBDIR += yorick
|
||||
SUBDIR += yorick-doc
|
||||
|
|
|
@ -1,53 +0,0 @@
|
|||
# ex:ts=8
|
||||
# Ports collection makefile for: tensile
|
||||
# Date created: May 6, 2002
|
||||
# Whom: ijliao
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= tensile
|
||||
PORTVERSION= 0.9
|
||||
PORTREVISION= 1
|
||||
PORTEPOCH= 1
|
||||
CATEGORIES= lang
|
||||
MASTER_SITES= http://unixpages.org/distfiles/
|
||||
|
||||
MAINTAINER= ports@FreeBSD.org
|
||||
COMMENT= Programming language designed for especially complex processing texts
|
||||
|
||||
LIB_DEPENDS= utils.1:${PORTSDIR}/lang/libutils
|
||||
|
||||
BROKEN= Segfault during build
|
||||
DEPRECATED= ${BROKEN}
|
||||
EXPIRATION_DATE=2006-12-01
|
||||
|
||||
USE_AUTOTOOLS= libltdl:15
|
||||
USE_GMAKE= yes
|
||||
GNU_CONFIGURE= yes
|
||||
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
|
||||
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
|
||||
LDFLAGS="-L${LOCALBASE}/lib"
|
||||
CONFIGURE_ARGS= --disable-module-postgres
|
||||
MAKE_ARGS= CFLAGS="${CFLAGS}"
|
||||
USE_LDCONFIG= yes
|
||||
|
||||
MAN1= sl.1 sla.1
|
||||
MAN7= docstrip.7t sl_crypt.7t sl_files.7t sl_fpmath.7t sl_int64.7t \
|
||||
sl_ncurses.7t sl_postgres.7t sl_rand.7t sl_readline.7t
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
.if ${OSVERSION} >= 600000
|
||||
BROKEN= "Coredump during build on FreeBSD >= 6.x"
|
||||
.endif
|
||||
|
||||
.if ${OSVERSION} < 400010
|
||||
LIB_DEPENDS+= ncurses.5:${PORTSDIR}/devel/ncurses
|
||||
.endif
|
||||
|
||||
post-patch:
|
||||
@${FIND} ${WRKSRC} -name "Makefile.in" | ${XARGS} ${REINPLACE_CMD} -e \
|
||||
's|= -module$$|= -module -avoid-version|g'
|
||||
|
||||
.include <bsd.port.post.mk>
|
|
@ -1,3 +0,0 @@
|
|||
MD5 (tensile-0.9.tar.gz) = 33aef6af31dd07e27f4eae36ac25c0ed
|
||||
SHA256 (tensile-0.9.tar.gz) = 473adf5e968700fa75f5c134bad8f88ec77a3bb0d666312040f618816e39d8cd
|
||||
SIZE (tensile-0.9.tar.gz) = 984267
|
|
@ -1,10 +0,0 @@
|
|||
--- configure.orig Sat Jan 4 22:06:49 2003
|
||||
+++ configure Mon Jul 21 23:16:45 2003
|
||||
@@ -7827,6 +7827,7 @@
|
||||
|
||||
# This can be used to rebuild libtool when needed
|
||||
LIBTOOL_DEPS="$ac_aux_dir/ltmain.sh"
|
||||
+$ac_aux_dir/ltconfig $LIBTOOL_DEPS
|
||||
|
||||
# Always use our own libtool.
|
||||
LIBTOOL='$(SHELL) $(top_builddir)/libtool'
|
|
@ -1,11 +0,0 @@
|
|||
Tensile is a brand-new programming languages designed especially
|
||||
for complex processing texts in SGML-like formats. Its key feature
|
||||
is the notion of finite-state automata used for defining text
|
||||
transformations. Tensile has been designed, too, for Web programming,
|
||||
so it has inherent CGI capabilities.
|
||||
|
||||
Tensile is an exTENSIbLE language which means that (a) pluggable
|
||||
modules are supported and (b) user-defined and predefined entities
|
||||
are mostly treated in the same way.
|
||||
|
||||
WWW: http://www.nongnu.org/nsl/
|
|
@ -1,113 +0,0 @@
|
|||
bin/docstrip
|
||||
bin/sl
|
||||
bin/sla
|
||||
lib/libtenpdt.a
|
||||
lib/libtenpdt.so
|
||||
lib/libtenpdt.so.0
|
||||
lib/libtensile.a
|
||||
lib/libtensile.so
|
||||
lib/libtensile.so.0
|
||||
lib/nsl/automata/arith.aut
|
||||
lib/nsl/automata/ascii.aut
|
||||
lib/nsl/automata/base64enc.aut
|
||||
lib/nsl/automata/chardef.aui
|
||||
lib/nsl/automata/cp1251.aut
|
||||
lib/nsl/automata/emailtrn.aut
|
||||
lib/nsl/automata/empty.aut
|
||||
lib/nsl/automata/escape.aut
|
||||
lib/nsl/automata/html.aut
|
||||
lib/nsl/automata/intconv.aut
|
||||
lib/nsl/automata/koi8r.aut
|
||||
lib/nsl/automata/linefilter.aut
|
||||
lib/nsl/automata/swabytes.aut
|
||||
lib/nsl/automata/unicode.aut
|
||||
lib/nsl/automata/urlencode.aut
|
||||
lib/nsl/automata/utf8.aut
|
||||
lib/nsl/automata/whole.aut
|
||||
lib/nsl/module.map
|
||||
lib/nsl/modules/crypt.scm
|
||||
lib/nsl/modules/crypt.so
|
||||
lib/nsl/modules/files.scm
|
||||
lib/nsl/modules/files.so
|
||||
lib/nsl/modules/fpmath.scm
|
||||
lib/nsl/modules/fpmath.so
|
||||
lib/nsl/modules/int64.scm
|
||||
lib/nsl/modules/int64.so
|
||||
lib/nsl/modules/ncurses.scm
|
||||
lib/nsl/modules/ncurses.so
|
||||
lib/nsl/modules/rand.scm
|
||||
lib/nsl/modules/rand.so
|
||||
lib/nsl/modules/readline.scm
|
||||
lib/nsl/modules/readline.so
|
||||
lib/nsl/modules/sockets.scm
|
||||
lib/nsl/modules/sockets.so
|
||||
lib/nsl/modules/time.scm
|
||||
lib/nsl/modules/time.so
|
||||
lib/nsl/preload.scm
|
||||
lib/nsl/scripts/base64enc.sc
|
||||
lib/nsl/scripts/bstream.sc
|
||||
lib/nsl/scripts/charlist.sc
|
||||
lib/nsl/scripts/counter.sc
|
||||
lib/nsl/scripts/diversion.sc
|
||||
lib/nsl/scripts/docstrip/docstrip.fmt
|
||||
lib/nsl/scripts/docstrip/docstrip_html.sc
|
||||
lib/nsl/scripts/docstrip/docstrip_man.sc
|
||||
lib/nsl/scripts/docstrip/docstrip_plain.sc
|
||||
lib/nsl/scripts/docstrip.sc
|
||||
lib/nsl/scripts/edittable.sc
|
||||
lib/nsl/scripts/empty.sc
|
||||
lib/nsl/scripts/fileutil.sc
|
||||
lib/nsl/scripts/fixhtml.sc
|
||||
lib/nsl/scripts/fontlist.sc
|
||||
lib/nsl/scripts/forumsend.sc
|
||||
lib/nsl/scripts/getopt.sc
|
||||
lib/nsl/scripts/getopt.sci
|
||||
lib/nsl/scripts/html2tex.sc
|
||||
lib/nsl/scripts/htmlinc.sc
|
||||
lib/nsl/scripts/htmlprep.sc
|
||||
lib/nsl/scripts/htmlprepaux.sc
|
||||
lib/nsl/scripts/iden2xml.sc
|
||||
lib/nsl/scripts/keeptrack.sc
|
||||
lib/nsl/scripts/linefilter.sc
|
||||
lib/nsl/scripts/loadsess.sc
|
||||
lib/nsl/scripts/mailbox.sc
|
||||
lib/nsl/scripts/mailbox.sci
|
||||
lib/nsl/scripts/man2html.sc
|
||||
lib/nsl/scripts/mkidentity.sc
|
||||
lib/nsl/scripts/mktable.sc
|
||||
lib/nsl/scripts/mktrie.sc
|
||||
lib/nsl/scripts/mkvote.sc
|
||||
lib/nsl/scripts/newsindex.sc
|
||||
lib/nsl/scripts/newsmaker.sc
|
||||
lib/nsl/scripts/registry.sci
|
||||
lib/nsl/scripts/safehtml.sc
|
||||
lib/nsl/scripts/sendmsg.sc
|
||||
lib/nsl/scripts/session.sc
|
||||
lib/nsl/scripts/sets.sc
|
||||
lib/nsl/scripts/shorthtml.sc
|
||||
lib/nsl/scripts/slexec.sc
|
||||
lib/nsl/scripts/snml2html.sc
|
||||
lib/nsl/scripts/sqlque.sc
|
||||
lib/nsl/scripts/subscribe.sc
|
||||
lib/nsl/scripts/tagmaster.sc
|
||||
lib/nsl/scripts/tmr-cgi.sc
|
||||
lib/nsl/scripts/tmr.sc
|
||||
lib/nsl/scripts/tsh.sc
|
||||
lib/nsl/scripts/unicode.sc
|
||||
lib/nsl/scripts/utf8html.sc
|
||||
lib/nsl/scripts/version.sc
|
||||
lib/nsl/scripts/viewtable.sc
|
||||
lib/nsl/scripts/voteman.sc
|
||||
lib/nsl/scripts/voteres.sc
|
||||
lib/nsl/scripts/wlist.sc
|
||||
lib/nsl/scripts/words.sc
|
||||
lib/nsl/scripts/xtranslate.sc
|
||||
lib/nsl/tables/ent2tex.t
|
||||
lib/nsl/tables/entities.t
|
||||
lib/nsl/tables/sgmlent.t
|
||||
@dirrm lib/nsl/tables
|
||||
@dirrm lib/nsl/scripts/docstrip
|
||||
@dirrm lib/nsl/scripts
|
||||
@dirrm lib/nsl/modules
|
||||
@dirrm lib/nsl/automata
|
||||
@dirrm lib/nsl
|
|
@ -1,58 +0,0 @@
|
|||
# ex:ts=8
|
||||
# New ports collection makefile for: yap
|
||||
# Date created: Apr 29, 2001
|
||||
# Whom: ijliao
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= yap
|
||||
PORTVERSION= 5.1.1
|
||||
PORTREVISION= 0
|
||||
CATEGORIES= lang
|
||||
MASTER_SITES= http://www.ncc.up.pt/~vsc/Yap/current/
|
||||
DISTNAME= Yap-${PORTVERSION}
|
||||
|
||||
MAINTAINER= ports@FreeBSD.org
|
||||
COMMENT= A high-performance Prolog compiler
|
||||
|
||||
LIB_DEPENDS= gmp.7:${PORTSDIR}/math/libgmp4
|
||||
|
||||
BROKEN= Does not compile
|
||||
DEPRECATED= ${BROKEN}
|
||||
EXPIRATION_DATE=2006-12-01
|
||||
|
||||
GNU_CONFIGURE= yes
|
||||
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
|
||||
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
|
||||
LDFLAGS="-L${LOCALBASE}/lib"
|
||||
USE_GMAKE= yes
|
||||
|
||||
INFO= yap
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
post-extract:
|
||||
@${RM} -f ${WRKSRC}/docs/*.info*
|
||||
|
||||
post-patch:
|
||||
@${REINPLACE_CMD} -e 's|VERSION}|VERSION:}|g' ${WRKSRC}/docs/yap.tex
|
||||
@${REINPLACE_CMD} -e "s,make),${GMAKE})," \
|
||||
-e "s,make install,${GMAKE} install," ${WRKSRC}/Makefile.in
|
||||
@${GREP} -lR '<malloc\.h>' ${WRKSRC} | ${XARGS} ${REINPLACE_CMD} \
|
||||
-e 's,<malloc\.h>,<stdlib.h>,'
|
||||
|
||||
post-build:
|
||||
cd ${WRKSRC}/docs && makeinfo --no-split yap.tex
|
||||
|
||||
pre-install:
|
||||
@${MKDIR} ${PREFIX}/${INFO_PATH}
|
||||
${INSTALL_DATA} ${WRKSRC}/docs/yap.info ${PREFIX}/${INFO_PATH}
|
||||
|
||||
post-install:
|
||||
@${FIND} ${PREFIX}/share/Yap ! -type d | \
|
||||
${SED} "s,^${PREFIX},," >> ${TMPPLIST}
|
||||
@${FIND} ${PREFIX}/share/Yap -type d | ${SORT} -r | \
|
||||
${SED} "s,^${PREFIX},@dirrm ," >> ${TMPPLIST}
|
||||
|
||||
.include <bsd.port.post.mk>
|
|
@ -1,3 +0,0 @@
|
|||
MD5 (Yap-5.1.1.tar.gz) = 1f5c26642a27158c98f6c2fac56d3dad
|
||||
SHA256 (Yap-5.1.1.tar.gz) = cadb35cb3b7e469aa6bc6f7a819904f1f746b1e9c71f4a2af1ea254569ed522d
|
||||
SIZE (Yap-5.1.1.tar.gz) = 3429186
|
|
@ -1,11 +0,0 @@
|
|||
--- C/load_aout.c.orig Thu Sep 15 09:59:51 2005
|
||||
+++ C/load_aout.c Thu Sep 15 10:04:05 2005
|
||||
@@ -43,6 +43,8 @@
|
||||
#endif
|
||||
#include <a.out.h>
|
||||
|
||||
+#define YAP_FILE_MAX PATH_MAX
|
||||
+
|
||||
static char YapExecutable[YAP_FILE_MAX];
|
||||
|
||||
#define oktox(n) \
|
|
@ -1,7 +0,0 @@
|
|||
YAP is a high-performance Prolog compiler developed at LIACC/Universidade do
|
||||
Porto and at COPPE Sistemas/UFRJ. Its Prolog engine is based in the WAM
|
||||
(Warren Abstract Machine), with several optimizations for better performance.
|
||||
YAP follows the Edinburgh tradition, and is largely compatible with the ISO-
|
||||
Prolog standard and with Quintus and SICStus Prolog.
|
||||
|
||||
WWW: http://www.ncc.up.pt/~vsc/Yap/
|
|
@ -1,17 +0,0 @@
|
|||
bin/yap
|
||||
include/Yap/YapInterface.h
|
||||
include/Yap/c_interface.h
|
||||
include/Yap/yap_structs.h
|
||||
@dirrm include/Yap
|
||||
lib/Yap/random.so
|
||||
lib/Yap/regcomp.so
|
||||
lib/Yap/regerror.so
|
||||
lib/Yap/regexec.so
|
||||
lib/Yap/regexp.so
|
||||
lib/Yap/regfree.so
|
||||
lib/Yap/startup
|
||||
lib/Yap/sys.so
|
||||
lib/Yap/yap2swi.so
|
||||
lib/Yap/yap_tries.so
|
||||
lib/libYap.a
|
||||
@dirrm lib/Yap
|
|
@ -161,7 +161,6 @@
|
|||
SUBDIR += inplace
|
||||
SUBDIR += instant-server
|
||||
SUBDIR += instant-tinderbox
|
||||
SUBDIR += instant-workstation
|
||||
SUBDIR += ipbt
|
||||
SUBDIR += iselect
|
||||
SUBDIR += iso-codes
|
||||
|
|
|
@ -1,59 +0,0 @@
|
|||
# New ports collection makefile for: instant-workstation
|
||||
# Date created: 12 February 2001
|
||||
# Whom: grog
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= instant-workstation
|
||||
PORTVERSION= 1.1
|
||||
PORTREVISION= 6
|
||||
CATEGORIES= misc
|
||||
MASTER_SITES= ftp://ftp.lemis.com/pub/
|
||||
|
||||
MAINTAINER= ports@FreeBSD.org
|
||||
COMMENT= Instant workstation installs a typical set of ports for a workstation
|
||||
|
||||
BROKEN= Incomplete pkg-plist
|
||||
DEPRECATED= ${BROKEN}
|
||||
EXPIRATION_DATE=2006-12-01
|
||||
|
||||
USE_GHOSTSCRIPT_RUN= yes
|
||||
|
||||
RUN_DEPENDS= acroread7:${PORTSDIR}/print/acroread7 \
|
||||
bash:${PORTSDIR}/shells/bash2 \
|
||||
cdrecord:${PORTSDIR}/sysutils/cdrtools \
|
||||
dos2unix:${PORTSDIR}/converters/unix2dos \
|
||||
emacs:${PORTSDIR}/editors/emacs \
|
||||
fetchmail:${PORTSDIR}/mail/fetchmail \
|
||||
grip:${PORTSDIR}/audio/grip \
|
||||
gimp:${PORTSDIR}/graphics/gimp1 \
|
||||
gv:${PORTSDIR}/print/gv \
|
||||
gpgv:${PORTSDIR}/security/gnupg1 \
|
||||
ispell:${PORTSDIR}/textproc/ispell \
|
||||
startkde:${PORTSDIR}/x11/kde3 \
|
||||
mutt:${PORTSDIR}/mail/mutt \
|
||||
mozilla:${PORTSDIR}/www/mozilla \
|
||||
${LOCALBASE}/sbin/postfix:${PORTSDIR}/mail/postfix \
|
||||
xtset:${PORTSDIR}/x11/xtset \
|
||||
xmms:${PORTSDIR}/multimedia/xmms \
|
||||
xv:${PORTSDIR}/graphics/xv
|
||||
|
||||
NO_WRKSUBDIR= YES
|
||||
NO_BUILD= YES
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
.if ${OSVERSION} <= 440002
|
||||
RUN_DEPENDS+= mount_smbfs:${PORTSDIR}/net/smbfs
|
||||
.endif
|
||||
|
||||
pre-everything::
|
||||
.if !defined(WITH_GHOSTSCRIPT_AFPL) || ${WITH_GHOSTSCRIPT_AFPL} != yes
|
||||
@${ECHO} ""
|
||||
@${ECHO} " Define WITH_GHOSTSCRIPT_AFPL=yes to use"
|
||||
@${ECHO} " AFPL Postscript interpreter instead of GNU one"
|
||||
@${ECHO} ""
|
||||
.endif
|
||||
|
||||
.include <bsd.port.post.mk>
|
|
@ -1,3 +0,0 @@
|
|||
MD5 (instant-workstation-1.1.tar.gz) = e8af09fe5b3a097171da825c94398c2a
|
||||
SHA256 (instant-workstation-1.1.tar.gz) = e27e4e0f058c92256a92d7abc9c5231259e5506f4019b05a5b50c1cf7da962c5
|
||||
SIZE (instant-workstation-1.1.tar.gz) = 9969
|
|
@ -1 +0,0 @@
|
|||
Instant workstation installs a typical set of ports for a workstation.
|
|
@ -1,8 +0,0 @@
|
|||
share/abbreviations
|
||||
share/dot.bashrc
|
||||
share/dot.muttrc
|
||||
share/dot.bash_profile
|
||||
etc/mailcap
|
||||
etc/instant-workstation/ntp.conf
|
||||
etc/instant-workstation/rc.conf
|
||||
@dirrm etc/instant-workstation
|
Loading…
Reference in a new issue