devel/py-pytest: Update to 2.8.7
- Update PORTVERSION and distinfo checksum (2.8.7) - Remove nose from TEST_DEPENDS (only mentioned in tox.ini) - Patch setup.py not to install version-suffixed console_scripts - Enable "concurrent" Python installation accordingly - Remove USES=zip, DISTFILES is now a tarball Changes: http://pytest.org/latest/changelog.html
This commit is contained in:
parent
90e622d893
commit
01529e80fd
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=409652
3 changed files with 18 additions and 6 deletions
|
@ -1,7 +1,7 @@
|
|||
# $FreeBSD$
|
||||
|
||||
PORTNAME= pytest
|
||||
PORTVERSION= 2.8.5
|
||||
PORTVERSION= 2.8.7
|
||||
CATEGORIES= devel python
|
||||
MASTER_SITES= CHEESESHOP
|
||||
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
|
||||
|
@ -14,12 +14,11 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
|
|||
|
||||
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}py>=1.4.29:${PORTSDIR}/devel/py-py
|
||||
TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}mock>0:${PORTSDIR}/devel/py-mock \
|
||||
${PYTHON_PKGNAMEPREFIX}nose>0:${PORTSDIR}/devel/py-nose \
|
||||
${PYTHON_PKGNAMEPREFIX}pexpect>0:${PORTSDIR}/misc/py-pexpect \
|
||||
${PYTHON_PKGNAMEPREFIX}pytest-xdist>=1.13:${PORTSDIR}/devel/py-pytest-xdist
|
||||
|
||||
USES= python zip
|
||||
USE_PYTHON= autoplist distutils
|
||||
USES= python
|
||||
USE_PYTHON= autoplist concurrent distutils
|
||||
|
||||
NO_ARCH= yes
|
||||
|
||||
|
|
|
@ -1,2 +1,2 @@
|
|||
SHA256 (pytest-2.8.5.zip) = 44bb32fb3925b5a284ceee1af55e0a63d25436ec415232089403eed3a347667e
|
||||
SIZE (pytest-2.8.5.zip) = 664063
|
||||
SHA256 (pytest-2.8.7.tar.gz) = fc4c86be54fce08e4b85b646a736efa18c6cde7599c1d2919f4f74629e018baf
|
||||
SIZE (pytest-2.8.7.tar.gz) = 564943
|
||||
|
|
13
devel/py-pytest/files/patch-setup.py
Normal file
13
devel/py-pytest/files/patch-setup.py
Normal file
|
@ -0,0 +1,13 @@
|
|||
--- setup.py.orig 2016-02-27 05:10:48 UTC
|
||||
+++ setup.py
|
||||
@@ -69,7 +69,9 @@ def main():
|
||||
platforms=['unix', 'linux', 'osx', 'cygwin', 'win32'],
|
||||
author='Holger Krekel, Bruno Oliveira, Ronny Pfannschmidt, Floris Bruynooghe, Brianna Laugher, Florian Bruhin and others',
|
||||
author_email='holger at merlinux.eu',
|
||||
- entry_points=make_entry_points(),
|
||||
+ entry_points= {
|
||||
+ 'console_scripts': ['py.test=pytest:main'],
|
||||
+ },
|
||||
classifiers=classifiers,
|
||||
cmdclass={'test': PyTest},
|
||||
# the following should be enabled for release
|
Loading…
Reference in a new issue