x11/antimicro: Remove expired port
2023-10-01 x11/antimicro: Replaced by x11/antimicrox upstream no longer maintained
This commit is contained in:
parent
836119fc88
commit
01607ea1ec
8 changed files with 1 additions and 102 deletions
1
MOVED
1
MOVED
|
@ -7927,3 +7927,4 @@ databases/percona57-pam-for-mysql||2023-10-01|Has expired: Upstream EOL reaches
|
|||
databases/percona57-server||2023-10-01|Has expired: Upstream EOL reaches on 2023-10-01
|
||||
databases/percona57-client||2023-10-01|Has expired: Upstream EOL reaches on 2023-10-01
|
||||
sysutils/nfs-over-tls||2023-10-01|Has expired: All supported releases of FreeBSD include this in base
|
||||
x11/antimicro|x11/antimicrox|2023-10-01|Has expired: Replaced by x11/antimicrox upstream no longer maintained
|
||||
|
|
|
@ -9,7 +9,6 @@
|
|||
SUBDIR += albert
|
||||
SUBDIR += alttab
|
||||
SUBDIR += aminal
|
||||
SUBDIR += antimicro
|
||||
SUBDIR += antimicrox
|
||||
SUBDIR += appmenu-registrar
|
||||
SUBDIR += appres
|
||||
|
|
|
@ -1,28 +0,0 @@
|
|||
PORTNAME= antimicro
|
||||
PORTVERSION= 2.23
|
||||
PORTREVISION= 3
|
||||
CATEGORIES= x11
|
||||
|
||||
MAINTAINER= ports@FreeBSD.org
|
||||
COMMENT= Program for mapping keyboard and mouse to a gamepad
|
||||
WWW= https://github.com/AntiMicro/antimicro
|
||||
|
||||
LICENSE= GPLv3
|
||||
|
||||
DEPRECATED= Replaced by x11/antimicrox upstream no longer maintained
|
||||
EXPIRATION_DATE= 2023-10-01
|
||||
|
||||
USES= cmake compiler:c++11-lang desktop-file-utils pkgconfig \
|
||||
qt:5 sdl shared-mime-info xorg
|
||||
USE_GITHUB= yes
|
||||
GH_ACCOUNT= antimicro #Ryochan7
|
||||
USE_QT= core gui linguisttools:build qmake:build buildtools:build widgets network
|
||||
USE_SDL= sdl2
|
||||
USE_XORG= x11 xi xtst
|
||||
|
||||
# Upstream assumes ${LOCALBASE}/lib is part of the default linker path. Pull
|
||||
# request 268 fixes it for X11 libraries, but SDL2 is still using pkg-config
|
||||
# output (without full paths).
|
||||
LDFLAGS+= -L${LOCALBASE}/lib
|
||||
|
||||
.include <bsd.port.mk>
|
|
@ -1,3 +0,0 @@
|
|||
TIMESTAMP = 1484123767
|
||||
SHA256 (antimicro-antimicro-2.23_GH0.tar.gz) = ef309170612da805992f9194f1973bf38a3174a0856856afedab67f9d927a9ef
|
||||
SIZE (antimicro-antimicro-2.23_GH0.tar.gz) = 1157299
|
|
@ -1,36 +0,0 @@
|
|||
Submitted upstream: https://github.com/AntiMicro/antimicro/pull/207
|
||||
|
||||
From e5d2c880ac336bc9ff558c43fe5ed7d47df28bbe Mon Sep 17 00:00:00 2001
|
||||
From: Raphael Kubo da Costa <rakuco@FreeBSD.org>
|
||||
Date: Mon, 29 Jan 2018 12:19:55 +0100
|
||||
Subject: [PATCH] cmake: Stop calling QT5_WRAP_CPP().
|
||||
|
||||
The USE_QT5 code path already unconditionally sets CMAKE_AUTOMOC to on.
|
||||
|
||||
Calling QT5_WRAP_CPP() used to be just redundant, as antimicro_HEADERS_MOC
|
||||
was never actually added as a source dependency of the antiword target. In
|
||||
other words, CMake's own automoc infrastructure was actually being used and
|
||||
the moc invocations from QT5_WRAP_CPP() were not being made at all.
|
||||
|
||||
Starting with Qt 5.9.4, calling QT5_WRAP_CPP() disables the AUTOMOC property
|
||||
on the macro's input files, which means neither CMake's automoc
|
||||
infrastructure not QT5_WRAP_CPP()'s code were being used and we ended up
|
||||
with several 'undefined reference to vtable' errors when linking.
|
||||
--- CMakeLists.txt.orig 2016-11-06 01:23:03 UTC
|
||||
+++ CMakeLists.txt
|
||||
@@ -499,7 +499,6 @@ if (UNIX)
|
||||
find_package(Qt5Network REQUIRED)
|
||||
find_package(Qt5LinguistTools REQUIRED)
|
||||
|
||||
- QT5_WRAP_CPP(antimicro_HEADERS_MOC ${antimicro_HEADERS})
|
||||
QT5_WRAP_UI(antimicro_FORMS_HEADERS ${antimicro_FORMS})
|
||||
QT5_ADD_RESOURCES(antimicro_RESOURCES_RCC ${antimicro_RESOURCES})
|
||||
add_subdirectory("share/antimicro/translations")
|
||||
@@ -550,7 +549,6 @@ elseif(WIN32)
|
||||
find_package(Qt5Network REQUIRED)
|
||||
find_package(Qt5LinguistTools REQUIRED)
|
||||
|
||||
- QT5_WRAP_CPP(antimicro_HEADERS_MOC ${antimicro_HEADERS})
|
||||
QT5_WRAP_UI(antimicro_FORMS_HEADERS ${antimicro_FORMS})
|
||||
QT5_ADD_RESOURCES(antimicro_RESOURCES_RCC ${antimicro_RESOURCES})
|
||||
add_subdirectory("share/antimicro/translations")
|
|
@ -1,11 +0,0 @@
|
|||
--- src/mainwindow.cpp.orig 2016-11-06 01:23:03 UTC
|
||||
+++ src/mainwindow.cpp
|
||||
@@ -364,7 +364,7 @@ void MainWindow::makeJoystickTabs()
|
||||
ui->tabWidget->addTab(tabwidget, joytabName);
|
||||
}
|
||||
|
||||
- if (joysticks > 0)
|
||||
+ if (joysticks->size() > 0)
|
||||
{
|
||||
ui->tabWidget->setCurrentIndex(0);
|
||||
ui->stackedWidget->setCurrentIndex(1);
|
|
@ -1,6 +0,0 @@
|
|||
AntiMicro is a graphical program used to map keyboard keys and mouse controls
|
||||
to a gamepad. This program is useful for playing PC games using a gamepad
|
||||
that do not have any form of built-in gamepad support. However,
|
||||
you can use this program to control any desktop application with a gamepad;
|
||||
this means that your system has to be running an X environment in order to
|
||||
run this program.
|
|
@ -1,17 +0,0 @@
|
|||
bin/antimicro
|
||||
%%DATADIR%%/translations/antimicro_br.qm
|
||||
%%DATADIR%%/translations/antimicro_de.qm
|
||||
%%DATADIR%%/translations/antimicro_en.qm
|
||||
%%DATADIR%%/translations/antimicro_es.qm
|
||||
%%DATADIR%%/translations/antimicro_fr.qm
|
||||
%%DATADIR%%/translations/antimicro_it.qm
|
||||
%%DATADIR%%/translations/antimicro_ja.qm
|
||||
%%DATADIR%%/translations/antimicro_ru.qm
|
||||
%%DATADIR%%/translations/antimicro_sr.qm
|
||||
%%DATADIR%%/translations/antimicro_uk.qm
|
||||
%%DATADIR%%/translations/antimicro_zh_CN.qm
|
||||
%%DATADIR%%/translations/antimicro.qm
|
||||
share/applications/antimicro.desktop
|
||||
share/man/man1/antimicro.1.gz
|
||||
share/mime/packages/antimicro.xml
|
||||
share/pixmaps/antimicro.png
|
Loading…
Reference in a new issue