* Fix build with SDL

* Fix build on amd64

Pointy hat to:	lioux
This commit is contained in:
Kris Kennaway 2006-10-07 17:12:14 +00:00
parent 12fe66095b
commit 01840bf3b2
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=174813
2 changed files with 14 additions and 5 deletions

View file

@ -85,7 +85,7 @@ LIB_FILES= libavcodec/libavcodec.a \
.include <bsd.port.pre.mk>
.if ${ARCH} == "ia64" || ${ARCH} == "amd64"
.if ${ARCH} == "ia64"
BROKEN= Does not compile on ${ARCH}
.endif
@ -547,7 +547,7 @@ post-patch:
${CONFIGURE_WRKSRC}/${CONFIGURE_SCRIPT}
@${FIND} ${WRKSRC} -type f | \
${XARGS} -n 10 ${REINPLACE_CMD} -E \
-e 's|#include <SDL|#include <SDL11/SDL|'
-e 's|#include <SDL|#include <SDL/SDL|'
.endif
.ifndef(WITHOUT_POSTPROCESS)
@${LN} -sf libpostproc.so \
@ -570,7 +570,7 @@ post-configure:
.endif
.ifdef(WITH_DTS)
@${REINPLACE_CMD} -E \
-e 's|-ldts|${LOCALBASE}/lib/libdts.a|' \
-e 's|-ldts|${LOCALBASE}/lib/libdts_pic.a|' \
-e 's|(-lx264)|-L${LOCALBASE}/lib \1|' \
${WRKSRC}/config.mak \
${WRKSRC}/libavcodec/Makefile

View file

@ -1,5 +1,14 @@
--- configure.orig Sun Mar 19 03:31:32 2006
+++ configure Thu Mar 23 15:15:34 2006
--- configure.orig Sun Mar 19 01:31:55 2006
+++ configure Thu Sep 28 20:27:49 2006
@@ -138,7 +138,7 @@
cpu="x86"
;;
x86_64|amd64)
- cpu="x86"
+ cpu="x86_64"
canon_arch="`cc -dumpmachine | sed -e 's,\([^-]*\)-.*,\1,'`"
if [ x"$canon_arch" = x"x86_64" -o x"$canon_arch" = x"amd64" ]; then
if [ -z "`echo $CFLAGS | grep -- -m32`" ]; then
@@ -1107,6 +1107,8 @@
builtin_vector=no
if $cc -msse -o $TMPO $TMPC 2> /dev/null ; then