www/rtv: update 1.9.1 -> 1.13.0 and new maintainer
- Remove python version limit 3.3+ - Remove dependency www/py-tornado not used anymore - Add new dependencies: www/py-requests www/py-beautifulsoup devel/py-decorator devel/py-mailcap-fix devel/py-update_checker - Fix duplicate entry of dependency devel/py-six - Small change on pkg-descr (line with more than 80 characters) - Install manpage(1) properly - Set architecture neutral - Set MAINTAINER to submitter PR: 213149 Submitted by: Danilo G. Baio <dbaio@bsd.com.br>
This commit is contained in:
parent
2a11622b79
commit
0185cc3dd6
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=425610
4 changed files with 30 additions and 19 deletions
|
@ -1,31 +1,30 @@
|
|||
# $FreeBSD$
|
||||
|
||||
PORTNAME= rtv
|
||||
PORTVERSION= 1.9.1
|
||||
PORTVERSION= 1.13.0
|
||||
DISTVERSIONPREFIX= v
|
||||
CATEGORIES= www
|
||||
|
||||
MAINTAINER= ports@FreeBSD.org
|
||||
MAINTAINER= dbaio@bsd.com.br
|
||||
COMMENT= Commandline client for reddit
|
||||
|
||||
LICENSE= MIT
|
||||
LICENSE_FILE= ${WRKSRC}/LICENSE
|
||||
|
||||
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}tornado>=3.2:www/py-tornado \
|
||||
${PYTHON_PKGNAMEPREFIX}praw>=3.4.0:www/py-praw \
|
||||
${PYTHON_PKGNAMEPREFIX}six>0:devel/py-six \
|
||||
${PYTHON_PKGNAMEPREFIX}six>=1.5.2:devel/py-six \
|
||||
${PYTHON_PKGNAMEPREFIX}kitchen>=1.2.4:devel/py-kitchen
|
||||
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}praw>=3.5.0:www/py-praw \
|
||||
${PYTHON_PKGNAMEPREFIX}six>=1.10.0:devel/py-six \
|
||||
${PYTHON_PKGNAMEPREFIX}kitchen>=1.2.4:devel/py-kitchen \
|
||||
${PYTHON_PKGNAMEPREFIX}requests>=2.11.1:www/py-requests \
|
||||
${PYTHON_PKGNAMEPREFIX}beautifulsoup>=4.5.1:www/py-beautifulsoup \
|
||||
${PYTHON_PKGNAMEPREFIX}decorator>=4.0.10:devel/py-decorator \
|
||||
${PYTHON_PKGNAMEPREFIX}mailcap_fix>=0.1.3:devel/py-mailcap-fix \
|
||||
${PYTHON_PKGNAMEPREFIX}update_checker>=0.11:devel/py-update_checker
|
||||
|
||||
USE_GITHUB= yes
|
||||
GH_ACCOUNT= michael-lazar
|
||||
USES= tar:xz python:3.3+
|
||||
|
||||
NO_ARCH= yes
|
||||
USES= tar:xz python
|
||||
USE_PYTHON= distutils autoplist
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
.if defined(PACKAGE_BUILDING) && ${PYTHON_VER} != ${PYTHON_DEFAULT}
|
||||
IGNORE= you have python ${PYTHON_DEFAULT} set as the default, and this needs ${PYTHON_VER}
|
||||
.endif
|
||||
|
||||
.include <bsd.port.post.mk>
|
||||
.include <bsd.port.mk>
|
||||
|
|
|
@ -1,3 +1,3 @@
|
|||
TIMESTAMP = 1467104818
|
||||
SHA256 (michael-lazar-rtv-v1.9.1_GH0.tar.gz) = 66307483708a6dc77bf6f3c289221c8ccba4743e2f592448239c01b4989b3927
|
||||
SIZE (michael-lazar-rtv-v1.9.1_GH0.tar.gz) = 2380606
|
||||
TIMESTAMP = 1476916532
|
||||
SHA256 (michael-lazar-rtv-v1.13.0_GH0.tar.gz) = 801f8674599d4a4abb5593d3d5ac957a748d3daf06f962538a0ae717db117abd
|
||||
SIZE (michael-lazar-rtv-v1.13.0_GH0.tar.gz) = 7135223
|
||||
|
|
11
www/rtv/files/patch-setup.py
Normal file
11
www/rtv/files/patch-setup.py
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- setup.py.orig 2016-10-18 02:27:09 UTC
|
||||
+++ setup.py
|
||||
@@ -18,7 +18,7 @@ setuptools.setup(
|
||||
keywords='reddit terminal praw curses',
|
||||
packages=['rtv'],
|
||||
package_data={'rtv': ['templates/*']},
|
||||
- data_files=[("share/man/man1", ["rtv.1"])],
|
||||
+ data_files=[("man/man1", ["rtv.1"])],
|
||||
install_requires=requirements,
|
||||
entry_points={'console_scripts': ['rtv=rtv.__main__:main']},
|
||||
classifiers=[
|
|
@ -1,3 +1,4 @@
|
|||
Reddit Terminal Viewer allows you to view and interact with reddit from your terminal.
|
||||
Reddit Terminal Viewer allows you to view and interact with reddit
|
||||
from your terminal.
|
||||
|
||||
WWW: https://github.com/michael-lazar/rtv
|
||||
|
|
Loading…
Reference in a new issue