Update to 5.6.0.
Move doc-files from pkg-plist to Makefile. Approved by: Ryan Thompson <ryan@sasknow.com> (maintainer)
This commit is contained in:
parent
93107187dd
commit
01a6b1fcb3
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=105848
4 changed files with 11 additions and 23 deletions
|
@ -6,8 +6,7 @@
|
|||
#
|
||||
|
||||
PORTNAME= biew
|
||||
PORTVERSION= 5.5.0
|
||||
PORTREVISION= 1
|
||||
PORTVERSION= 5.6.0
|
||||
CATEGORIES= editors
|
||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
|
||||
MASTER_SITE_SUBDIR= ${PORTNAME}
|
||||
|
@ -20,7 +19,7 @@ COMMENT= Binary vIEWer + editor for binary, hexadecimal and dis-asm modes
|
|||
USE_BZIP2= yes
|
||||
USE_GMAKE= yes
|
||||
|
||||
MYPORTDOCS= biew_en.txt biew_ru.txt develop.en develop.ru file_ini.en \
|
||||
PORTDOCS= biew_en.txt biew_ru.txt develop.en develop.ru file_ini.en \
|
||||
file_ini.ru licence.en licence.ru release.txt unix.txt
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
@ -57,7 +56,7 @@ do-install:
|
|||
${INSTALL_DATA} ${WRKSRC}/hlp/biew.hlp ${DATADIR}
|
||||
.if !defined(NOPORTDOCS)
|
||||
@ ${MKDIR} ${DOCSDIR}
|
||||
.for file in ${MYPORTDOCS}
|
||||
.for file in ${PORTDOCS}
|
||||
${INSTALL_DATA} ${WRKSRC}/doc/${file} ${DOCSDIR}
|
||||
.endfor
|
||||
.endif
|
||||
|
|
|
@ -1,2 +1,2 @@
|
|||
MD5 (biew-550.tar.bz2) = e24de24e56900b00420ee882305c9167
|
||||
SIZE (biew-550.tar.bz2) = 526883
|
||||
MD5 (biew-560.tar.bz2) = ecd5684e1c91deac21d1aa43d4e9da95
|
||||
SIZE (biew-560.tar.bz2) = 600582
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
--- biewlib/sysdep/generic/unix/keyboard.c.orig Mon Apr 29 15:26:59 2002
|
||||
+++ biewlib/sysdep/generic/unix/keyboard.c Mon Apr 29 15:28:12 2002
|
||||
@@ -41,7 +41,11 @@
|
||||
--- biewlib/sysdep/generic/unix/keyboard.c.orig Wed Mar 31 16:16:47 2004
|
||||
+++ biewlib/sysdep/generic/unix/keyboard.c Wed Mar 31 16:16:58 2004
|
||||
@@ -44,7 +44,11 @@
|
||||
#endif
|
||||
|
||||
#ifdef _CURSES_
|
||||
|
@ -9,6 +9,6 @@
|
|||
+#else
|
||||
#include <curses.h>
|
||||
+#endif
|
||||
#if defined(NCURSES_MOUSE_VERSION) && !defined(HAVE_MOUSE)
|
||||
#define HAVE_MOUSE
|
||||
#endif
|
||||
char *rawkb_name="Curses";
|
||||
unsigned rawkb_size=sizeof(int); /* size of rawkb_buf elements 1,2 or 4*/
|
||||
int rawkb_method=0;
|
||||
|
|
|
@ -4,15 +4,4 @@ share/biew/biew.hlp
|
|||
share/biew/golded.skn
|
||||
share/biew/insight.skn
|
||||
share/biew/standard.skn
|
||||
%%PORTDOCS%%share/doc/biew/biew_en.txt
|
||||
%%PORTDOCS%%share/doc/biew/biew_ru.txt
|
||||
%%PORTDOCS%%share/doc/biew/develop.en
|
||||
%%PORTDOCS%%share/doc/biew/develop.ru
|
||||
%%PORTDOCS%%share/doc/biew/file_ini.en
|
||||
%%PORTDOCS%%share/doc/biew/file_ini.ru
|
||||
%%PORTDOCS%%share/doc/biew/licence.en
|
||||
%%PORTDOCS%%share/doc/biew/licence.ru
|
||||
%%PORTDOCS%%share/doc/biew/release.txt
|
||||
%%PORTDOCS%%share/doc/biew/unix.txt
|
||||
%%PORTDOCS%%@dirrm share/doc/biew
|
||||
@dirrm share/biew
|
||||
|
|
Loading…
Reference in a new issue